aboutsummaryrefslogtreecommitdiff
path: root/security/ipsec-tools
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2019-05-12 13:22:28 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2019-05-12 13:22:28 +0000
commite917e3b2c59befd0f78bc1a3a1c34f2d29d3018a (patch)
treeb48548aa72aa7671dc7943ff0e2b60258bd42d75 /security/ipsec-tools
parent428da0e419444a027d0aafa5132107618076d46c (diff)
downloadports-e917e3b2c59befd0f78bc1a3a1c34f2d29d3018a.tar.gz
ports-e917e3b2c59befd0f78bc1a3a1c34f2d29d3018a.zip
security/ipsec-tools: autoload ipsec.ko if possible
Check for IPSEC support in kernel and auto-load ipsec.ko if needed while starting racoon except of 11.0-RELEASE that had not IPSEC as a module.
Notes
Notes: svn path=/head/; revision=501380
Diffstat (limited to 'security/ipsec-tools')
-rw-r--r--security/ipsec-tools/Makefile13
-rw-r--r--security/ipsec-tools/files/racoon.in1
2 files changed, 9 insertions, 5 deletions
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index e16034a691f8..9a55c71079f7 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -8,7 +8,7 @@
PORTNAME= ipsec-tools
PORTVERSION= 0.8.2
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= security
MASTER_SITES= SF
@@ -17,11 +17,10 @@ COMMENT= KAME racoon IKE daemon, ipsec-tools version
LICENSE= BSD3CLAUSE
-CONFLICTS= racoon-[0-9]*
+USES= libtool tar:bzip2 ssl
+CONFLICTS= racoon-[0-9]*
INSTALL_TARGET= install-strip
-
-USES= libtool tar:bzip2 ssl
USE_RC_SUBR= racoon
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
@@ -30,7 +29,7 @@ CONFIGURE_ARGS= --enable-shared --sysconfdir=${PREFIX}/etc/racoon \
--with-pkgversion=freebsd-${PORTVERSION}
STATEDIR= /var/db/racoon
-SUB_LIST+= STATEDIR=${STATEDIR}
+SUB_LIST+= STATEDIR=${STATEDIR} REQUIREMOD=${REQUIREMOD}
PLIST_SUB+= STATEDIR=${STATEDIR}
OPTIONS_DEFINE= DEBUG IPV6 ADMINPORT STATS DPD NATT NATTF FRAG HYBRID PAM \
@@ -83,6 +82,10 @@ NATT_EXTRA_PATCHES= ${FILESDIR}/natt.diff
.include <bsd.port.pre.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1100510
+REQUIREMOD?= ipsec
+.endif
+
# Need to be patched for openssl-1.1.1 (default after 1200080)
.if ${OPSYS} == FreeBSD
. if ${OSVERSION} >= 1200085 && ${SSL_DEFAULT} != openssl
diff --git a/security/ipsec-tools/files/racoon.in b/security/ipsec-tools/files/racoon.in
index 1ab85061fcfa..007c55b6e2aa 100644
--- a/security/ipsec-tools/files/racoon.in
+++ b/security/ipsec-tools/files/racoon.in
@@ -33,6 +33,7 @@ stop_postcmd="${name}_cleanup"
socketfile="%%STATEDIR%%/${name}.sock"
required_files="%%PREFIX%%/etc/${name}/${name}.conf"
required_dirs="%%STATEDIR%%"
+required_modules="%%REQUIREMOD%%"
racoon_cleanup()
{