aboutsummaryrefslogtreecommitdiff
path: root/security/isakmpd
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-30 06:16:41 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-30 06:16:41 +0000
commit23cbcaeccce81cf47a53efb6bc7bce5de77a5fbf (patch)
treeca8066c5841bb504238764db35684740b86afaaf /security/isakmpd
parentf4ef5a2dc8b21293fca22a5bb348cee34d196d03 (diff)
downloadports-23cbcaeccce81cf47a53efb6bc7bce5de77a5fbf.tar.gz
ports-23cbcaeccce81cf47a53efb6bc7bce5de77a5fbf.zip
update security/isakmpd: Enable use of keynote
PR: 43892 Submitted by: Daniel C. Sobral <dcs@tcoip.com.br>
Notes
Notes: svn path=/head/; revision=85895
Diffstat (limited to 'security/isakmpd')
-rw-r--r--security/isakmpd/Makefile5
-rw-r--r--security/isakmpd/files/patch-ab10
2 files changed, 15 insertions, 0 deletions
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
index 88cbde6de2b2..00bdcfce18b3 100644
--- a/security/isakmpd/Makefile
+++ b/security/isakmpd/Makefile
@@ -22,6 +22,11 @@ COMMENT= OpenBSD IKE daemon
BROKEN= "requires IPsec support"
.endif
+# If keynote is in use, bring the dependency
+.if defined(USE_KEYNOTE)
+BUILD_DEPENDS+= keynote:${PORTSDIR}/security/keynote
+.endif
+
USE_OPENSSL= yes
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/isakmpd
diff --git a/security/isakmpd/files/patch-ab b/security/isakmpd/files/patch-ab
index 516941d79013..d60ab0e995c1 100644
--- a/security/isakmpd/files/patch-ab
+++ b/security/isakmpd/files/patch-ab
@@ -9,3 +9,13 @@
# The mkdir below is for installation on OpenBSD pre 2.7
install:
+--- Makefile.orig Wed Oct 9 17:15:53 2002
++++ Makefile Wed Oct 9 17:16:26 2002
+@@ -164,6 +164,7 @@
+ USE_LIBDES= yes
+ LDADD+= -lkeynote -lm
+ DPADD+= ${LIBKEYNOTE} ${LIBM}
++POLICY= policy.c
+ CFLAGS+= -DUSE_KEYNOTE
+ .endif
+