aboutsummaryrefslogtreecommitdiff
path: root/security/isakmpd
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-09-10 08:22:59 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-09-10 08:22:59 +0000
commit7aba119cf1e387827bfff61763ac008b2d9a70fe (patch)
treee01b2713d082bc264e7674ecb7957e4f4cd6d9ea /security/isakmpd
parentbf3a028ff1f4e1da3281fffed2fe8eb6b1661240 (diff)
downloadports-7aba119cf1e387827bfff61763ac008b2d9a70fe.tar.gz
ports-7aba119cf1e387827bfff61763ac008b2d9a70fe.zip
Notes
Diffstat (limited to 'security/isakmpd')
-rw-r--r--security/isakmpd/Makefile4
-rw-r--r--security/isakmpd/files/patch-Makefile.sysdep10
-rw-r--r--security/isakmpd/files/patch-aa13
-rw-r--r--security/isakmpd/files/patch-ab10
-rw-r--r--security/isakmpd/files/patch-conf.c9
-rw-r--r--security/isakmpd/files/patch-sa.c25
-rw-r--r--security/isakmpd/files/patch-sysdep-os.h21
-rw-r--r--security/isakmpd/pkg-plist1
8 files changed, 76 insertions, 17 deletions
diff --git a/security/isakmpd/Makefile b/security/isakmpd/Makefile
index 6f8eec259181..18b548b12a99 100644
--- a/security/isakmpd/Makefile
+++ b/security/isakmpd/Makefile
@@ -10,7 +10,7 @@
PORTNAME= isakmpd
PORTVERSION= 20021118
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_NETBSD}
MASTER_SITE_SUBDIR= LOCAL_PORTS
@@ -34,7 +34,7 @@ WRKSRC= ${WRKDIR}/isakmpd
MAKE_ENV+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man
MAN5= isakmpd.conf.5 isakmpd.policy.5
-MAN8= isakmpd.8
+MAN8= certpatch.8 isakmpd.8
MANCOMPRESSED= yes
post-patch:
diff --git a/security/isakmpd/files/patch-Makefile.sysdep b/security/isakmpd/files/patch-Makefile.sysdep
index 0560c8c85233..583385bcc6df 100644
--- a/security/isakmpd/files/patch-Makefile.sysdep
+++ b/security/isakmpd/files/patch-Makefile.sysdep
@@ -15,3 +15,13 @@ $FreeBSD$
-I${.CURDIR}/sysdep/common -I/usr/include \
-I/usr/local/include -I/usr/local/include/openssl
+@@ -60,9 +60,6 @@
+ GENERATED+= sysdep-target
+ sysdep-target:
+ cd ${.CURDIR}/sysdep/common/libsysdep; ${MAKE} ${.MAKEFLAGS}
+-
+-# Kludge around much strange behaviour in /usr/share/mk/bsd.*/mk, don't build certpatch
+-SUBDIR=
+
+ .if make(clean)
+ SUBDIR+= sysdep/common/libsysdep
diff --git a/security/isakmpd/files/patch-aa b/security/isakmpd/files/patch-aa
index c94efc2bced5..71f752585eeb 100644
--- a/security/isakmpd/files/patch-aa
+++ b/security/isakmpd/files/patch-aa
@@ -12,3 +12,16 @@
#OS= linux
#OS= bsdi
+@@ -159,6 +159,7 @@
+ USE_LIBDES= yes
+ LDADD+= -lkeynote -lm
+ DPADD+= ${LIBKEYNOTE} ${LIBM}
++POLICY= policy.c
+ CFLAGS+= -DUSE_KEYNOTE
+ .endif
+
+@@ -204,4 +205,3 @@
+ ${PROG} beforedepend: ${GENERATED}
+
+ .include <bsd.prog.mk>
+-.include <bsd.subdir.mk>
diff --git a/security/isakmpd/files/patch-ab b/security/isakmpd/files/patch-ab
index d60ab0e995c1..516941d79013 100644
--- a/security/isakmpd/files/patch-ab
+++ b/security/isakmpd/files/patch-ab
@@ -9,13 +9,3 @@
# The mkdir below is for installation on OpenBSD pre 2.7
install:
---- Makefile.orig Wed Oct 9 17:15:53 2002
-+++ Makefile Wed Oct 9 17:16:26 2002
-@@ -164,6 +164,7 @@
- USE_LIBDES= yes
- LDADD+= -lkeynote -lm
- DPADD+= ${LIBKEYNOTE} ${LIBM}
-+POLICY= policy.c
- CFLAGS+= -DUSE_KEYNOTE
- .endif
-
diff --git a/security/isakmpd/files/patch-conf.c b/security/isakmpd/files/patch-conf.c
new file mode 100644
index 000000000000..519308708fdb
--- /dev/null
+++ b/security/isakmpd/files/patch-conf.c
@@ -0,0 +1,9 @@
+--- conf.c.orig Mon Nov 18 06:58:04 2002
++++ conf.c Sat Feb 8 11:39:43 2003
+@@ -254,5 +254,5 @@
+ if (!section)
+ {
+- log_print ("conf_parse_line: %d: malloc (%d) failed", ln, i);
++ log_print ("conf_parse_line: %d: malloc (%ld) failed", ln, (long) i);
+ return;
+ }
diff --git a/security/isakmpd/files/patch-sa.c b/security/isakmpd/files/patch-sa.c
new file mode 100644
index 000000000000..95052dac11a1
--- /dev/null
+++ b/security/isakmpd/files/patch-sa.c
@@ -0,0 +1,25 @@
+--- sa.c.orig Wed Nov 13 04:31:38 2002
++++ sa.c Sat Feb 8 12:04:21 2003
+@@ -440,6 +440,6 @@
+ LOG_DBG ((cls, level, "%s: msgid %08x refcnt %d", header,
+ decode_32 (sa->message_id), sa->refcnt));
+- LOG_DBG ((cls, level, "%s: life secs %llu kb %llu", header, sa->seconds,
+- sa->kilobytes));
++ LOG_DBG ((cls, level, "%s: life secs %llu kb %llu", header, (long long unsigned) sa->seconds,
++ (long long unsigned) sa->kilobytes));
+ for (proto = TAILQ_FIRST (&sa->protos); proto;
+ proto = TAILQ_NEXT (proto, link))
+@@ -1040,5 +1040,5 @@
+ LOG_DBG ((LOG_TIMER, 95,
+ "sa_setup_expirations: SA %p soft timeout in %llu seconds",
+- sa, seconds));
++ sa, (long long unsigned) seconds));
+ expiration.tv_sec += seconds;
+ sa->soft_death
+@@ -1058,5 +1058,5 @@
+ LOG_DBG ((LOG_TIMER, 95,
+ "sa_setup_expirations: SA %p hard timeout in %llu seconds",
+- sa, sa->seconds));
++ sa, (long long unsigned) sa->seconds));
+ expiration.tv_sec += sa->seconds;
+ sa->death
diff --git a/security/isakmpd/files/patch-sysdep-os.h b/security/isakmpd/files/patch-sysdep-os.h
index 861ea6549485..5643589a3167 100644
--- a/security/isakmpd/files/patch-sysdep-os.h
+++ b/security/isakmpd/files/patch-sysdep-os.h
@@ -1,14 +1,25 @@
--- sysdep/freebsd/sysdep-os.h~ Fri Jan 25 14:55:21 2002
+++ sysdep/freebsd/sysdep-os.h Tue Nov 26 14:40:03 2002
-@@ -81,4 +81,11 @@
+@@ -56,7 +56,7 @@
+ /* FreeBSD 4.2 */
+ #define SADB_X_EALG_BLF SADB_EALG_BLOWFISHCBC
+ #define SADB_X_EALG_CAST SADB_EALG_CAST128CBC
+-#else if ( SADB_EALG_MAX == 12 )
++#elif ( SADB_EALG_MAX == 12 )
+ /* FreeBSD 4.4 */
+ #define SADB_X_EALG_BLF SADB_X_EALG_BLOWFISHCBC
+ #define SADB_X_EALG_CAST SADB_X_EALG_CAST128CBC
+@@ -79,6 +79,13 @@
+ memcpy ((o), (i), BLOCKSIZE); \
+ CAST_decrypt ((CAST_LONG *)(o), (k)); \
}
- #endif
-
++#endif
++
+#ifndef CPI_RESERVED_MAX
+#define CPI_RESERVED_MIN 1
+#define CPI_RESERVED_MAX 255
+#define CPI_PRIVATE_MIN 61440
+#define CPI_PRIVATE_MAX 65536
-+#endif
-+
+ #endif
+
#endif /* _SYSDEP_OS_H_ */
diff --git a/security/isakmpd/pkg-plist b/security/isakmpd/pkg-plist
index a9f3e8adb9c5..77e92ee33423 100644
--- a/security/isakmpd/pkg-plist
+++ b/security/isakmpd/pkg-plist
@@ -1,3 +1,4 @@
+sbin/certpatch
sbin/isakmpd
share/examples/isakmpd/VPN-3way-template.conf
share/examples/isakmpd/VPN-east.conf