aboutsummaryrefslogtreecommitdiff
path: root/security/john/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-30 18:47:13 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-06-30 18:47:13 +0000
commit19b4e169a49baa36f8d955c0315acde21104157d (patch)
tree696c55c405d050ca4ffc6418a754006f15023134 /security/john/Makefile
parent8a4e0b56f92982cd26bd6bf3ab7b42c397185adf (diff)
downloadports-19b4e169a49baa36f8d955c0315acde21104157d.tar.gz
ports-19b4e169a49baa36f8d955c0315acde21104157d.zip
Notes
Diffstat (limited to 'security/john/Makefile')
-rw-r--r--security/john/Makefile24
1 files changed, 6 insertions, 18 deletions
diff --git a/security/john/Makefile b/security/john/Makefile
index 816e7cb19459..f97574c884eb 100644
--- a/security/john/Makefile
+++ b/security/john/Makefile
@@ -1,6 +1,6 @@
-# Ports collection makefile for: john
-# Date created: Sun Mar 09, 1997
-# Whom: David O'Brien (obrien@FreeBSD.org)
+# Ports collection makefile for: John the Ripper
+# Date created: Sun Mar 09, 1997
+# Whom: David O'Brien <obrien@FreeBSD.org>
#
# $FreeBSD$
#
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.openwall.com/john/f/ \
ftp://ftp.se.openwall.com/pub/projects/john/${PORTVERSION}/ \
http://distro.ibiblio.org/pub/linux/distributions/openwall/projects/john/${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Featureful Unix password cracker
DATAFILES= all.chr alnum.chr alpha.chr digits.chr lanman.chr password.lst
@@ -28,24 +28,12 @@ CFLAGS+= -DJOHN_SYSTEMWIDE=1 \
-DJOHN_SYSTEMWIDE_HOME=\\"${DATADIR}\\" \
-DCFG_FULL_NAME=\\"${PREFIX}/etc/${PORTNAME}.conf\\"
-# workaround for OSVERSION/ARCH detection before bsd.port.pre.mk
-# (required for OPTIONS usage)
-ARCH!= /usr/bin/uname -p
-OSVERSION!= /sbin/sysctl -n kern.osreldate
-
-.if ${ARCH} == "i386"
-. if ${OSVERSION} > 500000
-OPTIONS= SSE2 "Enable SSE2 optimizations" off
-. endif
-OPTIONS+= MMX "Enable MMX optimizations" off
-.endif
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
-. if defined(WITH_SSE2)
+. if ${MACHINE_CPU:Msse2}
ALL_TARGET= ${OSNAME}-x86-sse2
-. elif defined(WITH_MMX)
+. elif ${MACHINE_CPU:Mmmx}
ALL_TARGET= ${OSNAME}-x86-mmx
. else
ALL_TARGET= ${OSNAME}-x86-any