aboutsummaryrefslogtreecommitdiff
path: root/security/john
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-01-08 11:21:17 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-01-08 11:21:17 +0000
commit1abafe5709f862e9cf2928309606b47f83fb2ddb (patch)
tree65c85babd89d8bd86ae72af9f1d3028e57256312 /security/john
parent1c88fd5a37bea5cc76e64848e6b4f3aee252fe7b (diff)
downloadports-1abafe5709f862e9cf2928309606b47f83fb2ddb.tar.gz
ports-1abafe5709f862e9cf2928309606b47f83fb2ddb.zip
- Update to version 1.7.9-jumbo-5
- Add an OPTION to build with OpenMP support (disabled by default) - Adjust `pre-build' target message to mention OpenMP support (with/without) - Fix overly aggressive CFLAGS patching via REINPLACE_CMD - Remove unneeded global modifiers from sed(1) expressions and kill one superfluous empty line while I am here
Notes
Notes: svn path=/head/; revision=288748
Diffstat (limited to 'security/john')
-rw-r--r--security/john/Makefile17
-rw-r--r--security/john/distinfo4
-rw-r--r--security/john/pkg-plist2
3 files changed, 15 insertions, 8 deletions
diff --git a/security/john/Makefile b/security/john/Makefile
index e5c76b361acf..02f504ae288a 100644
--- a/security/john/Makefile
+++ b/security/john/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= john
-DISTVERSION= 1.7.8-jumbo-8
+DISTVERSION= 1.7.9-jumbo-5
CATEGORIES= security
MASTER_SITES= http://www.openwall.com/john/g/ \
http://mirrors.kernel.org/openwall/projects/john/${DISTVERSION:C/-.*//}/ \
@@ -38,6 +38,8 @@ CFLAGS+= -DJOHN_SYSTEMWIDE=1 \
PORTDOCS= CHANGES CONFIG EXAMPLES EXTERNAL FAQ MODES OPTIONS README \
RULES CONTACT CREDITS
+OPTIONS= OPENMP "Compile with OpenMP support" off
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
@@ -61,16 +63,22 @@ BROKEN= Does not compile on sparc64
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|= gcc|= ${CC}|g' \
- -e 's|CFLAGS =.*|CFLAGS = -c ${CFLAGS}|g' \
+ @${REINPLACE_CMD} -e 's|= gcc|= ${CC}|' \
+ -e '/^CFLAGS =/s|-O2|${CFLAGS}|' ${WRKSRC}/src/Makefile
+.if defined(WITH_OPENMP)
+ @${REINPLACE_CMD} -E \
+ '/(fopenmp|-m${MACHINE_CPU:Msse2})$$/s,#(OMPFLAGS =),\1,' \
${WRKSRC}/src/Makefile
+.endif
@${REINPLACE_CMD} -i '' -e 's|/usr/bin|${LOCALBASE}/bin|' \
${WRKSRC}/run/*.rb
@${REINPLACE_CMD} -e '/_XOPEN_SOURCE/d' ${WRKSRC}/src/recovery.c
pre-build:
@${ECHO_CMD}
- @${ECHO_CMD} "Building for ${ALL_TARGET}"
+ @${ECHO_CMD} "Building John the Ripper for ${ALL_TARGET}" \
+ ${WITH_OPENMP:C/.*/with/}${WITHOUT_OPENMP:C/.*/without/} \
+ "OpenMP support"
@${ECHO_CMD}
do-install:
@@ -85,7 +93,6 @@ do-install:
.if !exists(${PREFIX}/etc/john.conf)
${INSTALL_DATA} ${WRKSRC}/run/john.conf ${PREFIX}/etc
.endif
-
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
diff --git a/security/john/distinfo b/security/john/distinfo
index 4249cd58e6c6..bd1f21894ab4 100644
--- a/security/john/distinfo
+++ b/security/john/distinfo
@@ -1,2 +1,2 @@
-SHA256 (john-1.7.8-jumbo-8.tar.bz2) = ab5aaf483b63656751bea3de767a856523e9814450bd94e386e539ec6daacd69
-SIZE (john-1.7.8-jumbo-8.tar.bz2) = 1170660
+SHA256 (john-1.7.9-jumbo-5.tar.bz2) = 4007aec40d2fedb1ce3287c62f23f8a1a8b8029d22cd3cbc60bb1a42f56c1a7f
+SIZE (john-1.7.9-jumbo-5.tar.bz2) = 1214046
diff --git a/security/john/pkg-plist b/security/john/pkg-plist
index d351052dc0f1..d710d692affa 100644
--- a/security/john/pkg-plist
+++ b/security/john/pkg-plist
@@ -21,7 +21,7 @@ etc/john.conf.default
%%DATADIR%%/netntlm.pl
%%DATADIR%%/netscreen.py
%%DATADIR%%/password.lst
-%%DATADIR%%/relbench.pl
+%%DATADIR%%/radius2john.pl
%%DATADIR%%/sap_prepare.pl
%%DATADIR%%/sha-dump.pl
%%DATADIR%%/sha-test.pl