aboutsummaryrefslogtreecommitdiff
path: root/security/john
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-12-17 17:27:12 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-12-17 17:27:12 +0000
commit72fd1ce0021531d881243e8ae2a9675a13afdd08 (patch)
tree853bd2a2c7cc1aea2007026acc2c58b1b868c052 /security/john
parentfd1bd5870443e26e8408bcf77e3f3d13a7277c5f (diff)
downloadports-72fd1ce0021531d881243e8ae2a9675a13afdd08.tar.gz
ports-72fd1ce0021531d881243e8ae2a9675a13afdd08.zip
Limit PORTSCOUT version check to -jumbo releases and explain why.
Notes
Notes: svn path=/head/; revision=287553
Diffstat (limited to 'security/john')
-rw-r--r--security/john/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/security/john/Makefile b/security/john/Makefile
index 10f902d6c571..e5c76b361acf 100644
--- a/security/john/Makefile
+++ b/security/john/Makefile
@@ -22,6 +22,14 @@ USE_BZIP2= yes
USE_GMAKE= yes
BUILD_WRKSRC= ${WRKDIR}/${DISTNAME}/src
+# We prefer -jumbo (community-enhanced) versions instead of vanilla releases
+# due to the sad fact that `-jumbo-???' suffixed versions *precede* official
+# ones per pkg_version(1) -t check. So, when Alexander rolls out new "plain"
+# release, just hold the horses and wait for corresponding -jumbo one, which
+# usually does not take too long to appear.
+#
+PORTSCOUT= limit:.*-jumbo
+
OSNAME= ${OPSYS:L}
CFLAGS+= -DJOHN_SYSTEMWIDE=1 \
-DJOHN_SYSTEMWIDE_HOME=\\"${DATADIR}\\" \