aboutsummaryrefslogtreecommitdiff
path: root/security/john
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-08 08:59:20 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-03-08 08:59:20 +0000
commite45ef3e5e0350268241ee6f04c85b5c349320dae (patch)
tree1dc0e2195bf198a3bd4f8155a2a0a359250725a2 /security/john
parente15eb98209308a2fd9099896bb5d7d3d5aff6912 (diff)
downloadports-e45ef3e5e0350268241ee6f04c85b5c349320dae.tar.gz
ports-e45ef3e5e0350268241ee6f04c85b5c349320dae.zip
Drop the raw SHA-0 format, it's unlikely anyone will ever need it.
Notes
Notes: svn path=/head/; revision=495030
Diffstat (limited to 'security/john')
-rw-r--r--security/john/Makefile3
-rw-r--r--security/john/files/patch-rawSHA0__fmt__plug.c27
2 files changed, 2 insertions, 28 deletions
diff --git a/security/john/Makefile b/security/john/Makefile
index 6ecc03ebeffd..0ba5f94c5cd0 100644
--- a/security/john/Makefile
+++ b/security/john/Makefile
@@ -59,7 +59,8 @@ OPTIONS_DEFINE= DOCS #OPENMP
#OPENMP_USES= compiler:openmp
post-extract:
- @${RM} ${WRKSRC}/pfx_fmt_plug.c ${WRKSRC}/ssh_fmt_plug.c
+ @${RM} ${WRKSRC}/pfx_fmt_plug.c ${WRKSRC}/rawSHA0_fmt_plug.c \
+ ${WRKSRC}/ssh_fmt_plug.c \
post-patch:
# Replace methods and types that were marked deprecated by OpenSSL 0.9.7
diff --git a/security/john/files/patch-rawSHA0__fmt__plug.c b/security/john/files/patch-rawSHA0__fmt__plug.c
deleted file mode 100644
index a058e163a672..000000000000
--- a/security/john/files/patch-rawSHA0__fmt__plug.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- rawSHA0_fmt_plug.c.orig 2014-09-19 16:40:51 UTC
-+++ rawSHA0_fmt_plug.c
-@@ -6,6 +6,10 @@
- * Based on Raw-SHA1, but this is OpenSSL only.
- */
-
-+#include <openssl/sha.h>
-+
-+#ifndef OPENSSL_NO_SHA0
-+
- #if FMT_EXTERNS_H
- extern struct fmt_main fmt_rawSHA_0;
- #elif FMT_REGISTERS_H
-@@ -13,7 +17,6 @@ john_register_one(&fmt_rawSHA_0);
- #else
-
- #include <string.h>
--#include <openssl/sha.h>
-
- #include "arch.h"
- #include "misc.h"
-@@ -208,3 +211,5 @@ struct fmt_main fmt_rawSHA_0 = {
- };
-
- #endif /* plugin stanza */
-+
-+#endif /* OPENSSL_NO_SHA0 */