aboutsummaryrefslogtreecommitdiff
path: root/security/keepass
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-05-16 16:39:14 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-05-16 16:39:14 +0000
commit12942b43035c3df36115d23aa591da29268c896d (patch)
tree509b93370c0da609cdc9ff8a04c5615288367631 /security/keepass
parentb67a67f87743e47f9ceaf60848a9689b8f444aba (diff)
downloadports-12942b43035c3df36115d23aa591da29268c896d.tar.gz
ports-12942b43035c3df36115d23aa591da29268c896d.zip
Add security/keepass, the official KeePass client.
KeePass is a free open source password manager, which helps you to manage your passwords in a secure way. You can put all your passwords in one database, which is locked with one master key or a key file. So you only have to remember one single master password or select the key file to unlock the whole database. The databases are encrypted using the best and most secure encryption algorithms currently known (AES and Twofish). This is the official KeePass application, which was originally only available for Windows, but has now been re-written with .Net and able to be run on BSD, Linux and Mac OS X with Mono. WWW: http://keepass.info/ PR: 200062 Submitted by: Ben Woods
Notes
Notes: svn path=/head/; revision=386557
Diffstat (limited to 'security/keepass')
-rw-r--r--security/keepass/Makefile56
-rw-r--r--security/keepass/distinfo2
-rw-r--r--security/keepass/files/keepass.sh.in3
-rw-r--r--security/keepass/pkg-descr12
-rw-r--r--security/keepass/pkg-plist14
5 files changed, 87 insertions, 0 deletions
diff --git a/security/keepass/Makefile b/security/keepass/Makefile
new file mode 100644
index 000000000000..8d9c6b1876b6
--- /dev/null
+++ b/security/keepass/Makefile
@@ -0,0 +1,56 @@
+# Created by: Ben Woods <woodsb02@gmail.com>
+# $FreeBSD$
+
+PORTNAME= keepass
+PORTVERSION= 2.29
+CATEGORIES= security
+MASTER_SITES= SF/${PORTNAME}/KeePass%202.x/${PORTVERSION}
+DISTNAME= KeePass-${PORTVERSION}-Source
+
+MAINTAINER= woodsb02@gmail.com
+COMMENT= Light-weight and easy-to-use password manager
+
+LICENSE= GPLv2 # or later
+
+BUILD_DEPENDS= icotool:${PORTSDIR}/graphics/icoutils
+LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgdiplus.so:${PORTSDIR}/x11-toolkits/libgdiplus
+RUN_DEPENDS= xdotool:${PORTSDIR}/x11/xdotool \
+ xsel:${PORTSDIR}/x11/xsel
+
+EXTRACT_AFTER_ARGS= -d ${WRKDIR}/${DISTNAME}
+
+USES= mono zip
+INSTALLS_ICONS= yes
+SUB_FILES= ${PORTNAME}.sh
+
+DESKTOP_ENTRIES="KeePass" \
+ "${COMMENT}" \
+ "${PORTNAME}" \
+ "keepass.sh" \
+ "Utility;" \
+ true
+
+do-build:
+ # Extract icons
+ (cd ${WRKSRC} && ${LOCALBASE}/bin/icotool -x KeePass/KeePass.ico)
+ # Prepare build
+ (cd ${WRKSRC}/Build && ${SH} PrepMonoDev.sh)
+ # Do build
+ (cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${LOCALBASE}/bin/xbuild /t:KeePass /p:Configuration=Release)
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/Build/KeePass/Release/KeePass.exe ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Ext/KeePass.config.xml ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Ext/KeePass.exe.config ${STAGEDIR}${DATADIR}
+ @(cd ${WRKSRC}/Ext && ${COPYTREE_SHARE} XSL ${STAGEDIR}${DATADIR})
+.for size in 16 32 48 256
+ @${MKDIR} ${STAGEDIR}${LOCALBASE}/share/icons/hicolor/${size}x${size}/apps
+ ${INSTALL_DATA} ${WRKSRC}/KeePass_*_${size}x${size}x32.png \
+ ${STAGEDIR}${LOCALBASE}/share/icons/hicolor/${size}x${size}/apps/keepass.png
+.endfor
+
+.include <bsd.port.mk>
diff --git a/security/keepass/distinfo b/security/keepass/distinfo
new file mode 100644
index 000000000000..9194cd819fe5
--- /dev/null
+++ b/security/keepass/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KeePass-2.29-Source.zip) = b5582eb96611726a70b523c156c89dfb83ae80ce051a4f57bb0b7a6fbf023a14
+SIZE (KeePass-2.29-Source.zip) = 4762221
diff --git a/security/keepass/files/keepass.sh.in b/security/keepass/files/keepass.sh.in
new file mode 100644
index 000000000000..629c62be3f93
--- /dev/null
+++ b/security/keepass/files/keepass.sh.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec %%PREFIX%%/bin/mono %%PREFIX%%/share/keepass/KeePass.exe "$@"
diff --git a/security/keepass/pkg-descr b/security/keepass/pkg-descr
new file mode 100644
index 000000000000..de103332e695
--- /dev/null
+++ b/security/keepass/pkg-descr
@@ -0,0 +1,12 @@
+KeePass is a free open source password manager, which helps you to manage your
+passwords in a secure way. You can put all your passwords in one database, which
+is locked with one master key or a key file. So you only have to remember one
+single master password or select the key file to unlock the whole database. The
+databases are encrypted using the best and most secure encryption algorithms
+currently known (AES and Twofish).
+
+This is the official KeePass application, which was originally only available
+for Windows, but has now been re-written with .Net and able to be run on BSD,
+Linux and Mac OS X with Mono.
+
+WWW: http://keepass.info/
diff --git a/security/keepass/pkg-plist b/security/keepass/pkg-plist
new file mode 100644
index 000000000000..a9b37c7a6765
--- /dev/null
+++ b/security/keepass/pkg-plist
@@ -0,0 +1,14 @@
+bin/keepass.sh
+share/icons/hicolor/16x16/apps/keepass.png
+share/icons/hicolor/256x256/apps/keepass.png
+share/icons/hicolor/32x32/apps/keepass.png
+share/icons/hicolor/48x48/apps/keepass.png
+%%DATADIR%%/KeePass.config.xml
+%%DATADIR%%/KeePass.exe
+%%DATADIR%%/KeePass.exe.config
+%%DATADIR%%/XSL/KDBX_DetailsFull.xsl
+%%DATADIR%%/XSL/KDBX_DetailsLite.xsl
+%%DATADIR%%/XSL/KDBX_PasswordsOnly.xsl
+%%DATADIR%%/XSL/KDBX_Styles.css
+%%DATADIR%%/XSL/KDBX_Tabular.xsl
+%%DATADIR%%/XSL/TableHeader.gif