aboutsummaryrefslogtreecommitdiff
path: root/security/keepass
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2017-06-17 03:50:46 +0000
committerBen Woods <woodsb02@FreeBSD.org>2017-06-17 03:50:46 +0000
commit2d0081a08d57bcd648321dc5fae70a022b946cbc (patch)
tree34a5d9a843b4dbfe6f66e5e8821a7a13a651cc2e /security/keepass
parent8a9ce6af61514041ea9698a0c11abf84ea4d5f34 (diff)
downloadports-2d0081a08d57bcd648321dc5fae70a022b946cbc.tar.gz
ports-2d0081a08d57bcd648321dc5fae70a022b946cbc.zip
security/keepass: Update to 2.36
- Also add DEBUG option (off by default) Changes this release: http://keepass.info/news/n170609_2.36.html
Notes
Notes: svn path=/head/; revision=443731
Diffstat (limited to 'security/keepass')
-rw-r--r--security/keepass/Makefile14
-rw-r--r--security/keepass/distinfo6
-rw-r--r--security/keepass/files/patch-KeePass.sln10
-rw-r--r--security/keepass/files/patch-KeePassLib_KeePassLib.csproj8
-rw-r--r--security/keepass/files/patch-KeePass_KeePass.csproj8
-rw-r--r--security/keepass/files/patch-Translation_TrlUtil_TrlUtil.csproj8
6 files changed, 12 insertions, 42 deletions
diff --git a/security/keepass/Makefile b/security/keepass/Makefile
index c09a27f61794..72919e1b094d 100644
--- a/security/keepass/Makefile
+++ b/security/keepass/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= keepass
-PORTVERSION= 2.35
-PORTREVISION= 1
+PORTVERSION= 2.36
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/KeePass%202.x/${PORTVERSION}
DISTNAME= KeePass-${PORTVERSION}-Source
@@ -33,15 +32,20 @@ DESKTOP_ENTRIES="KeePass" \
"Utility;" \
true
-OPTIONS_DEFINE= XDOTOOL XSEL
+OPTIONS_DEFINE= DEBUG XDOTOOL XSEL
XDOTOOL_DESC= Use the xdotool utility for auto-typing passwords
XSEL_DESC= Use the xsel utility for clipboard copying
OPTIONS_DEFAULT= XDOTOOL XSEL
+DEBUG_VARS= config=Debug
+DEBUG_VARS_OFF= config=Release
XDOTOOL_RUN_DEPENDS= xdotool:x11/xdotool
XSEL_RUN_DEPENDS= xsel:x11/xsel-conrad
+post-patch:
+ ${REINPLACE_CMD} -e 's|sed\ -i|sed\ -i\ \"\"|g' ${WRKSRC}/Build/PrepMonoDev.sh
+
do-build:
# Extract icons
(cd ${WRKSRC} && ${LOCALBASE}/bin/icotool -x KeePass/KeePass.ico)
@@ -49,12 +53,12 @@ do-build:
(cd ${WRKSRC}/Build && ${SH} PrepMonoDev.sh)
# Do build
(cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ${LOCALBASE}/bin/xbuild /t:KeePass /p:Configuration=Release)
+ ${SETENV} ${MAKE_ENV} ${LOCALBASE}/bin/xbuild /t:KeePass /p:Configuration=${CONFIG})
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/Build/KeePass/Release/KeePass.exe ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/Build/KeePass/${CONFIG}/KeePass.exe ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/Ext/KeePass.config.xml ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/Ext/KeePass.exe.config ${STAGEDIR}${DATADIR}
@(cd ${WRKSRC}/Ext && ${COPYTREE_SHARE} XSL ${STAGEDIR}${DATADIR})
diff --git a/security/keepass/distinfo b/security/keepass/distinfo
index cac989060fe6..a79c5221b7eb 100644
--- a/security/keepass/distinfo
+++ b/security/keepass/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1484560184
-SHA256 (KeePass-2.35-Source.zip) = 5faad9381af2f9d808d65ee3d880ff3bca9352c7ce886fea95d54f9169e863df
-SIZE (KeePass-2.35-Source.zip) = 4840873
+TIMESTAMP = 1497668905
+SHA256 (KeePass-2.36-Source.zip) = de7e3e9d9bedab13e4d66b0ee941b2ebedaa08d8090f7cd78bd0fc019187d8c8
+SIZE (KeePass-2.36-Source.zip) = 5063221
diff --git a/security/keepass/files/patch-KeePass.sln b/security/keepass/files/patch-KeePass.sln
deleted file mode 100644
index d5a5b3f1a6ee..000000000000
--- a/security/keepass/files/patch-KeePass.sln
+++ /dev/null
@@ -1,10 +0,0 @@
---- KeePass.sln.orig 2016-01-31 12:47:41 UTC
-+++ KeePass.sln
-@@ -1,5 +1,5 @@
--Microsoft Visual Studio Solution File, Format Version 10.00
--# Visual Studio 2008
-+Microsoft Visual Studio Solution File, Format Version 12.00
-+# Visual Studio 2012
- Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "KeePassLib", "KeePassLib\KeePassLib.csproj", "{53573E4E-33CB-4FDB-8698-C95F5E40E7F3}"
- EndProject
- Project("{FAE04EC0-301F-11D3-BF4B-00C04F79EFBC}") = "KeePass", "KeePass\KeePass.csproj", "{10938016-DEE2-4A25-9A5A-8FD3444379CA}"
diff --git a/security/keepass/files/patch-KeePassLib_KeePassLib.csproj b/security/keepass/files/patch-KeePassLib_KeePassLib.csproj
deleted file mode 100644
index bd2bb43bc394..000000000000
--- a/security/keepass/files/patch-KeePassLib_KeePassLib.csproj
+++ /dev/null
@@ -1,8 +0,0 @@
---- KeePassLib/KeePassLib.csproj.orig 2015-05-25 15:16:50 UTC
-+++ KeePassLib/KeePassLib.csproj
-@@ -1,4 +1,4 @@
--<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003" ToolsVersion="3.5">
-+<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003" ToolsVersion="4.0">
- <PropertyGroup>
- <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
- <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
diff --git a/security/keepass/files/patch-KeePass_KeePass.csproj b/security/keepass/files/patch-KeePass_KeePass.csproj
deleted file mode 100644
index 24faa24190d1..000000000000
--- a/security/keepass/files/patch-KeePass_KeePass.csproj
+++ /dev/null
@@ -1,8 +0,0 @@
---- KeePass/KeePass.csproj.orig 2015-05-25 15:16:50 UTC
-+++ KeePass/KeePass.csproj
-@@ -1,4 +1,4 @@
--<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003" ToolsVersion="3.5">
-+<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003" ToolsVersion="4.0">
- <PropertyGroup>
- <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
- <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
diff --git a/security/keepass/files/patch-Translation_TrlUtil_TrlUtil.csproj b/security/keepass/files/patch-Translation_TrlUtil_TrlUtil.csproj
deleted file mode 100644
index fe710946b252..000000000000
--- a/security/keepass/files/patch-Translation_TrlUtil_TrlUtil.csproj
+++ /dev/null
@@ -1,8 +0,0 @@
---- Translation/TrlUtil/TrlUtil.csproj.orig 2015-05-25 15:16:50 UTC
-+++ Translation/TrlUtil/TrlUtil.csproj
-@@ -1,4 +1,4 @@
--<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003" ToolsVersion="3.5">
-+<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003" ToolsVersion="4.0">
- <PropertyGroup>
- <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
- <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>