aboutsummaryrefslogtreecommitdiff
path: root/security/keepassx
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2008-09-03 13:09:46 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2008-09-03 13:09:46 +0000
commit9dfc7f3d45e5e2fd5d7e7ba562b8e186eecbd121 (patch)
tree11292be4925de2f1e207cea91f93bcf4133f37f5 /security/keepassx
parent129bf63f8416f47bb81fbbd4768288036db1681c (diff)
downloadports-9dfc7f3d45e5e2fd5d7e7ba562b8e186eecbd121.tar.gz
ports-9dfc7f3d45e5e2fd5d7e7ba562b8e186eecbd121.zip
Notes
Diffstat (limited to 'security/keepassx')
-rw-r--r--security/keepassx/Makefile6
-rw-r--r--security/keepassx/distinfo6
-rw-r--r--security/keepassx/files/patch-src-src.pro21
3 files changed, 6 insertions, 27 deletions
diff --git a/security/keepassx/Makefile b/security/keepassx/Makefile
index de720f2a1758..16b38cc8bf69 100644
--- a/security/keepassx/Makefile
+++ b/security/keepassx/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= KeePassX
-PORTVERSION= 0.3.1
-PORTREVISION= 1
+PORTVERSION= 0.3.3
CATEGORIES= security
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME:L}
@@ -16,6 +15,7 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= Cross Platform Password Manager
DATADIR= ${PREFIX}/share/${PORTNAME:L}
+WRKSRC= ${WRKDIR}/${PORTNAME:L}-${PORTVERSION}
USE_QT_VER= 4
QT_COMPONENTS= qmake_build moc_build uic_build qt3support_build rcc_build \
@@ -28,6 +28,6 @@ do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} -unix PREFIX=${PREFIX} \
INCLUDEPATH+=${LOCALBASE}/include LIBS+=-L${LOCALBASE}/lib \
- keepass.pro
+ keepassx.pro
.include <bsd.port.mk>
diff --git a/security/keepassx/distinfo b/security/keepassx/distinfo
index 39fab8d77ac2..36bbd0c31c41 100644
--- a/security/keepassx/distinfo
+++ b/security/keepassx/distinfo
@@ -1,3 +1,3 @@
-MD5 (KeePassX-0.3.1.tar.gz) = 1d6ebb010e44cf2d0a635b4796498694
-SHA256 (KeePassX-0.3.1.tar.gz) = 1f37b67f64d1b8d13b9c9c51fdfe15fe1cb33d122773b12688bb5213510876d2
-SIZE (KeePassX-0.3.1.tar.gz) = 501954
+MD5 (KeePassX-0.3.3.tar.gz) = 9796b905c92e1de6f3d600a28433aeb0
+SHA256 (KeePassX-0.3.3.tar.gz) = 954bce220c9581a32f68be2693c6cfb6b81f1b534c7d5f54f118bdc46674c37e
+SIZE (KeePassX-0.3.3.tar.gz) = 536021
diff --git a/security/keepassx/files/patch-src-src.pro b/security/keepassx/files/patch-src-src.pro
deleted file mode 100644
index 54cde3355c1c..000000000000
--- a/security/keepassx/files/patch-src-src.pro
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/src.pro.orig 2008-05-09 13:23:13.000000000 -0400
-+++ src/src.pro 2008-05-09 13:34:37.000000000 -0400
-@@ -18,6 +18,7 @@
- }
-
- win32 : QMAKE_WIN32 = 1
-+freebsd-* : QMAKE_FREEBSD = 1
-
- #-------------------------------------------------------------------------------
- # Platform Specific: Unix (except MacOS X)
-@@ -49,6 +50,10 @@
- HEADERS += Application_X11.h
- }
- SOURCES += main_unix.cpp
-+ isEqual(QMAKE_FREEBSD,1){
-+ CONFIG -= precompile_header
-+ QMAKE_CXXFLAGS += -include keepassx.h
-+ }
- }
-
-