aboutsummaryrefslogtreecommitdiff
path: root/security/keepassxc/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /security/keepassxc/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'security/keepassxc/Makefile')
-rw-r--r--security/keepassxc/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/security/keepassxc/Makefile b/security/keepassxc/Makefile
index d4ac9962062a..ddde29c9dcfc 100644
--- a/security/keepassxc/Makefile
+++ b/security/keepassxc/Makefile
@@ -23,8 +23,8 @@ LIB_DEPENDS= libargon2.so:security/libargon2 \
libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error
-USES= cmake:outsource desktop-file-utils shared-mime-info tar:xz
-USE_QT5= buildtools_build concurrent core dbus gui linguisttools network \
+USES= cmake:outsource desktop-file-utils qt:5 shared-mime-info tar:xz
+USE_QT= buildtools_build concurrent core dbus gui linguisttools network \
qmake_build testlib widgets
USE_XORG= x11
USE_LDCONFIG= yes
@@ -41,7 +41,8 @@ OPTIONS_SUB= yes
AUTOTYPE_CMAKE_BOOL= WITH_XC_AUTOTYPE
AUTOTYPE_DESC= Auto-type passwords in input fields
-AUTOTYPE_USE= QT5=x11extras XORG=xi,xtst
+AUTOTYPE_USES= qt:5
+AUTOTYPE_USE= QT=x11extras XORG=xi,xtst
BROWSER_CMAKE_BOOL= WITH_XC_BROWSER
BROWSER_DESC= Browser integration with KeePassXC-Browser