aboutsummaryrefslogtreecommitdiff
path: root/security/keychain
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2012-12-17 13:29:32 +0000
committerRenato Botelho <garga@FreeBSD.org>2012-12-17 13:29:32 +0000
commit99bb2aa664d9fd1e45966903aacdebf0fbf7a21f (patch)
tree78f9737a6beaee5f86b10e4d5d0ab12ceab26bff /security/keychain
parent0086deaf3c56d87a9ce31ace5ac2729970784a1d (diff)
downloadports-99bb2aa664d9fd1e45966903aacdebf0fbf7a21f.tar.gz
ports-99bb2aa664d9fd1e45966903aacdebf0fbf7a21f.zip
- Fix WWW line
- Remove -A parameter from fetch to fix download from funtoo - Add LICENSE - Fix COMMENT - Use GENTOO macro for MASTER_SITES - Replace some hardcoded keychain by ${PORTNAME} PR: ports/173972 Submitted by: nemysis <nemysis@gmx.ch>
Notes
Notes: svn path=/head/; revision=309089
Diffstat (limited to 'security/keychain')
-rw-r--r--security/keychain/Makefile26
-rw-r--r--security/keychain/pkg-descr2
2 files changed, 14 insertions, 14 deletions
diff --git a/security/keychain/Makefile b/security/keychain/Makefile
index e97eab9a797d..60984534418c 100644
--- a/security/keychain/Makefile
+++ b/security/keychain/Makefile
@@ -5,21 +5,22 @@ PORTNAME= keychain
PORTVERSION= 2.7.1
CATEGORIES= security
MASTER_SITES= http://www.funtoo.org/archive/keychain/ \
- ${MASTER_SITE_GENTOO}
-MASTER_SITE_SUBDIR= distfiles
+ GENTOO/distfiles
MAINTAINER= garga@FreeBSD.org
-COMMENT= A user-friendly front-end to ssh-agent(1)
+COMMENT= User-friendly front-end to ssh-agent(1)
-OPTIONS_DEFINE= DOCS
+LICENSE= GPLv2
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+OPTIONS_DEFINE= DOCS
+FETCH_ARGS?= -Fpr
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5_BUILD=yes
MAN1= keychain.1
-PLIST_FILES= bin/keychain
+PLIST_FILES= bin/${PORTNAME}
PORTDOCS= ChangeLog README.rst
@@ -30,13 +31,12 @@ RUN_DEPENDS+= ssh-agent:${PORTSDIR}/security/openssh-portable
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/keychain ${PREFIX}/bin/keychain
- ${INSTALL_MAN} ${WRKSRC}/keychain.1 ${PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>
diff --git a/security/keychain/pkg-descr b/security/keychain/pkg-descr
index a626270c9028..16c08e463115 100644
--- a/security/keychain/pkg-descr
+++ b/security/keychain/pkg-descr
@@ -6,4 +6,4 @@ Please study the documentation on the keychain website carefully since
incorrect usage of this script may have certain security implications.
Author: Daniel Robbins <drobbins@funtoo.org>
-WWW: http://www.funtoo.org/en/security/keychain/intro/
+WWW: http://www.funtoo.org/wiki/Keychain