aboutsummaryrefslogtreecommitdiff
path: root/security/klee
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2020-12-14 07:24:41 +0000
committerGleb Popov <arrowd@FreeBSD.org>2020-12-14 07:24:41 +0000
commit0ae12f109b7dcfeabd05b8cd3f5c31cba60208a0 (patch)
treebd97acfeb95c29c9b461b8d9dc7ba163370f3409 /security/klee
parent1341c7e1508e3a5e8d3f85b9e19fb1604cf10ca4 (diff)
downloadports-0ae12f109b7dcfeabd05b8cd3f5c31cba60208a0.tar.gz
ports-0ae12f109b7dcfeabd05b8cd3f5c31cba60208a0.zip
security/klee: Do not build on i386, it is unsupported upstream.
While here, add BACKEND multigroup and move STP and Z3 options there.
Notes
Notes: svn path=/head/; revision=558077
Diffstat (limited to 'security/klee')
-rw-r--r--security/klee/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/klee/Makefile b/security/klee/Makefile
index 91ef006caf6f..3038c08f0c2a 100644
--- a/security/klee/Makefile
+++ b/security/klee/Makefile
@@ -11,6 +11,8 @@ COMMENT= Symbolic virtual machine built on top of LLVM
LICENSE= NCSA
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
+NOT_FOR_ARCHS= i386
+
BUILD_DEPENDS= llvm-config${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT} \
gmake:devel/gmake
# Should be a LIB_DEPEND, but hard to express in a generic manner
@@ -28,8 +30,10 @@ CMAKE_ARGS= -DLLVM_CONFIG_BINARY=${LOCALBASE}/bin/llvm-config${LLVM_DEFAULT} \
-DMAKE_BINARY=${LOCALBASE}/bin/gmake
# TODO METASMT
-OPTIONS_DEFINE= TCMALLOC Z3 STP
+OPTIONS_DEFINE= TCMALLOC
OPTIONS_DEFAULT= TCMALLOC Z3 STP
+OPTIONS_MULTI= BACKEND
+OPTIONS_MULTI_BACKEND= Z3 STP
TCMALLOC_DESC= Use tcmalloc library for memory management
TCMALLOC_CMAKE_BOOL= ENABLE_TCMALLOC