aboutsummaryrefslogtreecommitdiff
path: root/security/klee
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2020-03-08 14:25:29 +0000
committerGleb Popov <arrowd@FreeBSD.org>2020-03-08 14:25:29 +0000
commitdf906e43f3840628d96cc6dbb6deba4a71874186 (patch)
tree55e67f8b5c662743b5b246924d4260a0d7c95470 /security/klee
parent17e77c6b827f79496a9e1ab63c91ee63196019f8 (diff)
downloadports-df906e43f3840628d96cc6dbb6deba4a71874186.tar.gz
ports-df906e43f3840628d96cc6dbb6deba4a71874186.zip
security/klee: Update to 2.1. Enable STP by default.
Notes
Notes: svn path=/head/; revision=528037
Diffstat (limited to 'security/klee')
-rw-r--r--security/klee/Makefile25
-rw-r--r--security/klee/distinfo6
-rw-r--r--security/klee/files/patch-CMakeLists.txt11
-rw-r--r--security/klee/files/patch-cmake_find__stp.cmake11
-rw-r--r--security/klee/files/patch-lib_Core_Executor.cpp11
-rw-r--r--security/klee/pkg-plist1
6 files changed, 12 insertions, 53 deletions
diff --git a/security/klee/Makefile b/security/klee/Makefile
index cdd4ffb9629e..4ae838002039 100644
--- a/security/klee/Makefile
+++ b/security/klee/Makefile
@@ -2,8 +2,7 @@
PORTNAME= klee
DISTVERSIONPREFIX= v
-DISTVERSION= 2.0
-PORTREVISION= 1
+DISTVERSION= 2.1
CATEGORIES= security devel
MAINTAINER= arrowd@FreeBSD.org
@@ -19,7 +18,7 @@ RUN_DEPENDS= llvm-config${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT} \
${PYTHON_PKGNAMEPREFIX}tabulate>0:devel/py-tabulate@${PY_FLAVOR}
USES= cmake compiler:c++14-lang localbase pkgconfig python:3.5+,run \
- shebangfix
+ shebangfix sqlite
USE_GITHUB= yes
SHEBANG_FILES= tools/klee-stats/klee-stats tools/ktest-tool/ktest-tool
USE_LDCONFIG= yes
@@ -28,30 +27,22 @@ CMAKE_OFF= ENABLE_POSIX_RUNTIME ENABLE_UNIT_TESTS ENABLE_SYSTEM_TESTS
CMAKE_ARGS= -DLLVM_CONFIG_BINARY=${LOCALBASE}/bin/llvm-config${LLVM_DEFAULT} \
-DMAKE_BINARY=${LOCALBASE}/bin/gmake
-OPTIONS_DEFINE= TCMALLOC
-OPTIONS_SINGLE= SOLVER
-OPTIONS_SINGLE_SOLVER= Z3 STP # TODO METASMT
-OPTIONS_DEFAULT= TCMALLOC Z3
-SOLVER_DESC= Solver: Use the
+# TODO METASMT
+OPTIONS_DEFINE= TCMALLOC Z3 STP
+OPTIONS_DEFAULT= TCMALLOC Z3 STP
TCMALLOC_DESC= Use tcmalloc library for memory management
TCMALLOC_CMAKE_BOOL= ENABLE_TCMALLOC
TCMALLOC_LIB_DEPENDS= libtcmalloc.so:devel/google-perftools
-Z3_DESC= Z3 SMT solver
+Z3_DESC= Enable Z3 SMT solver
Z3_CMAKE_BOOL= ENABLE_SOLVER_Z3
Z3_BUILD_DEPENDS= z3:math/z3
Z3_RUN_DEPENDS= z3:math/z3
-STP_DESC= STP SMT solver
+STP_DESC= Enable STP SMT solver
STP_CMAKE_BOOL= ENABLE_SOLVER_STP
-STP_CMAKE_ON= -DFREEBSD_STP_STATIC_LIBRARY:STRING=${LOCALBASE}/lib/libstp.a
STP_BUILD_DEPENDS= stp>0:math/stp
-
-.include <bsd.port.options.mk>
-
-.if ${LLVM_DEFAULT:S,-devel,990,} >= 90
-LLVM_DEFAULT= 80
-.endif
+STP_LIB_DEPENDS= libcryptominisat5.so:math/cryptominisat
.include <bsd.port.mk>
diff --git a/security/klee/distinfo b/security/klee/distinfo
index c96b29e4f8c2..f71a445fa37b 100644
--- a/security/klee/distinfo
+++ b/security/klee/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1553122599
-SHA256 (klee-klee-v2.0_GH0.tar.gz) = e1680086a3a2b0c22ef0b48737b75a897ab1d17e116690f04a940ac07eebc86b
-SIZE (klee-klee-v2.0_GH0.tar.gz) = 1023318
+TIMESTAMP = 1583304181
+SHA256 (klee-klee-v2.1_GH0.tar.gz) = bb3db767a159b42611e56367480a1fbfb12783c8920902d57a2b26422036a8fe
+SIZE (klee-klee-v2.1_GH0.tar.gz) = 1038275
diff --git a/security/klee/files/patch-CMakeLists.txt b/security/klee/files/patch-CMakeLists.txt
deleted file mode 100644
index afb02bad8af5..000000000000
--- a/security/klee/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMakeLists.txt.orig 2018-07-12 22:25:49 UTC
-+++ CMakeLists.txt
-@@ -412,7 +412,7 @@ endif()
- ################################################################################
- # Detect libcap
- ################################################################################
--check_include_file("sys/capability.h" HAVE_SYS_CAPABILITY_H)
-+#check_include_file("sys/capability.h" HAVE_SYS_CAPABILITY_H)
- if (HAVE_SYS_CAPABILITY_H)
- find_library(LIBCAP_LIBRARIES
- NAMES cap
diff --git a/security/klee/files/patch-cmake_find__stp.cmake b/security/klee/files/patch-cmake_find__stp.cmake
deleted file mode 100644
index 44bbac989400..000000000000
--- a/security/klee/files/patch-cmake_find__stp.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake/find_stp.cmake.orig 2018-07-12 22:25:49 UTC
-+++ cmake/find_stp.cmake
-@@ -13,6 +13,8 @@
- # is displayed in `ccmake` and `cmake-gui`.
- set(STP_DIR "" CACHE PATH "Path to directory containing STPConfig.cmake")
- find_package(STP CONFIG)
-+SET(STP_STATIC_LIBRARY ${FREEBSD_STP_STATIC_LIBRARY})
-+MESSAGE("YURI STP_STATIC_LIBRARY=${STP_STATIC_LIBRARY}")
-
- # Set the default so that if the following is true:
- # * STP was found
diff --git a/security/klee/files/patch-lib_Core_Executor.cpp b/security/klee/files/patch-lib_Core_Executor.cpp
deleted file mode 100644
index ed3382021528..000000000000
--- a/security/klee/files/patch-lib_Core_Executor.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Core/Executor.cpp.orig 2018-07-22 16:43:34 UTC
-+++ lib/Core/Executor.cpp
-@@ -3885,7 +3885,7 @@ void Executor::prepareForEarlyExit() {
-
- /// Returns the errno location in memory
- int *Executor::getErrnoLocation(const ExecutionState &state) const {
--#ifndef __APPLE__
-+#if !defined(__APPLE__) && !defined(__FreeBSD__)
- /* From /usr/include/errno.h: it [errno] is a per-thread variable. */
- return __errno_location();
- #else
diff --git a/security/klee/pkg-plist b/security/klee/pkg-plist
index 00ca9fa3a0fe..4af69b4a4a80 100644
--- a/security/klee/pkg-plist
+++ b/security/klee/pkg-plist
@@ -2,6 +2,7 @@ bin/gen-bout
bin/gen-random-bout
bin/kleaver
bin/klee
+bin/klee-replay
bin/klee-stats
bin/ktest-tool
include/klee/klee.h