aboutsummaryrefslogtreecommitdiff
path: root/security/kleopatra
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-01-13 14:02:08 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-01-13 14:02:08 +0000
commit63ddfd119714d37cecd4c5a7a6fa899798e9f356 (patch)
treec4ea8758278cf9d4acae0d63a11afd408376d0ca /security/kleopatra
parentf26b249c17d1266aed027f5e2299100635656a1b (diff)
downloadports-63ddfd119714d37cecd4c5a7a6fa899798e9f356.tar.gz
ports-63ddfd119714d37cecd4c5a7a6fa899798e9f356.zip
Fix key management in security/kleopatra
This was reported upstream also as https://bugs.kde.org/show_bug.cgi?id=415168 there has been a patch languishing there for a long time, which I've now (re)submitted upstream. It fixes all of the reported problem: a previous patch by me in FreeBSD ports only dealt with half of them. PR: 242670 Submitted by: Andre Heinecke Reported by: Gerhard Seibert
Notes
Notes: svn path=/head/; revision=561468
Diffstat (limited to 'security/kleopatra')
-rw-r--r--security/kleopatra/Makefile1
-rw-r--r--security/kleopatra/files/patch-D2639347
2 files changed, 1 insertions, 47 deletions
diff --git a/security/kleopatra/Makefile b/security/kleopatra/Makefile
index 12844d125a7d..197dedbdd341 100644
--- a/security/kleopatra/Makefile
+++ b/security/kleopatra/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kleopatra
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= security kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/security/kleopatra/files/patch-D26393 b/security/kleopatra/files/patch-D26393
deleted file mode 100644
index 4d0192ce9e33..000000000000
--- a/security/kleopatra/files/patch-D26393
+++ /dev/null
@@ -1,47 +0,0 @@
-Submitted upstream as D26393, see also
- https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242670
- https://bugs.kde.org/show_bug.cgi?id=415168
-
-diff --git src/commands/command_p.h src/commands/command_p.h
-index d9acbaae..0a16161e 100644
---- src/commands/command_p.h
-+++ src/commands/command_p.h
-@@ -37,6 +37,7 @@
- #include "view/keylistcontroller.h"
-
- #include <Libkleo/KeyListModel>
-+#include <Libkleo/KeyRearrangeColumnsProxyModel>
-
- #include <KMessageBox>
-
-@@ -73,7 +74,7 @@ public:
- }
- KeyListModelInterface *model() const
- {
-- return view_ ? dynamic_cast<KeyListModelInterface *>(view_->model()) : nullptr;
-+ return view_ ? dynamic_cast<KeyListModelInterface *>(dynamic_cast<KeyRearrangeColumnsProxyModel*>(view_->model())) : nullptr;
- }
- KeyListController *controller() const
- {
-diff --git src/dialogs/lookupcertificatesdialog.cpp src/dialogs/lookupcertificatesdialog.cpp
-index 4f7b0246..313c4f9f 100644
---- src/dialogs/lookupcertificatesdialog.cpp
-+++ src/dialogs/lookupcertificatesdialog.cpp
-@@ -37,6 +37,8 @@
- #include "ui_lookupcertificatesdialog.h"
-
- #include <Libkleo/KeyListModel>
-+#include <Libkleo/KeyRearrangeColumnsProxyModel>
-+
- #include <KConfigGroup>
- #include <gpgme++/key.h>
-
-@@ -99,7 +101,7 @@ private:
- if (!view) {
- return std::vector<Key>();
- }
-- const auto *const model = dynamic_cast<KeyListModelInterface*>(view->model());
-+ const auto *const model = dynamic_cast<KeyListModelInterface*>(dynamic_cast<KeyRearrangeColumnsProxyModel*>(view->model()));
- Q_ASSERT(model);
- const QItemSelectionModel *const sm = view->selectionModel();
- Q_ASSERT(sm);