aboutsummaryrefslogtreecommitdiff
path: root/security/kpcli
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-07-06 00:01:37 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-07-06 00:01:37 +0000
commit678899f48bc787c78f90db06f40a2ce7f33c4d7b (patch)
treec549dd90a7a5ee1d4c06a8c6d5bbcb84d519f14e /security/kpcli
parente44029f7e2ed0d98d135a01b5c76a2f853702e2e (diff)
downloadports-678899f48bc787c78f90db06f40a2ce7f33c4d7b.tar.gz
ports-678899f48bc787c78f90db06f40a2ce7f33c4d7b.zip
add new port: security/kpcli
A command line interface (interactive shell) to work with KeePassX and KeePass 1.x database files. WWW: http://kpcli.sourceforge.net/ PR: ports/168334 Submitted by: alexander.4mail@gmail.com
Notes
Notes: svn path=/head/; revision=300537
Diffstat (limited to 'security/kpcli')
-rw-r--r--security/kpcli/Makefile46
-rw-r--r--security/kpcli/distinfo2
-rw-r--r--security/kpcli/pkg-descr4
3 files changed, 52 insertions, 0 deletions
diff --git a/security/kpcli/Makefile b/security/kpcli/Makefile
new file mode 100644
index 000000000000..c73dd5bc0673
--- /dev/null
+++ b/security/kpcli/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: kpcli
+# Date created: 25 May 2012
+# Whom: Alexander Y. Grigoryev <alexander.4mail@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= kpcli
+PORTVERSION= 1.4
+CATEGORIES= security
+MASTER_SITES= SF/kpcli/
+EXTRACT_SUFX= .pl
+
+MAINTAINER= alexander.4mail@gmail.com
+COMMENT= Command line interface to KeePassX and KeePass 1.x database files
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Crypt-Rijndael>=1.08:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ p5-Term-ReadKey>=2.30:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-Sort-Naturally>=1.02:${PORTSDIR}/textproc/p5-Sort-Naturally \
+ p5-File-KeePass>=0.03:${PORTSDIR}/security/p5-File-KeePass \
+ p5-Term-ShellUI>=0.9:${PORTSDIR}/shells/p5-Term-ShellUI \
+ p5-ReadLine-Gnu>=1.19:${PORTSDIR}/devel/p5-ReadLine-Gnu \
+ p5-Clone>=0.31:${PORTSDIR}/devel/p5-Clone
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+USE_PERL5= yes
+
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= yes
+PLIST_FILES= bin/kpcli
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}.pl ${WRKSRC}/${PORTNAME}
+
+do-build:
+ ${LOCALBASE}/bin/pod2man ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
+ ${GZIP_CMD} ${WRKSRC}/${PORTNAME}.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1.gz ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/security/kpcli/distinfo b/security/kpcli/distinfo
new file mode 100644
index 000000000000..ede7cd001c20
--- /dev/null
+++ b/security/kpcli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kpcli-1.4.pl) = 9bf8d28117fe77f7257d595df51fe27d4472abe535700a94bbf8257e35272f4b
+SIZE (kpcli-1.4.pl) = 67714
diff --git a/security/kpcli/pkg-descr b/security/kpcli/pkg-descr
new file mode 100644
index 000000000000..8ef202925bb3
--- /dev/null
+++ b/security/kpcli/pkg-descr
@@ -0,0 +1,4 @@
+A command line interface (interactive shell) to work
+with KeePassX and KeePass 1.x database files.
+
+WWW: http://kpcli.sourceforge.net/