aboutsummaryrefslogtreecommitdiff
path: root/security/krb5-115/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2017-03-14 03:09:16 +0000
committerCy Schubert <cy@FreeBSD.org>2017-03-14 03:09:16 +0000
commit39e4f6e15c3a3c9f2da129a73de3b93acf2b9574 (patch)
tree42624933d31428b8966208214499eb7a9b5b5a97 /security/krb5-115/Makefile
parentbb89fb943eb48e90207c18a1df4d68dc37599bc5 (diff)
downloadports-39e4f6e15c3a3c9f2da129a73de3b93acf2b9574.tar.gz
ports-39e4f6e15c3a3c9f2da129a73de3b93acf2b9574.zip
Notes
Diffstat (limited to 'security/krb5-115/Makefile')
-rw-r--r--security/krb5-115/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/security/krb5-115/Makefile b/security/krb5-115/Makefile
index 1c5f257d583d..9f1905488f80 100644
--- a/security/krb5-115/Makefile
+++ b/security/krb5-115/Makefile
@@ -40,7 +40,7 @@ CPE_PRODUCT= kerberos
OPTIONS_DEFINE= KRB5_PDF KRB5_HTML DNS_FOR_REALM LDAP
OPTIONS_DEFAULT= KRB5_PDF KRB5_HTML READLINE
OPTIONS_RADIO= CMD_LINE_EDITING
-OPTIONS_RADIO_CMD_LINE_EDITING= READLINE LIBEDIT
+OPTIONS_RADIO_CMD_LINE_EDITING= READLINE READLINE_PORT LIBEDIT
KRB5_PDF_DESC= Install krb5 PDF documentation
KRB5_HTML_DESC= Install krb5 HTML documentation
DNS_FOR_REALM_DESC= Enable DNS lookups for Kerberos realm names
@@ -48,6 +48,9 @@ DNS_FOR_REALM_CONFIGURE_ENABLE= dns-for-realm
LDAP= Enable LDAP support
LDAP_USE= OPENLDAP=yes
LDAP_CONFIGURE_WITH= ldap
+READLINE_USES= readline
+READLINE_PORT_DESC= Command line editing via devel/readline
+READLINE_PORT_USES= readline:port
LIBEDIT_USES= libedit
LIBEDIT_CONFIGURE_WITH= libedit
@@ -79,8 +82,8 @@ LDFLAGS:= -Wl,-rpath,${_RPATH}${F:S/-Wl,-rpath,//} \
BROKEN= LIB_DEPENDS when using KRB5_HOME is broken
.endif
-.if ${PORT_OPTIONS:MREADLINE}
-USES+= readline
+# OPTIONS helper causes conflicting with/without
+.if ${PORT_OPTIONS:MREADLINE} || ${PORT_OPTIONS:MREADLINE_PORT}
CONFIGURE_ARGS+= --with-readline
.else
CONFIGURE_ARGS+= --without-readline