aboutsummaryrefslogtreecommitdiff
path: root/security/lasso
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-07-25 07:18:22 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-07-25 07:18:22 +0000
commit9b79dc3cb4e2e60d298e6b46355527b2ad8c3a5d (patch)
tree6ce8446e1e3a0a44614bac28a08f29bd6594a59c /security/lasso
parent51828b217a8d0a7d4d47e437467ce38204b70f0b (diff)
downloadports-9b79dc3cb4e2e60d298e6b46355527b2ad8c3a5d.tar.gz
ports-9b79dc3cb4e2e60d298e6b46355527b2ad8c3a5d.zip
Lasso is a free software C library aiming to implement the Liberty
Alliance standards; it defines processes for federated identities, single sign-on and related protocols. Lasso is built on top of libxml2, XMLSec and OpenSSL and is licensed under the GNU General Public License (with an OpenSSL exception). WWW: http://lasso.entrouvert.org/ PR: ports/114639 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=196250
Diffstat (limited to 'security/lasso')
-rw-r--r--security/lasso/Makefile62
-rw-r--r--security/lasso/distinfo3
-rw-r--r--security/lasso/files/patch-configure61
-rw-r--r--security/lasso/pkg-descr7
-rw-r--r--security/lasso/pkg-plist158
5 files changed, 291 insertions, 0 deletions
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
new file mode 100644
index 000000000000..6eaab3f56b36
--- /dev/null
+++ b/security/lasso/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: lasso
+# Date created: 2007-07-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lasso
+PORTVERSION= 2.0.0
+CATEGORIES= security
+MASTER_SITES= http://labs.libre-entreprise.org/frs/download.php/520/
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Free Liberty Alliance Implementation
+
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= xmlsec1:${PORTSDIR}/security/xmlsec1
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+CONFIGURE_ARGS+= --disable-java --disable-php4 --with-zlib
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack glib20
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+USE_PYTHON= yes
+
+.ifdef(WITH_PERL)
+CONFIGURE_ARGS+= --enable-perl
+PLIST_SUB+= WITH_PERL=""
+USE_PERL5= yes
+.else
+CONFIGURE_ARGS+= --disable-perl
+PLIST_SUB+= WITH_PERL="@comment "
+.endif
+
+#.ifdef(WITH_PHP5)
+#CONFIGURE_ARGS+= --enable-php5 \
+# --with-php5-config="${LOCALBASE}/bin/php-config" \
+# --with-php5-extension-dir="${PREFIX}/lib/php/${PHP_EXT_DIR}"
+#IGNORE_WITH_PHP= 4
+#PLIST_SUB+= WITH_PHP5=""
+#USE_PHP= yes
+#.else
+CONFIGURE_ARGS+= --disable-php5
+PLIST_SUB+= WITH_PHP5="@comment "
+#.endif
+
+.ifdef(WITH_PYTHON)
+CONFIGURE_ARGS+= --enable-python
+PLIST_SUB+= WITH_PYTHON=""
+.else
+CONFIGURE_ARGS+= --disable-python
+PLIST_SUB+= WITH_PYTHON="@comment "
+.endif
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal.pod
+.ifdef(NOPORTDOCS)
+ ${RM} -rf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/lasso/distinfo b/security/lasso/distinfo
new file mode 100644
index 000000000000..3d4300cbec96
--- /dev/null
+++ b/security/lasso/distinfo
@@ -0,0 +1,3 @@
+MD5 (lasso-2.0.0.tar.gz) = 7a93c35ad3560cfdff2f88e265e37d05
+SHA256 (lasso-2.0.0.tar.gz) = a67ec142880e5c43386881e6d07a07c91d19133706be8b37ba9f94348230f51c
+SIZE (lasso-2.0.0.tar.gz) = 1652083
diff --git a/security/lasso/files/patch-configure b/security/lasso/files/patch-configure
new file mode 100644
index 000000000000..183308e4dcc8
--- /dev/null
+++ b/security/lasso/files/patch-configure
@@ -0,0 +1,61 @@
+--- configure.orig Mon Jul 16 17:17:17 2007
++++ configure Mon Jul 16 17:18:09 2007
+@@ -22477,12 +22477,12 @@
+ pkg_cv_LASSO_CFLAGS="$LASSO_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6 openssl\"") >&5
+- ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6 openssl") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6\"") >&5
++ ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_LASSO_CFLAGS=`$PKG_CONFIG --cflags "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6 openssl" 2>/dev/null`
++ pkg_cv_LASSO_CFLAGS=`$PKG_CONFIG --cflags "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -22495,12 +22495,12 @@
+ pkg_cv_LASSO_LIBS="$LASSO_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6 openssl\"") >&5
+- ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6 openssl") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6\"") >&5
++ ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_LASSO_LIBS=`$PKG_CONFIG --libs "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6 openssl" 2>/dev/null`
++ pkg_cv_LASSO_LIBS=`$PKG_CONFIG --libs "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -22519,14 +22519,14 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- LASSO_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6 openssl"`
++ LASSO_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6"`
+ else
+- LASSO_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6 openssl"`
++ LASSO_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6"`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$LASSO_PKG_ERRORS" >&5
+
+- { { echo "$as_me:$LINENO: error: Package requirements (glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6 openssl) were not met:
++ { { echo "$as_me:$LINENO: error: Package requirements (glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6) were not met:
+
+ $LASSO_PKG_ERRORS
+
+@@ -22537,7 +22537,7 @@
+ and LASSO_LIBS to avoid the need to call pkg-config.
+ See the pkg-config man page for more details.
+ " >&5
+-echo "$as_me: error: Package requirements (glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6 openssl) were not met:
++echo "$as_me: error: Package requirements (glib-2.0 >= 2.4.0 gobject-2.0 >= 2.4.0 libxml-2.0 libxslt xmlsec1 >= 1.2.6 xmlsec1-openssl >= 1.2.6) were not met:
+
+ $LASSO_PKG_ERRORS
+
diff --git a/security/lasso/pkg-descr b/security/lasso/pkg-descr
new file mode 100644
index 000000000000..0104612c3e4e
--- /dev/null
+++ b/security/lasso/pkg-descr
@@ -0,0 +1,7 @@
+Lasso is a free software C library aiming to implement the Liberty
+Alliance standards; it defines processes for federated identities,
+single sign-on and related protocols. Lasso is built on top of
+libxml2, XMLSec and OpenSSL and is licensed under the GNU General
+Public License (with an OpenSSL exception).
+
+WWW: http://lasso.entrouvert.org/
diff --git a/security/lasso/pkg-plist b/security/lasso/pkg-plist
new file mode 100644
index 000000000000..c7bee4327594
--- /dev/null
+++ b/security/lasso/pkg-plist
@@ -0,0 +1,158 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/book.rst
+%%PORTDOCS%%%%DOCSDIR%%/common-knowledge.rst
+%%PORTDOCS%%%%DOCSDIR%%/getting-lasso.rst
+%%PORTDOCS%%%%DOCSDIR%%/integration.rst
+%%PORTDOCS%%%%DOCSDIR%%/language-bindings.rst
+%%PORTDOCS%%%%DOCSDIR%%/lasso-architecture.rst
+%%PORTDOCS%%%%DOCSDIR%%/liberty-architecture.rst
+%%PORTDOCS%%%%DOCSDIR%%/other-profiles.rst
+%%PORTDOCS%%%%DOCSDIR%%/preface.rst
+%%PORTDOCS%%%%DOCSDIR%%/single-sign-on.rst
+%%PORTDOCS%%%%DOCSDIR%%/writing-a-c-sp.txt
+%%PORTDOCS%%%%DOCSDIR%%/writing-a-java-sp.txt
+%%PORTDOCS%%%%DOCSDIR%%/writing-a-php-sp.txt
+%%PORTDOCS%%%%DOCSDIR%%/writing-a-saml2-php-sp.txt
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/lasso/.packlist
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/lasso/lasso.bs
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/lasso/lasso.so
+%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/lasso.pm
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/_lasso.a
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/_lasso.la
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/_lasso.so
+%%WITH_PYTHON%%%%PYTHON_SITELIBDIR%%/lasso.py
+include/lasso/errors.h
+include/lasso/export.h
+include/lasso/id-ff/defederation.h
+include/lasso/id-ff/federation.h
+include/lasso/id-ff/identity.h
+include/lasso/id-ff/lecp.h
+include/lasso/id-ff/login.h
+include/lasso/id-ff/logout.h
+include/lasso/id-ff/name_identifier_mapping.h
+include/lasso/id-ff/name_registration.h
+include/lasso/id-ff/profile.h
+include/lasso/id-ff/provider.h
+include/lasso/id-ff/server.h
+include/lasso/id-ff/session.h
+include/lasso/lasso.h
+include/lasso/lasso_config.h
+include/lasso/saml-2.0/ecp.h
+include/lasso/saml-2.0/name_id_management.h
+include/lasso/saml-2.0/profile.h
+include/lasso/xml/ds_key_info.h
+include/lasso/xml/ds_key_value.h
+include/lasso/xml/ds_rsa_key_value.h
+include/lasso/xml/lib_assertion.h
+include/lasso/xml/lib_authentication_statement.h
+include/lasso/xml/lib_authn_context.h
+include/lasso/xml/lib_authn_request.h
+include/lasso/xml/lib_authn_request_envelope.h
+include/lasso/xml/lib_authn_response.h
+include/lasso/xml/lib_authn_response_envelope.h
+include/lasso/xml/lib_federation_termination_notification.h
+include/lasso/xml/lib_idp_entries.h
+include/lasso/xml/lib_idp_entry.h
+include/lasso/xml/lib_idp_list.h
+include/lasso/xml/lib_logout_request.h
+include/lasso/xml/lib_logout_response.h
+include/lasso/xml/lib_name_identifier_mapping_request.h
+include/lasso/xml/lib_name_identifier_mapping_response.h
+include/lasso/xml/lib_register_name_identifier_request.h
+include/lasso/xml/lib_register_name_identifier_response.h
+include/lasso/xml/lib_request_authn_context.h
+include/lasso/xml/lib_scoping.h
+include/lasso/xml/lib_status_response.h
+include/lasso/xml/lib_subject.h
+include/lasso/xml/saml-2.0/saml2_action.h
+include/lasso/xml/saml-2.0/saml2_advice.h
+include/lasso/xml/saml-2.0/saml2_assertion.h
+include/lasso/xml/saml-2.0/saml2_attribute.h
+include/lasso/xml/saml-2.0/saml2_attribute_statement.h
+include/lasso/xml/saml-2.0/saml2_audience_restriction.h
+include/lasso/xml/saml-2.0/saml2_authn_context.h
+include/lasso/xml/saml-2.0/saml2_authn_statement.h
+include/lasso/xml/saml-2.0/saml2_authz_decision_statement.h
+include/lasso/xml/saml-2.0/saml2_base_idabstract.h
+include/lasso/xml/saml-2.0/saml2_condition_abstract.h
+include/lasso/xml/saml-2.0/saml2_conditions.h
+include/lasso/xml/saml-2.0/saml2_encrypted_element.h
+include/lasso/xml/saml-2.0/saml2_evidence.h
+include/lasso/xml/saml-2.0/saml2_key_info_confirmation_data.h
+include/lasso/xml/saml-2.0/saml2_name_id.h
+include/lasso/xml/saml-2.0/saml2_one_time_use.h
+include/lasso/xml/saml-2.0/saml2_proxy_restriction.h
+include/lasso/xml/saml-2.0/saml2_statement_abstract.h
+include/lasso/xml/saml-2.0/saml2_subject.h
+include/lasso/xml/saml-2.0/saml2_subject_confirmation.h
+include/lasso/xml/saml-2.0/saml2_subject_confirmation_data.h
+include/lasso/xml/saml-2.0/saml2_subject_locality.h
+include/lasso/xml/saml-2.0/samlp2_artifact_resolve.h
+include/lasso/xml/saml-2.0/samlp2_artifact_response.h
+include/lasso/xml/saml-2.0/samlp2_assertion_idrequest.h
+include/lasso/xml/saml-2.0/samlp2_attribute_query.h
+include/lasso/xml/saml-2.0/samlp2_authn_query.h
+include/lasso/xml/saml-2.0/samlp2_authn_request.h
+include/lasso/xml/saml-2.0/samlp2_authz_decision_query.h
+include/lasso/xml/saml-2.0/samlp2_extensions.h
+include/lasso/xml/saml-2.0/samlp2_idp_entry.h
+include/lasso/xml/saml-2.0/samlp2_idp_list.h
+include/lasso/xml/saml-2.0/samlp2_logout_request.h
+include/lasso/xml/saml-2.0/samlp2_logout_response.h
+include/lasso/xml/saml-2.0/samlp2_manage_name_id_request.h
+include/lasso/xml/saml-2.0/samlp2_manage_name_id_response.h
+include/lasso/xml/saml-2.0/samlp2_name_id_mapping_request.h
+include/lasso/xml/saml-2.0/samlp2_name_id_mapping_response.h
+include/lasso/xml/saml-2.0/samlp2_name_id_policy.h
+include/lasso/xml/saml-2.0/samlp2_request_abstract.h
+include/lasso/xml/saml-2.0/samlp2_requested_authn_context.h
+include/lasso/xml/saml-2.0/samlp2_response.h
+include/lasso/xml/saml-2.0/samlp2_scoping.h
+include/lasso/xml/saml-2.0/samlp2_status.h
+include/lasso/xml/saml-2.0/samlp2_status_code.h
+include/lasso/xml/saml-2.0/samlp2_status_detail.h
+include/lasso/xml/saml-2.0/samlp2_status_response.h
+include/lasso/xml/saml-2.0/samlp2_subject_query_abstract.h
+include/lasso/xml/saml-2.0/samlp2_terminate.h
+include/lasso/xml/saml_advice.h
+include/lasso/xml/saml_assertion.h
+include/lasso/xml/saml_attribute.h
+include/lasso/xml/saml_attribute_designator.h
+include/lasso/xml/saml_attribute_statement.h
+include/lasso/xml/saml_attribute_value.h
+include/lasso/xml/saml_audience_restriction_condition.h
+include/lasso/xml/saml_authentication_statement.h
+include/lasso/xml/saml_authority_binding.h
+include/lasso/xml/saml_condition_abstract.h
+include/lasso/xml/saml_conditions.h
+include/lasso/xml/saml_name_identifier.h
+include/lasso/xml/saml_statement_abstract.h
+include/lasso/xml/saml_subject.h
+include/lasso/xml/saml_subject_confirmation.h
+include/lasso/xml/saml_subject_locality.h
+include/lasso/xml/saml_subject_statement.h
+include/lasso/xml/saml_subject_statement_abstract.h
+include/lasso/xml/samlp_request.h
+include/lasso/xml/samlp_request_abstract.h
+include/lasso/xml/samlp_response.h
+include/lasso/xml/samlp_response_abstract.h
+include/lasso/xml/samlp_status.h
+include/lasso/xml/samlp_status_code.h
+include/lasso/xml/strings.h
+include/lasso/xml/xml.h
+lib/liblasso.a
+lib/liblasso.la
+lib/liblasso.so
+lib/liblasso.so.7
+libdata/pkgconfig/lasso.pc
+@dirrmtry libdata/pkgconfig
+@dirrmtry libdata
+@dirrmtry include/lasso/xml/saml-2.0
+@dirrmtry include/lasso/xml
+@dirrmtry include/lasso/saml-2.0
+@dirrmtry include/lasso/id-wsf
+@dirrmtry include/lasso/id-ff
+@dirrmtry include/lasso
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/lasso
+%%WITH_PERL%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/lasso
+%%PORTDOCS%%@dirrm %%DOCSDIR%%