aboutsummaryrefslogtreecommitdiff
path: root/security/libargon2
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-07-12 08:46:21 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-07-12 08:46:21 +0000
commitdbdf0b1ecb59bbc7ad64ebcb7d926752b8cf12a7 (patch)
tree9719e722f9f810b6e94e125e2efcade07e6dd5de /security/libargon2
parentca37aeeebebd5cac9d5574e860bf41915400b14e (diff)
downloadports-dbdf0b1ecb59bbc7ad64ebcb7d926752b8cf12a7.tar.gz
ports-dbdf0b1ecb59bbc7ad64ebcb7d926752b8cf12a7.zip
security/libargon2: add new port
PR: 209411 Submitted by: Christopher Hall <christopherhall.hsw@gmail.com> Reviewed by: Yonas Yanfa, Vladimir Krstulja Argon2 is a password-hashing function that summarizes the state of the art in the design of memory-hard functions and can be used to hash passwords for credential storage, key derivation, or other applications. https://github.com/P-H-C/phc-winner-argon2
Notes
Notes: svn path=/head/; revision=418416
Diffstat (limited to 'security/libargon2')
-rw-r--r--security/libargon2/Makefile28
-rw-r--r--security/libargon2/distinfo2
-rw-r--r--security/libargon2/pkg-descr6
-rw-r--r--security/libargon2/pkg-plist5
4 files changed, 41 insertions, 0 deletions
diff --git a/security/libargon2/Makefile b/security/libargon2/Makefile
new file mode 100644
index 000000000000..782416a860a9
--- /dev/null
+++ b/security/libargon2/Makefile
@@ -0,0 +1,28 @@
+# Created by: Christopher Hall <hsw@bitmark.com>
+# $FreeBSD$
+
+PORTNAME= libargon2
+PORTVERSION= 20160530
+CATEGORIES= security devel
+
+MAINTAINER= hsw@bitmark.com
+COMMENT= Memory hard password hashing program and library
+
+LICENSE= CC0-1.0
+
+USE_GITHUB= yes
+GH_ACCOUNT= P-H-C
+GH_PROJECT= phc-winner-argon2
+GH_TAGNAME= 4625cc5
+
+USES= gmake
+USE_LDCONFIG= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/include/argon2.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_LIB} ${WRKSRC}/libargon2.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/libargon2.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/argon2 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/argon2.1 ${STAGEDIR}${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/security/libargon2/distinfo b/security/libargon2/distinfo
new file mode 100644
index 000000000000..8cae3d216943
--- /dev/null
+++ b/security/libargon2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (P-H-C-phc-winner-argon2-20160530-4625cc5_GH0.tar.gz) = 14e0a5107e2d868de7ecdfbd0ad7ff5c46fa2a8f8eaf4c9c4f10fde7d1d8d77e
+SIZE (P-H-C-phc-winner-argon2-20160530-4625cc5_GH0.tar.gz) = 1162095
diff --git a/security/libargon2/pkg-descr b/security/libargon2/pkg-descr
new file mode 100644
index 000000000000..70d0f78816d5
--- /dev/null
+++ b/security/libargon2/pkg-descr
@@ -0,0 +1,6 @@
+Argon2 is a password-hashing function that summarizes the state of the
+art in the design of memory-hard functions and can be used to hash
+passwords for credential storage, key derivation, or other
+applications.
+
+WWW: https://github.com/P-H-C/phc-winner-argon2
diff --git a/security/libargon2/pkg-plist b/security/libargon2/pkg-plist
new file mode 100644
index 000000000000..f1e40cd2043e
--- /dev/null
+++ b/security/libargon2/pkg-plist
@@ -0,0 +1,5 @@
+bin/argon2
+include/argon2.h
+lib/libargon2.a
+lib/libargon2.so
+man/man1/argon2.1.gz