aboutsummaryrefslogtreecommitdiff
path: root/security/libdecaf
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2018-01-10 07:39:30 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2018-01-10 07:39:30 +0000
commit5ab137d6d2c12fc71ac248b40d1385d9580084cf (patch)
tree0488647d7f89dbc75204215d5ddc3d4d8595a82a /security/libdecaf
parent72a7ccc6a5f8f2b21e2896e484afd088a8bce6ac (diff)
downloadports-5ab137d6d2c12fc71ac248b40d1385d9580084cf.tar.gz
ports-5ab137d6d2c12fc71ac248b40d1385d9580084cf.zip
- Remove explicit -march=native declaration.
- Mark ONLY_FOR_ARCHS=amd64 (it is temporary only until I'm ready with proper configure and Makefiles to set ARCH_FOR_p448=arch_ref64 ARCH_FOR_p25519=arch_ref64 for aarch64 instead of arch_x86_64 and arch_32 for i386) - Manually install headers (until we've proper build system in upstream as well)
Notes
Notes: svn path=/head/; revision=458613
Diffstat (limited to 'security/libdecaf')
-rw-r--r--security/libdecaf/Makefile8
-rw-r--r--security/libdecaf/files/patch-Makefile15
-rw-r--r--security/libdecaf/pkg-plist23
3 files changed, 40 insertions, 6 deletions
diff --git a/security/libdecaf/Makefile b/security/libdecaf/Makefile
index e56ab4ce35d2..05b19cd19e01 100644
--- a/security/libdecaf/Makefile
+++ b/security/libdecaf/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libdecaf
PORTVERSION= 0.9.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/ed448goldilocks/
@@ -11,19 +12,20 @@ COMMENT= Implementation of elliptic curve cryptography
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+ONLY_FOR_ARCHS= amd64
+
USES= gmake python:2.7 tar:tgz
USE_LDCONFIG= yes
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/ristretto bin/shakesum \
- lib/libdecaf.so lib/libdecaf.so.1
-
post-patch:
@${REINPLACE_CMD} -e 's|PYTHON ?= python|PYTHON ?= ${PYTHON_CMD}|g' \
${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/build/bin/* ${STAGEDIR}${PREFIX}/bin/
+ ${CP} -R ${WRKSRC}/src/GENERATED/include/* ${STAGEDIR}${PREFIX}/include/
${INSTALL_LIB} ${WRKSRC}/build/lib/* ${STAGEDIR}${PREFIX}/lib/
.include <bsd.port.mk>
diff --git a/security/libdecaf/files/patch-Makefile b/security/libdecaf/files/patch-Makefile
index 8c544618d62b..04ef90deb59a 100644
--- a/security/libdecaf/files/patch-Makefile
+++ b/security/libdecaf/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2018-01-08 13:58:29 UTC
+--- Makefile.orig 2017-10-16 23:18:47 UTC
+++ Makefile
@@ -19,7 +19,7 @@ BUILD_IBIN = build/obj/bin
@@ -9,7 +9,16 @@
CC = clang
CXX = clang++
else
-@@ -97,14 +97,14 @@ scan: clean
+@@ -49,8 +49,6 @@ endif
+
+ TODAY = $(shell date "+%Y-%m-%d")
+
+-ARCHFLAGS ?= -march=native
+-
+ ifeq ($(CC),clang)
+ WARNFLAGS_C += -Wgcc-compat
+ endif
+@@ -97,14 +95,14 @@ scan: clean
# Internal test programs, which are not part of the final build/bin directory.
$(BUILD_IBIN)/test: $(BUILD_OBJ)/test_decaf.o lib
@@ -26,7 +35,7 @@
$(LDXX) $(LDFLAGS) -o $@ $< -L$(BUILD_LIB) -ldecaf
else
$(LDXX) $(LDFLAGS) -Wl,-rpath,`pwd`/$(BUILD_LIB) -o $@ $< -L$(BUILD_LIB) -ldecaf
-@@ -112,14 +112,14 @@ endif
+@@ -112,14 +110,14 @@ endif
# Internal test programs, which are not part of the final build/bin directory.
$(BUILD_IBIN)/test_ct: $(BUILD_OBJ)/test_ct.o lib
diff --git a/security/libdecaf/pkg-plist b/security/libdecaf/pkg-plist
new file mode 100644
index 000000000000..64dcbc1c58b2
--- /dev/null
+++ b/security/libdecaf/pkg-plist
@@ -0,0 +1,23 @@
+bin/ristretto
+bin/shakesum
+include/decaf.h
+include/decaf.hxx
+include/decaf/common.h
+include/decaf/ed255.h
+include/decaf/ed255.hxx
+include/decaf/ed448.h
+include/decaf/ed448.hxx
+include/decaf/eddsa.hxx
+include/decaf/point_255.h
+include/decaf/point_255.hxx
+include/decaf/point_448.h
+include/decaf/point_448.hxx
+include/decaf/secure_buffer.hxx
+include/decaf/sha512.h
+include/decaf/sha512.hxx
+include/decaf/shake.h
+include/decaf/shake.hxx
+include/decaf/spongerng.h
+include/decaf/spongerng.hxx
+lib/libdecaf.so
+lib/libdecaf.so.1