aboutsummaryrefslogtreecommitdiff
path: root/security/libfprint
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-06 17:59:31 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-06 17:59:31 +0000
commitb2a96c6df1c8809216eced623ec37a8372b3216e (patch)
tree0c994bc87e8a2f221a7e2be76b9aafc16eab32bb /security/libfprint
parent87b685f5d4325ba771e96b0ef49c71f903fb3ae0 (diff)
downloadports-b2a96c6df1c8809216eced623ec37a8372b3216e.tar.gz
ports-b2a96c6df1c8809216eced623ec37a8372b3216e.zip
- Remove conditional checks for FreeBSD 5.x and older
Notes
Notes: svn path=/head/; revision=225335
Diffstat (limited to 'security/libfprint')
-rw-r--r--security/libfprint/Makefile8
-rw-r--r--security/libfprint/files/extra-patch-FreeBSD531
2 files changed, 1 insertions, 38 deletions
diff --git a/security/libfprint/Makefile b/security/libfprint/Makefile
index cb4afe40aaca..ae0cbee54b81 100644
--- a/security/libfprint/Makefile
+++ b/security/libfprint/Makefile
@@ -24,14 +24,8 @@ USE_LDCONFIG= yes
USE_OPENSSL= yes
USE_GNOME= glib20 pkgconfig
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-FreeBSD5
-.endif
-
CONFIGURE_ENV+= CRYPTO_CFLAGS=-I${OPENSSLINC} \
CRYPTO_LIBS=-lcrypto \
CFLAGS="${CFLAGS} -DHAVE_MEMMEM"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/libfprint/files/extra-patch-FreeBSD5 b/security/libfprint/files/extra-patch-FreeBSD5
deleted file mode 100644
index f804d8d4643d..000000000000
--- a/security/libfprint/files/extra-patch-FreeBSD5
+++ /dev/null
@@ -1,31 +0,0 @@
---- libfprint/drivers/upekts.c.orig 2008-04-29 22:04:53.000000000 +0200
-+++ libfprint/drivers/upekts.c 2008-04-29 22:11:18.000000000 +0200
-@@ -35,6 +35,8 @@
-
- #include <fp_internal.h>
-
-+#include "libfprint/errno_compat.h"
-+
- #define EP_IN (1 | USB_ENDPOINT_IN)
- #define EP_OUT (2 | USB_ENDPOINT_OUT)
- #define TIMEOUT 5000
---- libfprint/drivers/uru4000.c.orig 2008-04-29 22:04:44.000000000 +0200
-+++ libfprint/drivers/uru4000.c 2008-04-29 22:11:33.000000000 +0200
-@@ -28,6 +28,8 @@
-
- #include <fp_internal.h>
-
-+#include "libfprint/errno_compat.h"
-+
- #define EP_INTR (1 | USB_ENDPOINT_IN)
- #define EP_DATA (2 | USB_ENDPOINT_IN)
- #define USB_RQ 0x04
---- libfprint/errno_compat.h.orig 2008-04-29 22:30:31.550769000 +0200
-+++ libfprint/errno_compat.h 2008-04-29 22:30:31.550769000 +0200
-@@ -0,0 +1,6 @@
-+#ifndef _ERRNO_COMPAT_H_
-+#define _ERRNO_COMPAT_H_
-+
-+#define EPROTO 92
-+
-+#endif /* _ERRNO_COMPAT_H_ */