aboutsummaryrefslogtreecommitdiff
path: root/security/libfprint
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-03-09 17:15:43 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-03-09 17:15:43 +0000
commitf5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa (patch)
tree343e91600b9cf81ffb94bf71017b43a88bfcbf45 /security/libfprint
parente9e0ba8df0a817712eab81d4a962e79cae35dca1 (diff)
downloadports-f5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa.tar.gz
ports-f5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Notes
Notes: svn path=/head/; revision=229765
Diffstat (limited to 'security/libfprint')
-rw-r--r--security/libfprint/Makefile13
-rw-r--r--security/libfprint/files/extra-patch-usb118
-rw-r--r--security/libfprint/files/patch-libfprint_data.c10
3 files changed, 138 insertions, 3 deletions
diff --git a/security/libfprint/Makefile b/security/libfprint/Makefile
index ae0cbee54b81..0b80daddb5dc 100644
--- a/security/libfprint/Makefile
+++ b/security/libfprint/Makefile
@@ -15,8 +15,7 @@ MASTER_SITE_SUBDIR= fprint
MAINTAINER= barner@FreeBSD.org
COMMENT= Library for fingerprint reader devices
-LIB_DEPENDS+= Magick:${PORTSDIR}/graphics/ImageMagick \
- usb:${PORTSDIR}/devel/libusb
+LIB_DEPENDS+= Magick:${PORTSDIR}/graphics/ImageMagick
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -28,4 +27,12 @@ CONFIGURE_ENV+= CRYPTO_CFLAGS=-I${OPENSSLINC} \
CRYPTO_LIBS=-lcrypto \
CFLAGS="${CFLAGS} -DHAVE_MEMMEM"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-usb
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/libfprint/files/extra-patch-usb b/security/libfprint/files/extra-patch-usb
new file mode 100644
index 000000000000..dc14e7864090
--- /dev/null
+++ b/security/libfprint/files/extra-patch-usb
@@ -0,0 +1,118 @@
+--- configure.orig 2008-03-20 16:57:56.000000000 +0300
++++ configure 2009-03-07 23:40:53.000000000 +0300
+@@ -20182,113 +20182,10 @@
+ { echo "$as_me:$LINENO: checking for LIBUSB" >&5
+ echo $ECHO_N "checking for LIBUSB... $ECHO_C" >&6; }
+
+-if test -n "$PKG_CONFIG"; then
+- if test -n "$LIBUSB_CFLAGS"; then
+- pkg_cv_LIBUSB_CFLAGS="$LIBUSB_CFLAGS"
+- else
+- if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\"libusb\"\"") >&5
+- ($PKG_CONFIG --exists --print-errors ""libusb"") 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; then
+- pkg_cv_LIBUSB_CFLAGS=`$PKG_CONFIG --cflags ""libusb"" 2>/dev/null`
+-else
+- pkg_failed=yes
+-fi
+- fi
+-else
+- pkg_failed=untried
+-fi
+-if test -n "$PKG_CONFIG"; then
+- if test -n "$LIBUSB_LIBS"; then
+- pkg_cv_LIBUSB_LIBS="$LIBUSB_LIBS"
+- else
+- if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"\"libusb\"\"") >&5
+- ($PKG_CONFIG --exists --print-errors ""libusb"") 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; then
+- pkg_cv_LIBUSB_LIBS=`$PKG_CONFIG --libs ""libusb"" 2>/dev/null`
+-else
+- pkg_failed=yes
+-fi
+- fi
+-else
+- pkg_failed=untried
+-fi
+-
+-
+-
+-if test $pkg_failed = yes; then
+-
+-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+- _pkg_short_errors_supported=yes
+-else
+- _pkg_short_errors_supported=no
+-fi
+- if test $_pkg_short_errors_supported = yes; then
+- LIBUSB_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors ""libusb""`
+- else
+- LIBUSB_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors ""libusb""`
+- fi
+- # Put the nasty error message in config.log where it belongs
+- echo "$LIBUSB_PKG_ERRORS" >&5
+-
+- { { echo "$as_me:$LINENO: error: Package requirements (\"libusb\") were not met:
+-
+-$LIBUSB_PKG_ERRORS
+-
+-Consider adjusting the PKG_CONFIG_PATH environment variable if you
+-installed software in a non-standard prefix.
+-
+-Alternatively, you may set the environment variables LIBUSB_CFLAGS
+-and LIBUSB_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details.
+-" >&5
+-echo "$as_me: error: Package requirements (\"libusb\") were not met:
+-
+-$LIBUSB_PKG_ERRORS
+-
+-Consider adjusting the PKG_CONFIG_PATH environment variable if you
+-installed software in a non-standard prefix.
+-
+-Alternatively, you may set the environment variables LIBUSB_CFLAGS
+-and LIBUSB_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-elif test $pkg_failed = untried; then
+- { { echo "$as_me:$LINENO: error: The pkg-config script could not be found or is too old. Make sure it
+-is in your PATH or set the PKG_CONFIG environment variable to the full
+-path to pkg-config.
+-
+-Alternatively, you may set the environment variables LIBUSB_CFLAGS
+-and LIBUSB_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details.
+-
+-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: The pkg-config script could not be found or is too old. Make sure it
+-is in your PATH or set the PKG_CONFIG environment variable to the full
+-path to pkg-config.
+-
+-Alternatively, you may set the environment variables LIBUSB_CFLAGS
+-and LIBUSB_LIBS to avoid the need to call pkg-config.
+-See the pkg-config man page for more details.
+-
+-To get pkg-config, see <http://pkg-config.freedesktop.org/>.
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
+-else
+- LIBUSB_CFLAGS=$pkg_cv_LIBUSB_CFLAGS
+- LIBUSB_LIBS=$pkg_cv_LIBUSB_LIBS
++ LIBUSB_CFLAGS=""
++ LIBUSB_LIBS="-lusb"
+ { echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6; }
+- :
+-fi
+-
+
+
+ # check for OpenSSL's libcrypto
diff --git a/security/libfprint/files/patch-libfprint_data.c b/security/libfprint/files/patch-libfprint_data.c
new file mode 100644
index 000000000000..9fe490c7426d
--- /dev/null
+++ b/security/libfprint/files/patch-libfprint_data.c
@@ -0,0 +1,10 @@
+--- libfprint/data.c.orig 2009-03-07 23:42:59.000000000 +0300
++++ libfprint/data.c 2009-03-07 23:43:09.000000000 +0300
+@@ -19,6 +19,7 @@
+
+ #include <config.h>
+ #include <errno.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>