aboutsummaryrefslogtreecommitdiff
path: root/security/libmcrypt
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
commit534fffca27bb18f7529d548c46ee3326505a89c7 (patch)
treea09ac440edd299d85a3517dea62caa2b115543fc /security/libmcrypt
parent5bc499ce47fa1a8da853b36cc61cddf06075d203 (diff)
downloadports-534fffca27bb18f7529d548c46ee3326505a89c7.tar.gz
ports-534fffca27bb18f7529d548c46ee3326505a89c7.zip
${PERL} -> ${REINPLACE_CMD}
PR: 40784 Submitted by: corecode@corecode.ath.cx Reviewed by: flynn@energyhq.homeip.net
Notes
Notes: svn path=/head/; revision=65426
Diffstat (limited to 'security/libmcrypt')
-rw-r--r--security/libmcrypt/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/libmcrypt/Makefile b/security/libmcrypt/Makefile
index 644f54104775..fedb83b6317d 100644
--- a/security/libmcrypt/Makefile
+++ b/security/libmcrypt/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= ltdl.1:${PORTSDIR}/devel/libtool
RESTRICTED= "yes - cryptography"
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -31,8 +32,8 @@ post-extract:
${FIND} ${WRKSRC} -name configure -exec ${RM} -f \{\} \;
pre-patch:
- @${FIND} ${WRKSRC}/modules -name '*.[ch]' | ${XARGS} ${PERL} -pi -e \
- 's|#ifdef USE_LTDL|#if defined\(USE_LTDL\) && !defined\(__FreeBSD__\)|g'
+ @${FIND} ${WRKSRC}/modules -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|#ifdef USE_LTDL|#if defined(USE_LTDL) && !defined(__FreeBSD__)|g'
post-patch:
@cd ${WRKSRC}/libltdl && ${LOCALBASE}/bin/autoconf