aboutsummaryrefslogtreecommitdiff
path: root/security/libotr
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-05-20 19:56:15 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-05-20 19:56:15 +0000
commit30b4a374e357f7344e1f15ffbce3b937f50f1e1a (patch)
tree2785d8af64ef5d7d86cee9f26333b05a1be5c6d6 /security/libotr
parent150de10167d309b32200f563de31d16536f88eb1 (diff)
downloadports-30b4a374e357f7344e1f15ffbce3b937f50f1e1a.tar.gz
ports-30b4a374e357f7344e1f15ffbce3b937f50f1e1a.zip
- Remove build dependency on pkgconf.
- USES=libtool pathfix. - Reenable -fstack-protector. There was only ever a problem on FreeBSD i386 <10 which can be fixed by adding -lssp_nonshared to LDFLAGS like Mk/bsd.ssp.mk does. Approved by: cs (maintainer)
Notes
Notes: svn path=/head/; revision=354679
Diffstat (limited to 'security/libotr')
-rw-r--r--security/libotr/Makefile27
-rw-r--r--security/libotr/pkg-plist2
2 files changed, 11 insertions, 18 deletions
diff --git a/security/libotr/Makefile b/security/libotr/Makefile
index a425a7a284f5..ce81fa0b2326 100644
--- a/security/libotr/Makefile
+++ b/security/libotr/Makefile
@@ -2,9 +2,7 @@
PORTNAME= libotr
PORTVERSION= 4.0.0
-# Please do not bump PORTREVISION for this port unless you have
-# confirmed via testing that it is necessary
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net-im net
MASTER_SITES= https://otr.cypherpunks.ca/ \
http://www.c-s.li/ports/
@@ -16,27 +14,22 @@ COMMENT= Portable OTR Messaging Library and toolkit
LICENSE= LGPL21
-BUILD_DEPENDS= pkgconf>0:${PORTSDIR}/devel/pkgconf
LIB_DEPENDS= libgpg-error.so:${PORTSDIR}/security/libgpg-error \
libgcrypt.so:${PORTSDIR}/security/libgcrypt
CONFLICTS= libotr3-*
-USE_AUTOTOOLS= autoconf libtool
+GNU_CONFIGURE= yes
+USES= libtool pathfix
USE_LDCONFIG= yes
-verify: checksum
- gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e 's#^pkgconfigdir .*#pkgconfigdir = ${PREFIX}/libdata/pkgconfig#' \
- ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.am
+.include <bsd.port.options.mk>
-.if ${OSVERSION} >= 800000 && ${OSVERSION} < 1000000
- @${REINPLACE_CMD} -e 's#OTR_CHECK_CFLAGS(.*stack-protector.*#dnl &#' \
- ${WRKSRC}/configure.ac
+.if ${OSVERSION} < 1000036 && ${ARCH} == i386
+LDFLAGS+= -lssp_nonshared
.endif
-.include <bsd.port.post.mk>
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
+.include <bsd.port.mk>
diff --git a/security/libotr/pkg-plist b/security/libotr/pkg-plist
index a255f7d36a5a..8a054b57d85e 100644
--- a/security/libotr/pkg-plist
+++ b/security/libotr/pkg-plist
@@ -21,9 +21,9 @@ include/libotr/tlv.h
include/libotr/userstate.h
include/libotr/version.h
lib/libotr.a
-lib/libotr.la
lib/libotr.so
lib/libotr.so.5
+lib/libotr.so.5.0.0
libdata/pkgconfig/libotr.pc
man/man1/otr_mackey.1.gz
man/man1/otr_modify.1.gz