aboutsummaryrefslogtreecommitdiff
path: root/security/libp11
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-06-12 16:58:38 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-06-12 16:58:38 +0000
commita8e121cb3c7c2dbd6b7b27c116df00166f546fb4 (patch)
treed436cb5d838719237c60615c7cca06d438bce3b0 /security/libp11
parent7fdb2af1ba801649b25c4e26e30165c0af968ef9 (diff)
downloadports-a8e121cb3c7c2dbd6b7b27c116df00166f546fb4.tar.gz
ports-a8e121cb3c7c2dbd6b7b27c116df00166f546fb4.zip
Libp11 is a library implementing a small layer
on top of PKCS#11 API to make using PKCS#11 implementations easier. WWW: http://www.opensc-project.org/libp11/
Notes
Notes: svn path=/head/; revision=165244
Diffstat (limited to 'security/libp11')
-rw-r--r--security/libp11/Makefile42
-rw-r--r--security/libp11/distinfo3
-rw-r--r--security/libp11/pkg-descr8
-rw-r--r--security/libp11/pkg-plist12
4 files changed, 65 insertions, 0 deletions
diff --git a/security/libp11/Makefile b/security/libp11/Makefile
new file mode 100644
index 000000000000..884de860daf0
--- /dev/null
+++ b/security/libp11/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: libp11
+# Date created: 1 Jun 2006
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libp11
+PORTVERSION= 0.2.2
+CATEGORIES= security devel
+MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A small layer on top of PKCS#11 API
+
+USE_AUTOTOOLS= libltdl:15
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack pkgconfig
+INSTALLS_SHLIB= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ OPENSSL_CFLAGS="-I${OPENSSLINC}" \
+ OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
+
+DOC_FILES= README *.sh *.xsl *.css *.html api
+
+PORTDOCS= *
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${CP} -R ${DOC_FILES} ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/libp11/distinfo b/security/libp11/distinfo
new file mode 100644
index 000000000000..77184602633d
--- /dev/null
+++ b/security/libp11/distinfo
@@ -0,0 +1,3 @@
+MD5 (libp11-0.2.2.tar.gz) = b8655b2065575eb1b96a9c924c234c63
+SHA256 (libp11-0.2.2.tar.gz) = 6593e76b815393f2a3896e163d1c23a7e0bd3eb1fabaf9795ba1bbbc4c500630
+SIZE (libp11-0.2.2.tar.gz) = 420870
diff --git a/security/libp11/pkg-descr b/security/libp11/pkg-descr
new file mode 100644
index 000000000000..37400869a51f
--- /dev/null
+++ b/security/libp11/pkg-descr
@@ -0,0 +1,8 @@
+Libp11 is a library implementing a small layer
+on top of PKCS#11 API to make using PKCS#11
+implementations easier.
+
+WWW: http://www.opensc-project.org/libp11/
+
+- Alex Dupre
+ale@FreeBSD.org
diff --git a/security/libp11/pkg-plist b/security/libp11/pkg-plist
new file mode 100644
index 000000000000..c00d5cfa9b6e
--- /dev/null
+++ b/security/libp11/pkg-plist
@@ -0,0 +1,12 @@
+include/libp11.h
+lib/libp11.a
+lib/libp11.la
+lib/libp11.so
+lib/libp11.so.1
+libdata/pkgconfig/libp11.pc
+%%EXAMPLESDIR%%/Makefile
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/auth.c
+%%EXAMPLESDIR%%/decrypt.c
+%%EXAMPLESDIR%%/getrandom.c
+@dirrm %%EXAMPLESDIR%%