aboutsummaryrefslogtreecommitdiff
path: root/security/libp11
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2014-05-13 12:21:02 +0000
committerAlex Dupre <ale@FreeBSD.org>2014-05-13 12:21:02 +0000
commitd6900751f5093e41eedf806ce282e9c87b2efd31 (patch)
tree72ba7e5ed4116b760d3ce18baa7f795b635f62a4 /security/libp11
parent0d53bced5ffd74e5ff05bb55fffa5e6b32a22311 (diff)
downloadports-d6900751f5093e41eedf806ce282e9c87b2efd31.tar.gz
ports-d6900751f5093e41eedf806ce282e9c87b2efd31.zip
Stagify.
Notes
Notes: svn path=/head/; revision=353937
Diffstat (limited to 'security/libp11')
-rw-r--r--security/libp11/Makefile26
-rw-r--r--security/libp11/pkg-descr2
-rw-r--r--security/libp11/pkg-plist2
3 files changed, 12 insertions, 18 deletions
diff --git a/security/libp11/Makefile b/security/libp11/Makefile
index e825a69bd42a..80eb0bb6254d 100644
--- a/security/libp11/Makefile
+++ b/security/libp11/Makefile
@@ -4,19 +4,19 @@
PORTNAME= libp11
PORTVERSION= 0.2.8
CATEGORIES= security devel
-MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/
+MASTER_SITES= SF/opensc/${PORTNAME}
MAINTAINER= ale@FreeBSD.org
COMMENT= Small layer on top of PKCS\#11 API
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
-USE_AUTOTOOLS= libltdl libtool
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+USE_AUTOTOOLS= libltdl
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-USES= pkgconfig
-USE_GNOME= ltverhack
+USES= libtool pkgconfig
USE_LDCONFIG= yes
CONFIGURE_ENV= LTLIB_CFLAGS="-I${LOCALBASE}/include" \
@@ -26,26 +26,20 @@ CONFIGURE_ENV= LTLIB_CFLAGS="-I${LOCALBASE}/include" \
PORTDOCS= *
-.ifndef(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+=--enable-doc
.endif
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
${WRKSRC}/configure
-.ifndef(NOPORTDOCS)
@${REINPLACE_CMD} 's|install-data-am: install-apidocDATA install-dist_docDATA|install-data-am: install-dist_docDATA|' \
${WRKSRC}/doc/Makefile.in
-.else
- @${REINPLACE_CMD} 's|install-data-am: install-dist_docDATA|install-data-am:|' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} 's|install-data-am: install-apidocDATA install-dist_docDATA|install-data-am:|' \
- ${WRKSRC}/doc/Makefile.in
-.endif
post-install:
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/security/libp11/pkg-descr b/security/libp11/pkg-descr
index fc16f64487a2..b71cf7412841 100644
--- a/security/libp11/pkg-descr
+++ b/security/libp11/pkg-descr
@@ -2,4 +2,4 @@ Libp11 is a library implementing a small layer
on top of PKCS#11 API to make using PKCS#11
implementations easier.
-WWW: http://www.opensc-project.org/libp11/
+WWW: https://github.com/OpenSC/libp11/wiki
diff --git a/security/libp11/pkg-plist b/security/libp11/pkg-plist
index 4ca0bdc6b63c..2dc9502e6454 100644
--- a/security/libp11/pkg-plist
+++ b/security/libp11/pkg-plist
@@ -1,8 +1,8 @@
include/libp11.h
lib/libp11.a
-lib/libp11.la
lib/libp11.so
lib/libp11.so.2
+lib/libp11.so.2.2.0
libdata/pkgconfig/libp11.pc
%%EXAMPLESDIR%%/Makefile
%%EXAMPLESDIR%%/README