aboutsummaryrefslogtreecommitdiff
path: root/security/libprelude
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /security/libprelude
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'security/libprelude')
-rw-r--r--security/libprelude/Makefile6
-rw-r--r--security/libprelude/pkg-plist8
2 files changed, 3 insertions, 11 deletions
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index e9184041a80e..febfdda11720 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libprelude
PORTVERSION= 1.0.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= security
MASTER_SITES= http://www.prelude-ids.org/attachments/download/241/
@@ -70,10 +70,6 @@ post-install:
${RM} ${STAGEDIR}${ETCDIR}/default/${f} # Remove files install-data-local installs
.endfor
-.if ${PORT_OPTIONS:MPERL}
- -@${RM} -f ${PREFIX}/lib/perl5/${PERL_VER}/${PERL_ARCH}/perllocal.pod
-.endif
-
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${STAGEDIR}${DOCSDIR}
diff --git a/security/libprelude/pkg-plist b/security/libprelude/pkg-plist
index 6fe2bdd7c8e9..8e69686f221d 100644
--- a/security/libprelude/pkg-plist
+++ b/security/libprelude/pkg-plist
@@ -72,10 +72,8 @@ lib/libpreludecpp.so
lib/libpreludecpp.so.0
lib/libpreludecpp.so.0.3.0
man/man1/prelude-admin.1.gz
-%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Prelude.pm
-%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude/.packlist
-%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude/Prelude.so
-%%PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/PreludeEasy/.packlist
+%%PERL%%%%SITE_ARCH%%/Prelude.pm
+%%PERL%%%%SITE_ARCH%%/auto/Prelude/Prelude.so
%%PYTHON%%%%PYTHON_SITELIBDIR%%/PreludeEasy-%%VERSION%%-py%%PYTHON_VER%%.egg-info
%%PYTHON%%%%PYTHON_SITELIBDIR%%/PreludeEasy.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/PreludeEasy.pyc
@@ -86,8 +84,6 @@ man/man1/prelude-admin.1.gz
%%PYTHON%%%%PYTHON_SITELIBDIR%%/prelude.pyc
libdata/pkgconfig/libprelude.pc
share/aclocal/libprelude.m4
-%%PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/PreludeEasy
-%%PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Prelude
@dirrm include/libprelude
@dirrmtry %%ETCDIR%%/default
@dirrmtry %%ETCDIR%%/profile