aboutsummaryrefslogtreecommitdiff
path: root/security/libpreludedb
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-10-07 04:44:48 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-10-07 04:44:48 +0000
commita65ebd957d1faeb18e86b2f73770f349c29f492e (patch)
tree7792d13c91ee053e53dc4a2ccbe96d6a0eda0d9e /security/libpreludedb
parent60476ac41fef761a0685ec4b438b9617025d8644 (diff)
downloadports-a65ebd957d1faeb18e86b2f73770f349c29f492e.tar.gz
ports-a65ebd957d1faeb18e86b2f73770f349c29f492e.zip
Convert to OptionsNG
PR: ports/172426 Submitted by: Michael Gmelin <freebsd@grem.de>
Notes
Notes: svn path=/head/; revision=305429
Diffstat (limited to 'security/libpreludedb')
-rw-r--r--security/libpreludedb/Makefile29
1 files changed, 12 insertions, 17 deletions
diff --git a/security/libpreludedb/Makefile b/security/libpreludedb/Makefile
index c0bc09496125..5810120f76c6 100644
--- a/security/libpreludedb/Makefile
+++ b/security/libpreludedb/Makefile
@@ -1,6 +1,4 @@
-# New ports collection makefile for: libpreludedb
-# Date created: 2005-10-14
-# Whom: Sergei Kolobov <sergei@FreeBSD.org>
+# Created by: Sergei Kolobov <sergei@FreeBSD.org>
# $FreeBSD$
PORTNAME= libpreludedb
@@ -23,15 +21,12 @@ USE_LDCONFIG= yes
MAN1= preludedb-admin.1
PORTDOCS= *
-OPTIONS= PERL "Include Perl bindings" off \
- PYTHON "Include Python bindings" off \
- MYSQL "Use MySQL backend" on \
- PGSQL "Use PostgreSQL backend" off \
- SQLITE "Use SQLite backend" off
+OPTIONS_DEFINE= DOCS MYSQL PERL PGSQL PYTHON SQLITE
+OPTIONS_DEFAULT=MYSQL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PERL)
+.if ${PORT_OPTIONS:MPERL}
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl
PLIST_SUB+= WITH_PERL=""
@@ -40,7 +35,7 @@ CONFIGURE_ARGS+= --without-perl
PLIST_SUB+= WITH_PERL="@comment "
.endif
-.if defined(WITH_PYTHON)
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"
CONFIGURE_ARGS+= --with-python
@@ -50,7 +45,7 @@ CONFIGURE_ARGS+= --without-python
PLIST_SUB+= WITH_PYTHON="@comment "
.endif
-.if defined(WITH_MYSQL) || exists(${LOCALBASE}/bin/mysql_config)
+.if ${PORT_OPTIONS:MMYSQL} || exists(${LOCALBASE}/bin/mysql_config)
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql
PLIST_SUB+= WITH_MYSQL=""
@@ -59,7 +54,7 @@ CONFIGURE_ARGS+= --without-mysql
PLIST_SUB+= WITH_MYSQL="@comment "
.endif
-.if defined(WITH_PGSQL) || exists(${LOCALBASE}/bin/pg_config)
+.if ${PORT_OPTIONS:MPGSQL} || exists(${LOCALBASE}/bin/pg_config)
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgresql
PLIST_SUB+= WITH_PGSQL=""
@@ -68,7 +63,7 @@ CONFIGURE_ARGS+= --without-postgresql
PLIST_SUB+= WITH_PGSQL="@comment "
.endif
-.if defined(WITH_SQLITE) || exists(${LOCALBASE}/lib/libsqlite3.so)
+.if ${PORT_OPTIONS:MSQLITE} || exists(${LOCALBASE}/lib/libsqlite3.so)
USE_SQLITE= yes
CONFIGURE_ARGS+= --with-sqlite3
PLIST_SUB+= WITH_SQLITE=""
@@ -78,16 +73,16 @@ CONFIGURE_ARGS+= --without-sqlite3
PLIST_SUB+= WITH_SQLITE="@comment "
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/api/html/* ${DOCSDIR}
.endif
@${INSTALL_MAN} ${WRKSRC}/docs/manpages/*.1 ${MAN1PREFIX}/man/man1/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>