aboutsummaryrefslogtreecommitdiff
path: root/security/libretls
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-01-17 11:37:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-01-17 11:37:24 +0000
commit1cee6275032cc8808c680dcb5c1bcb7db147a55d (patch)
treefd146e96e3a32567371fa7eb3fcffea9effd9f7e /security/libretls
parent926c3e988e042267711e15cc39e38ca64f7042cb (diff)
downloadports-1cee6275032cc8808c680dcb5c1bcb7db147a55d.tar.gz
ports-1cee6275032cc8808c680dcb5c1bcb7db147a55d.zip
LibreTLS is a port of libtls from LibreSSL to OpenSSL. libtls is "a new TLS
library, designed to make it easier to write foolproof applications". libtls provides an excellent new API, but LibreSSL can be difficult to install on systems which already use OpenSSL. LibreTLS aims to make the libtls API more easily and widely available. WWW: https://git.causal.agency/libretls/about/
Notes
Notes: svn path=/head/; revision=561811
Diffstat (limited to 'security/libretls')
-rw-r--r--security/libretls/Makefile19
-rw-r--r--security/libretls/distinfo3
-rw-r--r--security/libretls/pkg-descr8
-rw-r--r--security/libretls/pkg-plist94
4 files changed, 124 insertions, 0 deletions
diff --git a/security/libretls/Makefile b/security/libretls/Makefile
new file mode 100644
index 000000000000..80a374122fbd
--- /dev/null
+++ b/security/libretls/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= libretls
+PORTVERSION= 3.3.1
+CATEGORIES= security devel
+MASTER_SITES= https://causal.agency/libretls/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= TLS library designed to ease writing foolproff applications
+
+LICENSE= ISCL
+
+USES= libtool ssl pkgconfig
+INSTALL_TARGET= install-strip
+GNU_CONFIGURE= yes
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/security/libretls/distinfo b/security/libretls/distinfo
new file mode 100644
index 000000000000..720dc7cf380c
--- /dev/null
+++ b/security/libretls/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1610882864
+SHA256 (libretls-3.3.1.tar.gz) = f23a29ef321eff099b8fbabdecc3a3378cfb9eca24b2bf02062554e9779c4d33
+SIZE (libretls-3.3.1.tar.gz) = 431233
diff --git a/security/libretls/pkg-descr b/security/libretls/pkg-descr
new file mode 100644
index 000000000000..ec3a3cefc213
--- /dev/null
+++ b/security/libretls/pkg-descr
@@ -0,0 +1,8 @@
+LibreTLS is a port of libtls from LibreSSL to OpenSSL. libtls is "a new TLS
+library, designed to make it easier to write foolproof applications".
+
+libtls provides an excellent new API, but LibreSSL can be difficult to install
+on systems which already use OpenSSL. LibreTLS aims to make the libtls API more
+easily and widely available.
+
+WWW: https://git.causal.agency/libretls/about/
diff --git a/security/libretls/pkg-plist b/security/libretls/pkg-plist
new file mode 100644
index 000000000000..1330004caccf
--- /dev/null
+++ b/security/libretls/pkg-plist
@@ -0,0 +1,94 @@
+include/tls.h
+lib/libtls.a
+lib/libtls.so
+lib/libtls.so.20
+lib/libtls.so.20.0.1
+libdata/pkgconfig/libtls.pc
+man/man3/tls_accept_cbs.3.gz
+man/man3/tls_accept_fds.3.gz
+man/man3/tls_accept_socket.3.gz
+man/man3/tls_client.3.gz
+man/man3/tls_close.3.gz
+man/man3/tls_config_add_keypair_file.3.gz
+man/man3/tls_config_add_keypair_mem.3.gz
+man/man3/tls_config_add_keypair_ocsp_file.3.gz
+man/man3/tls_config_add_keypair_ocsp_mem.3.gz
+man/man3/tls_config_add_ticket_key.3.gz
+man/man3/tls_config_clear_keys.3.gz
+man/man3/tls_config_error.3.gz
+man/man3/tls_config_free.3.gz
+man/man3/tls_config_insecure_noverifycert.3.gz
+man/man3/tls_config_insecure_noverifyname.3.gz
+man/man3/tls_config_insecure_noverifytime.3.gz
+man/man3/tls_config_new.3.gz
+man/man3/tls_config_ocsp_require_stapling.3.gz
+man/man3/tls_config_parse_protocols.3.gz
+man/man3/tls_config_prefer_ciphers_client.3.gz
+man/man3/tls_config_prefer_ciphers_server.3.gz
+man/man3/tls_config_set_alpn.3.gz
+man/man3/tls_config_set_ca_file.3.gz
+man/man3/tls_config_set_ca_mem.3.gz
+man/man3/tls_config_set_ca_path.3.gz
+man/man3/tls_config_set_cert_file.3.gz
+man/man3/tls_config_set_cert_mem.3.gz
+man/man3/tls_config_set_ciphers.3.gz
+man/man3/tls_config_set_crl_file.3.gz
+man/man3/tls_config_set_crl_mem.3.gz
+man/man3/tls_config_set_dheparams.3.gz
+man/man3/tls_config_set_ecdhecurves.3.gz
+man/man3/tls_config_set_key_file.3.gz
+man/man3/tls_config_set_key_mem.3.gz
+man/man3/tls_config_set_keypair_file.3.gz
+man/man3/tls_config_set_keypair_mem.3.gz
+man/man3/tls_config_set_keypair_ocsp_file.3.gz
+man/man3/tls_config_set_keypair_ocsp_mem.3.gz
+man/man3/tls_config_set_ocsp_staple_file.3.gz
+man/man3/tls_config_set_ocsp_staple_mem.3.gz
+man/man3/tls_config_set_protocols.3.gz
+man/man3/tls_config_set_session_fd.3.gz
+man/man3/tls_config_set_session_id.3.gz
+man/man3/tls_config_set_session_lifetime.3.gz
+man/man3/tls_config_set_verify_depth.3.gz
+man/man3/tls_config_verify.3.gz
+man/man3/tls_config_verify_client.3.gz
+man/man3/tls_config_verify_client_optional.3.gz
+man/man3/tls_configure.3.gz
+man/man3/tls_conn_alpn_selected.3.gz
+man/man3/tls_conn_cipher.3.gz
+man/man3/tls_conn_cipher_strength.3.gz
+man/man3/tls_conn_servername.3.gz
+man/man3/tls_conn_session_resumed.3.gz
+man/man3/tls_conn_version.3.gz
+man/man3/tls_connect.3.gz
+man/man3/tls_connect_cbs.3.gz
+man/man3/tls_connect_fds.3.gz
+man/man3/tls_connect_servername.3.gz
+man/man3/tls_connect_socket.3.gz
+man/man3/tls_default_ca_cert_file.3.gz
+man/man3/tls_error.3.gz
+man/man3/tls_free.3.gz
+man/man3/tls_handshake.3.gz
+man/man3/tls_init.3.gz
+man/man3/tls_load_file.3.gz
+man/man3/tls_ocsp_process_response.3.gz
+man/man3/tls_peer_cert_chain_pem.3.gz
+man/man3/tls_peer_cert_contains_name.3.gz
+man/man3/tls_peer_cert_hash.3.gz
+man/man3/tls_peer_cert_issuer.3.gz
+man/man3/tls_peer_cert_notafter.3.gz
+man/man3/tls_peer_cert_notbefore.3.gz
+man/man3/tls_peer_cert_provided.3.gz
+man/man3/tls_peer_cert_subject.3.gz
+man/man3/tls_peer_ocsp_cert_status.3.gz
+man/man3/tls_peer_ocsp_crl_reason.3.gz
+man/man3/tls_peer_ocsp_next_update.3.gz
+man/man3/tls_peer_ocsp_response_status.3.gz
+man/man3/tls_peer_ocsp_result.3.gz
+man/man3/tls_peer_ocsp_revocation_time.3.gz
+man/man3/tls_peer_ocsp_this_update.3.gz
+man/man3/tls_peer_ocsp_url.3.gz
+man/man3/tls_read.3.gz
+man/man3/tls_reset.3.gz
+man/man3/tls_server.3.gz
+man/man3/tls_unload_file.3.gz
+man/man3/tls_write.3.gz