aboutsummaryrefslogtreecommitdiff
path: root/security/libsecret
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-03-08 16:53:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-03-08 16:53:19 +0000
commit2d99b1ed47f593897cddc1075bbcf419d691839a (patch)
tree33347cd63d1a1907d089d0f457d3d1d133ae9e2b /security/libsecret
parent805615886e1195630292be437d1a0cefc933a4b6 (diff)
downloadports-2d99b1ed47f593897cddc1075bbcf419d691839a.tar.gz
ports-2d99b1ed47f593897cddc1075bbcf419d691839a.zip
libsecret is a library for storing and retrieving passwords and other
secrets. It communicates with the "Secret Service" using DBus. gnome-keyring and ksecretservice are both implementations of a Secret Service. interfaces and classes for commonly used data structures. interfaces and classes for commonly used data structures. Obtained from: GNOME dev repo
Notes
Notes: svn path=/head/; revision=347523
Diffstat (limited to 'security/libsecret')
-rw-r--r--security/libsecret/Makefile26
-rw-r--r--security/libsecret/distinfo2
-rw-r--r--security/libsecret/pkg-descr7
-rw-r--r--security/libsecret/pkg-plist101
4 files changed, 136 insertions, 0 deletions
diff --git a/security/libsecret/Makefile b/security/libsecret/Makefile
new file mode 100644
index 000000000000..9f2767648327
--- /dev/null
+++ b/security/libsecret/Makefile
@@ -0,0 +1,26 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/security/libsecret/Makefile 18610 2013-06-30 16:33:05Z marcus $
+
+PORTNAME= libsecret
+PORTVERSION= 0.15
+CATEGORIES= security gnome
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Library to access the secret service API
+
+BUILD_DEPENDS= docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl
+LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
+
+USE_XZ= yes
+USE_GNOME= gnomehier glib20 libxslt:build intltool introspection:build
+USES= gettext gmake libtool pathfix pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-introspection --disable-vala
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsecret-1.so.0
+
+.include <bsd.port.mk>
diff --git a/security/libsecret/distinfo b/security/libsecret/distinfo
new file mode 100644
index 000000000000..f9a208b2fa80
--- /dev/null
+++ b/security/libsecret/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libsecret-0.15.tar.xz) = 33e728b843efbe099483376ff5a3469260ee4b6ce035c7730909ac3793cb0fb8
+SIZE (libsecret-0.15.tar.xz) = 484532
diff --git a/security/libsecret/pkg-descr b/security/libsecret/pkg-descr
new file mode 100644
index 000000000000..3d5fb9e931da
--- /dev/null
+++ b/security/libsecret/pkg-descr
@@ -0,0 +1,7 @@
+libsecret is a library for storing and retrieving passwords and other
+secrets. It communicates with the "Secret Service" using
+DBus. gnome-keyring and ksecretservice are both implementations
+of a Secret Service. interfaces and classes for commonly used
+data structures. interfaces and classes for commonly used data structures.
+
+WWW: https://live.gnome.org/Libsecret
diff --git a/security/libsecret/pkg-plist b/security/libsecret/pkg-plist
new file mode 100644
index 000000000000..dfc283836613
--- /dev/null
+++ b/security/libsecret/pkg-plist
@@ -0,0 +1,101 @@
+bin/secret-tool
+include/libsecret-1/libsecret/secret-attributes.h
+include/libsecret-1/libsecret/secret-collection.h
+include/libsecret-1/libsecret/secret-enum-types.h
+include/libsecret-1/libsecret/secret-item.h
+include/libsecret-1/libsecret/secret-password.h
+include/libsecret-1/libsecret/secret-paths.h
+include/libsecret-1/libsecret/secret-prompt.h
+include/libsecret-1/libsecret/secret-schema.h
+include/libsecret-1/libsecret/secret-schemas.h
+include/libsecret-1/libsecret/secret-service.h
+include/libsecret-1/libsecret/secret-types.h
+include/libsecret-1/libsecret/secret-value.h
+include/libsecret-1/libsecret/secret.h
+lib/girepository-1.0/Secret-1.typelib
+lib/girepository-1.0/SecretUnstable-0.typelib
+lib/libsecret-1.a
+lib/libsecret-1.la
+lib/libsecret-1.so
+lib/libsecret-1.so.0
+lib/libsecret-1.so.0.0.0
+libdata/pkgconfig/libsecret-1.pc
+libdata/pkgconfig/libsecret-unstable.pc
+man/man1/secret-tool.1.gz
+share/gir-1.0/Secret-1.gir
+share/gir-1.0/SecretUnstable-0.gir
+share/gtk-doc/html/libsecret-1/SecretCollection.html
+share/gtk-doc/html/libsecret-1/SecretError.html
+share/gtk-doc/html/libsecret-1/SecretItem.html
+share/gtk-doc/html/libsecret-1/SecretPrompt.html
+share/gtk-doc/html/libsecret-1/SecretService.html
+share/gtk-doc/html/libsecret-1/SecretValue.html
+share/gtk-doc/html/libsecret-1/annotation-glossary.html
+share/gtk-doc/html/libsecret-1/c-examples.html
+share/gtk-doc/html/libsecret-1/c-lookup-example.html
+share/gtk-doc/html/libsecret-1/c-remove-example.html
+share/gtk-doc/html/libsecret-1/c-store-example.html
+share/gtk-doc/html/libsecret-1/complete.html
+share/gtk-doc/html/libsecret-1/examples.html
+share/gtk-doc/html/libsecret-1/home.png
+share/gtk-doc/html/libsecret-1/index.html
+share/gtk-doc/html/libsecret-1/index.sgml
+share/gtk-doc/html/libsecret-1/js-examples.html
+share/gtk-doc/html/libsecret-1/js-lookup-example.html
+share/gtk-doc/html/libsecret-1/js-remove-example.html
+share/gtk-doc/html/libsecret-1/js-store-example.html
+share/gtk-doc/html/libsecret-1/left.png
+share/gtk-doc/html/libsecret-1/libsecret-1.devhelp2
+share/gtk-doc/html/libsecret-1/libsecret-DBus-Path-Related-Functions.html
+share/gtk-doc/html/libsecret-1/libsecret-Password-storage.html
+share/gtk-doc/html/libsecret-1/libsecret-Secret-Attributes.html
+share/gtk-doc/html/libsecret-1/libsecret-SecretSchema.html
+share/gtk-doc/html/libsecret-1/migrating-api.html
+share/gtk-doc/html/libsecret-1/migrating-introduction.html
+share/gtk-doc/html/libsecret-1/migrating-items.html
+share/gtk-doc/html/libsecret-1/migrating-keyrings.html
+share/gtk-doc/html/libsecret-1/migrating-locking.html
+share/gtk-doc/html/libsecret-1/migrating-memory.html
+share/gtk-doc/html/libsecret-1/migrating-misc.html
+share/gtk-doc/html/libsecret-1/migrating-removing.html
+share/gtk-doc/html/libsecret-1/migrating-schemas.html
+share/gtk-doc/html/libsecret-1/migrating-searching.html
+share/gtk-doc/html/libsecret-1/migrating-storing.html
+share/gtk-doc/html/libsecret-1/migrating.html
+share/gtk-doc/html/libsecret-1/py-examples.html
+share/gtk-doc/html/libsecret-1/py-lookup-example.html
+share/gtk-doc/html/libsecret-1/py-remove-example.html
+share/gtk-doc/html/libsecret-1/py-store-example.html
+share/gtk-doc/html/libsecret-1/right.png
+share/gtk-doc/html/libsecret-1/simple.html
+share/gtk-doc/html/libsecret-1/style.css
+share/gtk-doc/html/libsecret-1/up.png
+share/gtk-doc/html/libsecret-1/using-c.html
+share/gtk-doc/html/libsecret-1/using-js.html
+share/gtk-doc/html/libsecret-1/using-python.html
+share/gtk-doc/html/libsecret-1/using-vala.html
+share/gtk-doc/html/libsecret-1/using.html
+share/gtk-doc/html/libsecret-1/vala-examples.html
+share/gtk-doc/html/libsecret-1/vala-lookup-example.html
+share/gtk-doc/html/libsecret-1/vala-remove-example.html
+share/gtk-doc/html/libsecret-1/vala-store-example.html
+share/locale/cs/LC_MESSAGES/libsecret.mo
+share/locale/es/LC_MESSAGES/libsecret.mo
+share/locale/gl/LC_MESSAGES/libsecret.mo
+share/locale/hu/LC_MESSAGES/libsecret.mo
+share/locale/it/LC_MESSAGES/libsecret.mo
+share/locale/ja/LC_MESSAGES/libsecret.mo
+share/locale/pl/LC_MESSAGES/libsecret.mo
+share/locale/pt_BR/LC_MESSAGES/libsecret.mo
+share/locale/ru/LC_MESSAGES/libsecret.mo
+share/locale/sl/LC_MESSAGES/libsecret.mo
+share/locale/sr/LC_MESSAGES/libsecret.mo
+share/locale/sr@latin/LC_MESSAGES/libsecret.mo
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrm share/gtk-doc/html/libsecret-1
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
+@dirrm include/libsecret-1/libsecret
+@dirrm include/libsecret-1
+