aboutsummaryrefslogtreecommitdiff
path: root/security/libssh2/Makefile
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2009-04-03 18:55:42 +0000
committerDavid Thiel <lx@FreeBSD.org>2009-04-03 18:55:42 +0000
commit77a0c6a037966187bf0238e2f797814389990eeb (patch)
tree43ab0592b056d38dfb95d0d70e51c4d9f30297fc /security/libssh2/Makefile
parent21243d2edde7c1255112cbde67887206e477d3d4 (diff)
downloadports-77a0c6a037966187bf0238e2f797814389990eeb.tar.gz
ports-77a0c6a037966187bf0238e2f797814389990eeb.zip
Notes
Diffstat (limited to 'security/libssh2/Makefile')
-rw-r--r--security/libssh2/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index fa683a283f53..3ac2aedd2103 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libssh2
-PORTVERSION= 1.0
+PORTVERSION= 1.1
PORTEPOCH= 2
CATEGORIES= security devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -35,29 +35,32 @@ MAN3= libssh2_banner_set.3 libssh2_channel_close.3 \
libssh2_channel_handle_extended_data.3 \
libssh2_channel_handle_extended_data2.3 libssh2_channel_open_ex.3 \
libssh2_channel_process_startup.3 libssh2_channel_read_ex.3 \
+ libssh2_channel_receive_window_adjust.3 \
+ libssh2_channel_receive_window_adjust2.3 \
libssh2_channel_request_pty_ex.3 libssh2_channel_send_eof.3 \
libssh2_channel_set_blocking.3 libssh2_channel_setenv_ex.3 \
- libssh2_channel_wait_eof.3 libssh2_channel_x11_req_ex.3 \
+ libssh2_channel_wait_eof.3 libssh2_channel_window_read_ex.3 \
+ libssh2_channel_window_write_ex.3 libssh2_channel_x11_req_ex.3 \
libssh2_hostkey_hash.3 libssh2_scp_recv.3 libssh2_scp_send_ex.3 \
libssh2_session_abstract.3 libssh2_session_free.3 \
libssh2_session_callback_set.3 libssh2_session_disconnect_ex.3 \
- libssh2_session_init.3 libssh2_session_last_errno.3 \
+ libssh2_session_init_ex.3 libssh2_session_last_errno.3 \
libssh2_session_last_error.3 libssh2_session_method_pref.3 \
libssh2_session_methods.3 libssh2_session_set_blocking.3 \
libssh2_session_startup.3 libssh2_poll.3 libssh2_poll_channel_read.3 \
libssh2_sftp_close_handle.3 libssh2_sftp_fstat_ex.3 \
libssh2_sftp_last_error.3 libssh2_sftp_init.3 libssh2_sftp_open_ex.3 \
- libssh2_sftp_mkdir_ex.3 libssh2_sftp_read.3 libssh2_sftp_readdir.3 \
+ libssh2_sftp_mkdir_ex.3 libssh2_sftp_read.3 libssh2_sftp_readdir_ex.3 \
libssh2_sftp_rename_ex.3 libssh2_sftp_rmdir_ex.3 libssh2_sftp_seek.3 \
libssh2_sftp_shutdown.3 libssh2_sftp_stat_ex.3 \
libssh2_sftp_symlink_ex.3 libssh2_sftp_tell.3 \
libssh2_sftp_unlink_ex.3 libssh2_sftp_write.3 \
libssh2_userauth_authenticated.3 libssh2_userauth_list.3 \
- libssh2_userauth_password_ex.3 libssh2_userauth_publickey_fromfile.3 \
+ libssh2_userauth_password_ex.3 libssh2_userauth_publickey_fromfile_ex.3 \
libssh2_channel_wait_closed.3 libssh2_channel_write_ex.3 \
libssh2_session_block_directions.3 libssh2_trace.3 \
libssh2_sftp_tell64.3 libssh2_userauth_keyboard_interactive_ex.3 \
- libssh2_base64_decode.3
+ libssh2_base64_decode.3 libssh2_version.3
post-patch:
@${REINPLACE_CMD} -e '/ssh2_sample\.o/d' ${WRKSRC}/Makefile.in