aboutsummaryrefslogtreecommitdiff
path: root/security/libssh2
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-28 21:21:57 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-28 21:21:57 +0000
commit009d225dd58f9f7a49a3f4a0aec9e94af7c3867b (patch)
treeb7f9f19866e074d058fe3fc6cd8f8d5f9c311e64 /security/libssh2
parentf7a672aec5582d6479267776ebbd64da52da1e25 (diff)
downloadports-009d225dd58f9f7a49a3f4a0aec9e94af7c3867b.tar.gz
ports-009d225dd58f9f7a49a3f4a0aec9e94af7c3867b.zip
security/libssh2:
- Convert to USES=libtool and USES=pathfix - Add INSTALL_TARGET=install-strip - Only depend on openssl if GCRYPT option is off - Sanitize libssh2.pc devel/libvirt: - Remove workaround for broken libssh2.pc - Add USES=libtool and bump dependent ports - Convert to INSTALL_TARGET=install-strip devel/libvirt-glib: - Convert to USES=libtool Approved by: portmgr (implicit, bump unstaged port)
Notes
Notes: svn path=/head/; revision=366456
Diffstat (limited to 'security/libssh2')
-rw-r--r--security/libssh2/Makefile27
-rw-r--r--security/libssh2/pkg-plist4
2 files changed, 19 insertions, 12 deletions
diff --git a/security/libssh2/Makefile b/security/libssh2/Makefile
index 9d1da783c02c..653fcccd0c12 100644
--- a/security/libssh2/Makefile
+++ b/security/libssh2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libssh2
PORTVERSION= 1.4.3
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= security devel
MASTER_SITES= http://www.libssh2.org/download/ \
@@ -14,9 +14,9 @@ COMMENT= Library implementing the SSH2 protocol
LICENSE= BSD3CLAUSE
-USE_OPENSSL= yes
-USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= libtool pathfix
USE_LDCONFIG= yes
OPTIONS_DEFINE= GCRYPT TRACE ZLIB
@@ -26,19 +26,26 @@ TRACE_DESC= Enable debug packet traces
TRACE_CONFIGURE_ENABLE= debug
GCRYPT_LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
-GCRYPT_CONFIGURE_ON= --with-libgcrypt -with-libgcrypt-prefix=${LOCALBASE} --without-openssl
-GCRYPT_CFLAGS= -I${LOCALBASE}/include
-GCRYPT_LDFLAGS= -L${LOCALBASE}/lib
+GCRYPT_CONFIGURE_ON= --with-libgcrypt --without-openssl
+GCRYPT_CONFIGURE_OFF= --without-libgcrypt --with-openssl
+GCRYPT_CPPFLAGS= -I${LOCALBASE}/include
+GCRYPT_LIBS= -L${LOCALBASE}/lib
ZLIB_CONFIGURE_WITH= libz
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MGCRYPT}
+USE_OPENSSL= yes
+.endif
+
.include <bsd.port.pre.mk>
post-patch:
+ @${REINPLACE_CMD} -e '/Libs:/s/@LDFLAGS@//' -e '/Libs:/s/@LIBS@//' \
+ ${WRKSRC}/libssh2.pc.in
.if defined(WITH_OPENSSL_BASE)
- @${REINPLACE_CMD} -e '/LIBSREQUIRED=/ s|libssl,libcrypto||' \
- ${WRKSRC}/configure.ac ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/LIBSREQUIRED=libssl,libcrypto/LIBS="$$LIBS -lssl -lcrypto"/' \
+ ${WRKSRC}/configure
.endif
- @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/Makefile.in
.include <bsd.port.post.mk>
diff --git a/security/libssh2/pkg-plist b/security/libssh2/pkg-plist
index 89f56e86e30b..8ffa6cee66ac 100644
--- a/security/libssh2/pkg-plist
+++ b/security/libssh2/pkg-plist
@@ -1,10 +1,10 @@
include/libssh2.h
include/libssh2_publickey.h
include/libssh2_sftp.h
+lib/libssh2.a
lib/libssh2.so
lib/libssh2.so.1
-lib/libssh2.la
-lib/libssh2.a
+lib/libssh2.so.1.0.1
man/man3/libssh2_agent_connect.3.gz
man/man3/libssh2_agent_disconnect.3.gz
man/man3/libssh2_agent_free.3.gz