aboutsummaryrefslogtreecommitdiff
path: root/security/logcheck
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-04 19:26:24 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-04 19:26:24 +0000
commit228ab588738952bd42427886fd5368181243ba6e (patch)
tree7fe589d0d1b0e6d00b7aa9cd05fc46ca15de7655 /security/logcheck
parent7374b5a054d87d64914c6c36520e15fa14f3f31b (diff)
downloadports-228ab588738952bd42427886fd5368181243ba6e.tar.gz
ports-228ab588738952bd42427886fd5368181243ba6e.zip
Change INSTALL_DATA to install with mode 644
Remove patches and hacks that were used to work around the previous situation This allows to stage more ports as a regular user Differential Revision: https://reviews.freebsd.org/D703 Reviewed by and discussed with: bapt With hat: portmgr
Notes
Notes: svn path=/head/; revision=367307
Diffstat (limited to 'security/logcheck')
-rw-r--r--security/logcheck/Makefile5
-rw-r--r--security/logcheck/pkg-plist2
2 files changed, 4 insertions, 3 deletions
diff --git a/security/logcheck/Makefile b/security/logcheck/Makefile
index 5abed2f6f06a..44e077765db5 100644
--- a/security/logcheck/Makefile
+++ b/security/logcheck/Makefile
@@ -36,7 +36,6 @@ USES= perl5 shebangfix tar:xz
WRKSRC= ${WRKDIR}/${DISTNAME:S!_!-!}
BINMODE= 755
-SHAREMODE= 640
SUB_LIST+= LOGCHECK_USER=${LOGCHECK_USER} \
LOGCHECK_GROUP=${LOGCHECK_GROUP} \
CRON=${PORT_OPTIONS:MCRON}
@@ -91,7 +90,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/src/detectrotate/*.dtr \
${STAGEDIR}${DATADIR}/detectrotate
@${INSTALL} -d ${STAGEDIR}${EXAMPLESDIR}
- @${INSTALL_DATA} -m 0644 ${WRKSRC}/debian/logcheck.cron.d \
+ @${INSTALL_DATA} ${WRKSRC}/debian/logcheck.cron.d \
${STAGEDIR}${EXAMPLESDIR}/crontab.in
@${ECHO_CMD} '@exec ${CHGRP} -R ${LOGCHECK_GROUP} \
${ETCDIR:S|^${PREFIX}/|%D/|} \
@@ -101,6 +100,6 @@ do-install:
@${GZIP_CMD} ${STAGEDIR}${MAN8PREFIX}/man/man8/$i
.endfor
@${INSTALL} -d ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} -m 0644 ${DOCS} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>
diff --git a/security/logcheck/pkg-plist b/security/logcheck/pkg-plist
index a638a1ea63c8..a3ea77dba2d3 100644
--- a/security/logcheck/pkg-plist
+++ b/security/logcheck/pkg-plist
@@ -1,3 +1,4 @@
+@mode 640
%%ETCDIR%%/cracking.d/kernel
%%ETCDIR%%/cracking.d/rlogind
%%ETCDIR%%/cracking.d/rsh
@@ -191,6 +192,7 @@
%%DATADIR%%/detectrotate/10-savelog.dtr
%%DATADIR%%/detectrotate/20-logrotate.dtr
%%DATADIR%%/detectrotate/30-logrotate-dateext.dtr
+@mode
man/man8/logcheck.8.gz
man/man8/logtail.8.gz
man/man8/logtail2.8.gz