aboutsummaryrefslogtreecommitdiff
path: root/security/mailzu
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
commit0b881b0ecebc9440a559f1c2b27758488a1188fa (patch)
tree933fd11da647dda8c169bc24693094174bdc0355 /security/mailzu
parent928d434bd206738b7213dd9b5802c680794a9b10 (diff)
downloadports-0b881b0ecebc9440a559f1c2b27758488a1188fa.tar.gz
ports-0b881b0ecebc9440a559f1c2b27758488a1188fa.zip
Convert security to new options framework
Notes
Notes: svn path=/head/; revision=316749
Diffstat (limited to 'security/mailzu')
-rw-r--r--security/mailzu/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/security/mailzu/Makefile b/security/mailzu/Makefile
index a5bc77850159..36747e4e145b 100644
--- a/security/mailzu/Makefile
+++ b/security/mailzu/Makefile
@@ -1,6 +1,5 @@
# Created by: Sahil Tandon <sahil@tandon.net>
# $FreeBSD$
-#
PORTNAME= mailzu
DISTVERSION= 0.8rc3
@@ -27,34 +26,35 @@ NO_BUILD= yes
USE_PHP= sockets
WANT_PHP_WEB= yes
-OPTIONS= MYSQL "Use MySQL database storage/auth backend (default)" On \
- PGSQL "Use PostgreSQL database/auth storage backend" Off \
- IMAP "Use IMAP auth backend" Off \
- LDAP "Use LDAP auth backend" Off
+OPTIONS_DEFINE= IMAP LDAP DOCS
+OPTIONS_MULTI= SQL
+OPTIONS_MULTI_SQL= MYSQL PGSQL
+OPTIONS_DEFAULT= MYSQL
+SQL_DESC= SQL sotage backend
+MYSQL_DESC= Use MySQL database storage/auth backend (default)
+PGSQL_DESC= Use PostgreSQL database/auth storage backend
+IMAP_DESC= Use IMAP auth backend
+LDAP_DESC= Use LDAP auth backend
.include <bsd.port.pre.mk>
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
.endif
-.if defined(WITH_IMAP)
+.if ${PORT_OPTIONS:MIMAP}
USE_PHP+= imap
.endif
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_PHP+= ldap
.endif
-.if !defined(WITH_MYSQL) && !defined(WITH_PGSQL)
-IGNORE= you must choose a SQL storage backend with 'make config'
-.endif
-
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
.endif
@@ -66,7 +66,7 @@ do-install:
@cd ${WRKSRC} && ${COPYTREE_BIN} scripts ${WWWDIR}
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d -o ${DOCOWN} -g ${DOCGRP} -m 555 ${DOCSDIR}
@${INSTALL_MAN} ${WRKSRC}/CHANGELOG ${WRKSRC}/README ${DOCSDIR}
@${INSTALL_MAN} ${WRKSRC}/docs/* ${DOCSDIR}