aboutsummaryrefslogtreecommitdiff
path: root/security/mbedtls
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-03-12 21:30:15 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-03-12 21:30:15 +0000
commitc958325f6d0d74a2e459434a565c8247893edb19 (patch)
tree95235a8cdc7ed47c214b7696daaa6d4b2293449a /security/mbedtls
parentb6941910fddedfed8ed2ae5609cf92c837882cbc (diff)
downloadports-c958325f6d0d74a2e459434a565c8247893edb19.tar.gz
ports-c958325f6d0d74a2e459434a565c8247893edb19.zip
Enable thread safety for www/hiawatha.
PR: 217668
Notes
Notes: svn path=/head/; revision=436028
Diffstat (limited to 'security/mbedtls')
-rw-r--r--security/mbedtls/Makefile1
-rw-r--r--security/mbedtls/files/patch-config.h20
2 files changed, 21 insertions, 0 deletions
diff --git a/security/mbedtls/Makefile b/security/mbedtls/Makefile
index 2c8956148d14..bf6ac6d8a4bb 100644
--- a/security/mbedtls/Makefile
+++ b/security/mbedtls/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mbedtls
PORTVERSION= 2.4.2
DISTVERSIONSUFFIX= -apache
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= https://tls.mbed.org/download/
diff --git a/security/mbedtls/files/patch-config.h b/security/mbedtls/files/patch-config.h
new file mode 100644
index 000000000000..ef5f7f4e7e03
--- /dev/null
+++ b/security/mbedtls/files/patch-config.h
@@ -0,0 +1,20 @@
+--- include/mbedtls/config.h.orig 2017-03-08 15:33:04 UTC
++++ include/mbedtls/config.h
+@@ -1285,7 +1285,7 @@
+ *
+ * Uncomment this to enable pthread mutexes.
+ */
+-//#define MBEDTLS_THREADING_PTHREAD
++#define MBEDTLS_THREADING_PTHREAD
+
+ /**
+ * \def MBEDTLS_VERSION_FEATURES
+@@ -2322,7 +2322,7 @@
+ *
+ * Enable this layer to allow use of mutexes within mbed TLS
+ */
+-//#define MBEDTLS_THREADING_C
++#define MBEDTLS_THREADING_C
+
+ /**
+ * \def MBEDTLS_TIMING_C