aboutsummaryrefslogtreecommitdiff
path: root/security/medusa
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2007-12-11 20:09:36 +0000
committerDavid Thiel <lx@FreeBSD.org>2007-12-11 20:09:36 +0000
commit1694682b5c398c465a099558e1759572cc5de9c6 (patch)
treeda7be76601d868041f8cb56405b29c4852273b00 /security/medusa
parentd108a1275914c65b14333cf9a067358eaea3a4e6 (diff)
downloadports-1694682b5c398c465a099558e1759572cc5de9c6.tar.gz
ports-1694682b5c398c465a099558e1759572cc5de9c6.zip
Update to 1.4.
Notes
Notes: svn path=/head/; revision=202975
Diffstat (limited to 'security/medusa')
-rw-r--r--security/medusa/Makefile34
-rw-r--r--security/medusa/distinfo6
-rw-r--r--security/medusa/files/patch-configure101
-rw-r--r--security/medusa/pkg-plist9
4 files changed, 138 insertions, 12 deletions
diff --git a/security/medusa/Makefile b/security/medusa/Makefile
index a63c910e1ab0..772b6163a1f1 100644
--- a/security/medusa/Makefile
+++ b/security/medusa/Makefile
@@ -6,21 +6,23 @@
#
PORTNAME= medusa
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= security
MASTER_SITES= http://www.foofus.net/jmk/tools/ \
http://redundancy.redundancy.org/mirror/
-MAINTAINER= lx@redundancy.redundancy.org
+MAINTAINER= lx@FreeBSD.org
COMMENT= A speedy, massively parallel, modular, login brute-forcer
OPTIONS= SVN "Enable Subversion module" off \
- POSTGRESQL "Enable PostgreSQL module" off
+ POSTGRESQL "Enable PostgreSQL module" off \
+ WEBFORM "Enable web form module" off \
+ SMTPAUTH "Enable web form module" off
LIB_DEPENDS+= ssh2:${PORTSDIR}/security/libssh2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --enable-untested --program-transform=
+CONFIGURE_ARGS+= --program-transform= --disable-module-ncp
MAN1= medusa.1
@@ -31,12 +33,34 @@ BROKEN= Does not build on ia64
.endif
.if defined(WITH_SVN)
-LIB_DEPENDS+= svn_client-1:${PORTSDIR}/devel/subversion
+PLIST_SUB+= SVN=""
+LIB_DEPENDS+= svn_client-1:${PORTSDIR}/devel/subversion \
+ apr-1:${PORTSDIR}/devel/apr
CFLAGS+= -I${LOCALBASE}/include/subversion-1 -I${LOCALBASE}/include/apr-1
+.else
+PLIST_SUB+= SVN="@comment "
.endif
.if defined(WITH_POSTGRESQL)
+PLIST_SUB+= POSTGRESQL=""
USE_PGSQL= yes
+CONFIGURE_ARGS+= --enable-module-postgres
+.else
+PLIST_SUB+= POSTGRESQL="@comment "
+.endif
+
+.if defined(WITH_WEBFORM)
+PLIST_SUB+= WEBFORM=""
+CONFIGURE_ARGS+= --enable-module-web-form
+.else
+PLIST_SUB+= WEBFORM="@comment "
+.endif
+
+.if defined(WITH_SMTPAUTH)
+PLIST_SUB+= SMTPAUTH=""
+CONFIGURE_ARGS+= --enable-module-smtp-auth
+.else
+PLIST_SUB+= SMTPAUTH="@comment "
.endif
.include <bsd.port.post.mk>
diff --git a/security/medusa/distinfo b/security/medusa/distinfo
index 901a34414d1a..fb3a8875a163 100644
--- a/security/medusa/distinfo
+++ b/security/medusa/distinfo
@@ -1,3 +1,3 @@
-MD5 (medusa-1.3.tar.gz) = 08e04a1cfd1b4b3a354a29db3e5514fa
-SHA256 (medusa-1.3.tar.gz) = d87a7b1654a5c12af77c7f6c0e274dc2c1391e555b1abdc53dc2f921a010d40f
-SIZE (medusa-1.3.tar.gz) = 273154
+MD5 (medusa-1.4.tar.gz) = aad236c87aaadbdc9162b6658c2118e6
+SHA256 (medusa-1.4.tar.gz) = 08af3917c8c53741627362ce3831f808bd8e9598b631e74cf49ec7c912adb237
+SIZE (medusa-1.4.tar.gz) = 306232
diff --git a/security/medusa/files/patch-configure b/security/medusa/files/patch-configure
new file mode 100644
index 000000000000..c6039eb51dfa
--- /dev/null
+++ b/security/medusa/files/patch-configure
@@ -0,0 +1,101 @@
+--- configure.old 2007-12-11 11:53:36.000000000 -0800
++++ configure 2007-12-11 11:54:16.000000000 -0800
+@@ -5794,8 +5794,8 @@
+
+ else
+ if test "${ac_cv_header_apr_1_0_apr_tables_h+set}" = set; then
+- { echo "$as_me:$LINENO: checking for apr-1.0/apr_tables.h" >&5
+-echo $ECHO_N "checking for apr-1.0/apr_tables.h... $ECHO_C" >&6; }
++ { echo "$as_me:$LINENO: checking for apr-1/apr_tables.h" >&5
++echo $ECHO_N "checking for apr-1/apr_tables.h... $ECHO_C" >&6; }
+ if test "${ac_cv_header_apr_1_0_apr_tables_h+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ fi
+@@ -5803,8 +5803,8 @@
+ echo "${ECHO_T}$ac_cv_header_apr_1_0_apr_tables_h" >&6; }
+ else
+ # Is the header compilable?
+-{ echo "$as_me:$LINENO: checking apr-1.0/apr_tables.h usability" >&5
+-echo $ECHO_N "checking apr-1.0/apr_tables.h usability... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking apr-1/apr_tables.h usability" >&5
++echo $ECHO_N "checking apr-1/apr_tables.h usability... $ECHO_C" >&6; }
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -5812,7 +5812,7 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_includes_default
+-#include <apr-1.0/apr_tables.h>
++#include <apr-1/apr_tables.h>
+ _ACEOF
+ rm -f conftest.$ac_objext
+ if { (ac_try="$ac_compile"
+@@ -5844,15 +5844,15 @@
+ echo "${ECHO_T}$ac_header_compiler" >&6; }
+
+ # Is the header present?
+-{ echo "$as_me:$LINENO: checking apr-1.0/apr_tables.h presence" >&5
+-echo $ECHO_N "checking apr-1.0/apr_tables.h presence... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking apr-1/apr_tables.h presence" >&5
++echo $ECHO_N "checking apr-1/apr_tables.h presence... $ECHO_C" >&6; }
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <apr-1.0/apr_tables.h>
++#include <apr-1/apr_tables.h>
+ _ACEOF
+ if { (ac_try="$ac_cpp conftest.$ac_ext"
+ case "(($ac_try" in
+@@ -5885,30 +5885,30 @@
+ # So? What about this header?
+ case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
+ yes:no: )
+- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&5
+-echo "$as_me: WARNING: apr-1.0/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
+- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: proceeding with the compiler's result" >&5
+-echo "$as_me: WARNING: apr-1.0/apr_tables.h: proceeding with the compiler's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&5
++echo "$as_me: WARNING: apr-1/apr_tables.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
++ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: proceeding with the compiler's result" >&5
++echo "$as_me: WARNING: apr-1/apr_tables.h: proceeding with the compiler's result" >&2;}
+ ac_header_preproc=yes
+ ;;
+ no:yes:* )
+- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: present but cannot be compiled" >&5
+-echo "$as_me: WARNING: apr-1.0/apr_tables.h: present but cannot be compiled" >&2;}
+- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: check for missing prerequisite headers?" >&5
+-echo "$as_me: WARNING: apr-1.0/apr_tables.h: check for missing prerequisite headers?" >&2;}
+- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: see the Autoconf documentation" >&5
+-echo "$as_me: WARNING: apr-1.0/apr_tables.h: see the Autoconf documentation" >&2;}
+- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&5
+-echo "$as_me: WARNING: apr-1.0/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&2;}
+- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: proceeding with the preprocessor's result" >&5
+-echo "$as_me: WARNING: apr-1.0/apr_tables.h: proceeding with the preprocessor's result" >&2;}
+- { echo "$as_me:$LINENO: WARNING: apr-1.0/apr_tables.h: in the future, the compiler will take precedence" >&5
+-echo "$as_me: WARNING: apr-1.0/apr_tables.h: in the future, the compiler will take precedence" >&2;}
++ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: present but cannot be compiled" >&5
++echo "$as_me: WARNING: apr-1/apr_tables.h: present but cannot be compiled" >&2;}
++ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: check for missing prerequisite headers?" >&5
++echo "$as_me: WARNING: apr-1/apr_tables.h: check for missing prerequisite headers?" >&2;}
++ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: see the Autoconf documentation" >&5
++echo "$as_me: WARNING: apr-1/apr_tables.h: see the Autoconf documentation" >&2;}
++ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&5
++echo "$as_me: WARNING: apr-1/apr_tables.h: section \"Present But Cannot Be Compiled\"" >&2;}
++ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: proceeding with the preprocessor's result" >&5
++echo "$as_me: WARNING: apr-1/apr_tables.h: proceeding with the preprocessor's result" >&2;}
++ { echo "$as_me:$LINENO: WARNING: apr-1/apr_tables.h: in the future, the compiler will take precedence" >&5
++echo "$as_me: WARNING: apr-1/apr_tables.h: in the future, the compiler will take precedence" >&2;}
+
+ ;;
+ esac
+-{ echo "$as_me:$LINENO: checking for apr-1.0/apr_tables.h" >&5
+-echo $ECHO_N "checking for apr-1.0/apr_tables.h... $ECHO_C" >&6; }
++{ echo "$as_me:$LINENO: checking for apr-1/apr_tables.h" >&5
++echo $ECHO_N "checking for apr-1/apr_tables.h... $ECHO_C" >&6; }
+ if test "${ac_cv_header_apr_1_0_apr_tables_h+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
diff --git a/security/medusa/pkg-plist b/security/medusa/pkg-plist
index 77f8a5a062ce..f7f1841dc128 100644
--- a/security/medusa/pkg-plist
+++ b/security/medusa/pkg-plist
@@ -10,18 +10,19 @@ lib/medusa/modules/mysql.mod
lib/medusa/modules/pcanywhere.mod
lib/medusa/modules/ftp.mod
lib/medusa/modules/imap.mod
+lib/medusa/modules/nntp.mod
lib/medusa/modules/rsh.mod
lib/medusa/modules/rexec.mod
lib/medusa/modules/wrapper.mod
lib/medusa/modules/rlogin.mod
-lib/medusa/modules/ncp.mod
lib/medusa/modules/vnc.mod
-lib/medusa/modules/postgres.mod
+%%POSTGRESQL%%lib/medusa/modules/postgres.mod
lib/medusa/modules/cvs.mod
lib/medusa/modules/vmauthd.mod
lib/medusa/modules/snmp.mod
lib/medusa/modules/smtp-vrfy.mod
-lib/medusa/modules/smtp-auth.mod
-lib/medusa/modules/svn.mod
+%%SMTPAUTH%%lib/medusa/modules/smtp-auth.mod
+%%SVN%%lib/medusa/modules/svn.mod
+%%WEBFORM%%lib/medusa/modules/web-form.mod
@dirrm lib/medusa/modules
@dirrm lib/medusa