aboutsummaryrefslogtreecommitdiff
path: root/security/modsecurity3-apache
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2019-05-06 18:55:19 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2019-05-06 18:55:19 +0000
commitea4ad8cdb04e37e35f1c0ab67119a779aaa33c5b (patch)
tree0556d806c5679e6c8fd81c3105c8f10b4e3151ad /security/modsecurity3-apache
parentd8cd9f899113aeebcea104e0dac914b92ad95345 (diff)
downloadports-ea4ad8cdb04e37e35f1c0ab67119a779aaa33c5b.tar.gz
ports-ea4ad8cdb04e37e35f1c0ab67119a779aaa33c5b.zip
New Port: security/modsecurity3-apache
The ModSecurity-apache connector is the connection point between Apache and libmodsecurity (ModSecurity v3). Said another way, this project provides a communication channel between Apache and libmodsecurity. This connector is required to use LibModSecurity with Apache. The ModSecurity-apache connector takes the form of an Apache module. The module simply serves as a layer of communication between Apache and ModSecurity. https://github.com/SpiderLabs/ModSecurity-apache Sponsored by: Netzkommune GmbH
Notes
Notes: svn path=/head/; revision=500924
Diffstat (limited to 'security/modsecurity3-apache')
-rw-r--r--security/modsecurity3-apache/Makefile38
-rw-r--r--security/modsecurity3-apache/distinfo3
-rw-r--r--security/modsecurity3-apache/pkg-descr10
-rw-r--r--security/modsecurity3-apache/pkg-plist4
4 files changed, 55 insertions, 0 deletions
diff --git a/security/modsecurity3-apache/Makefile b/security/modsecurity3-apache/Makefile
new file mode 100644
index 000000000000..c65480d52d55
--- /dev/null
+++ b/security/modsecurity3-apache/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= modsecurity3-apache
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.0.9-beta1-19
+DISTVERSIONSUFFIX= -gf76aaae
+CATEGORIES= security www
+
+MAINTAINER= joneum@FreeBSD.org
+COMMENT= Intrusion detection and prevention engine / Apache Wrapper
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libmodsecurity.so:security/modsecurity3
+
+USES= apache:2.4+ autoreconf
+USE_GCC= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= SpiderLabs
+GH_PROJECT= ModSecurity-apache
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= V3LIB=${LOCALBASE}/lib V3INCLUDE=${LOCALBASE}/include
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
+ ${INSTALL_LIB} ${WRKSRC}/src/.libs/mod_security3.so \
+ ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/modsecurity3-apache/distinfo b/security/modsecurity3-apache/distinfo
new file mode 100644
index 000000000000..7d2762be75b3
--- /dev/null
+++ b/security/modsecurity3-apache/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1556729006
+SHA256 (SpiderLabs-ModSecurity-apache-v0.0.9-beta1-19-gf76aaae_GH0.tar.gz) = 38bcdb44c971940f54693e89d19608df421372d464e9d02d28f29b2e36027977
+SIZE (SpiderLabs-ModSecurity-apache-v0.0.9-beta1-19-gf76aaae_GH0.tar.gz) = 64553
diff --git a/security/modsecurity3-apache/pkg-descr b/security/modsecurity3-apache/pkg-descr
new file mode 100644
index 000000000000..c719c5a7a425
--- /dev/null
+++ b/security/modsecurity3-apache/pkg-descr
@@ -0,0 +1,10 @@
+The ModSecurity-apache connector is the connection point between Apache and libmodsecurity
+(ModSecurity v3). Said another way, this project provides a communication channel between Apache
+and libmodsecurity. This connector is required to use LibModSecurity with Apache.
+
+The ModSecurity-apache connector takes the form of an Apache module.
+The module simply serves as a layer of communication between Apache and ModSecurity.
+
+Notice that this project depends on libmodsecurity rather than ModSecurity (version 2.9 or less).
+
+WWW: https://github.com/SpiderLabs/ModSecurity-apache
diff --git a/security/modsecurity3-apache/pkg-plist b/security/modsecurity3-apache/pkg-plist
new file mode 100644
index 000000000000..630ff3565e51
--- /dev/null
+++ b/security/modsecurity3-apache/pkg-plist
@@ -0,0 +1,4 @@
+%%APACHEMODDIR%%/mod_security3.so
+@postexec %D/sbin/apxs -e -a -n security3 %f
+@preunexec %D/sbin/apxs -e -A -n security3 %f
+%%PORTDOCS%%%%DOCSDIR%%/README.md