aboutsummaryrefslogtreecommitdiff
path: root/security/munge
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-09-24 16:53:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2016-09-24 16:53:57 +0000
commit21824645dc03b0e8e6830f324bead4d5e41b5cb8 (patch)
treea198a8e21d1e83604142b452c5207b60c552ba2e /security/munge
parent1def5973eae49272de0737590acdfc1217dcaada (diff)
downloadports-21824645dc03b0e8e6830f324bead4d5e41b5cb8.tar.gz
ports-21824645dc03b0e8e6830f324bead4d5e41b5cb8.zip
security/munge: UNBREAK and Update version 0.5.11=>0.5.12
- Move MASTER_SITES to GITHUB from GOOGLE_CODE - Update WWW PR: 212712 Submitted by: monwarez@mailoo.org
Notes
Notes: svn path=/head/; revision=422733
Diffstat (limited to 'security/munge')
-rw-r--r--security/munge/Makefile15
-rw-r--r--security/munge/distinfo5
-rw-r--r--security/munge/files/patch-src_etc_Makefile.in39
-rw-r--r--security/munge/pkg-descr2
-rw-r--r--security/munge/pkg-plist5
5 files changed, 51 insertions, 15 deletions
diff --git a/security/munge/Makefile b/security/munge/Makefile
index 09291d3e905b..72b03f00a56d 100644
--- a/security/munge/Makefile
+++ b/security/munge/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= munge
-PORTVERSION= 0.5.11
-PORTREVISION= 2
+PORTVERSION= 0.5.12
CATEGORIES= security
-MASTER_SITES= GOOGLE_CODE
MAINTAINER= bofh@FreeBSD.org
COMMENT= Authentication service for creating and validating credentials
@@ -13,18 +11,15 @@ COMMENT= Authentication service for creating and validating credentials
LICENSE= GPLv3 LGPL3
LICENSE_COMB= dual
-BROKEN= Unfetchable (google code has gone away)
+USE_GITHUB=yes
+GH_ACCOUNT= dun
+GH_TAGNAME= 880584f
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl-prefix=${OPENSSLBASE}
-USES= libtool pathfix perl5 ssl tar:bzip2
+USES= libtool pathfix perl5 ssl
USE_LDCONFIG= yes
USE_RC_SUBR= munged
INSTALL_TARGET= install-strip
-post-install:
- ${RM} -r ${STAGEDIR}${PREFIX}/etc/default
- ${RM} -r ${STAGEDIR}${PREFIX}/etc/init.d
- ${RM} -r ${STAGEDIR}${ETCDIR}
-
.include <bsd.port.mk>
diff --git a/security/munge/distinfo b/security/munge/distinfo
index ad8a656a5403..d095665e65d4 100644
--- a/security/munge/distinfo
+++ b/security/munge/distinfo
@@ -1,2 +1,3 @@
-SHA256 (munge-0.5.11.tar.bz2) = 8e075614f81cb0a6df21a0aafdc825498611a04429d0876f074fc828739351a5
-SIZE (munge-0.5.11.tar.bz2) = 423232
+TIMESTAMP = 1474733134
+SHA256 (dun-munge-0.5.12-880584f_GH0.tar.gz) = 3b1849b3482b7cf7d14c55c0529a3b9a963fc0f17f78b0283e0b865defc1268f
+SIZE (dun-munge-0.5.12-880584f_GH0.tar.gz) = 573947
diff --git a/security/munge/files/patch-src_etc_Makefile.in b/security/munge/files/patch-src_etc_Makefile.in
new file mode 100644
index 000000000000..5b6782b72e3e
--- /dev/null
+++ b/security/munge/files/patch-src_etc_Makefile.in
@@ -0,0 +1,39 @@
+--- src/etc/Makefile.in.orig 2016-09-24 16:18:55 UTC
++++ src/etc/Makefile.in
+@@ -520,36 +520,11 @@ distclean-local::
+ -rm -f *~ \#* .\#* cscope*.out core core.* tags TAGS
+
+ install-data-local:
+- test -d "/etc/rc.d/init.d" \
+- && INITDIR="$(sysconfdir)/rc.d/init.d" \
+- || INITDIR="$(sysconfdir)/init.d"; \
+- $(INSTALL) -m 0755 -d "$(DESTDIR)$${INITDIR}"; \
+- $(INSTALL) -m 0755 \
+- "$(builddir)/munge.init" "$(DESTDIR)$${INITDIR}/munge"
+- :
+- test -d "/etc/sysconfig" \
+- && CONFDIR="$(sysconfdir)/sysconfig" \
+- || CONFDIR="$(sysconfdir)/default"; \
+- $(INSTALL) -m 0755 -d "$(DESTDIR)$${CONFDIR}"; \
+- $(INSTALL) -m 0644 \
+- "$(srcdir)/munge.sysconfig" "$(DESTDIR)$${CONFDIR}/munge"
+- :
+ PKGCONFIGDIR="$(prefix)/libdata/pkgconfig"; \
+ $(INSTALL) -m 0755 -d "$(DESTDIR)$${PKGCONFIGDIR}"; \
+ $(INSTALL) -m 0644 \
+ "$(builddir)/munge.pc" "$(DESTDIR)$${PKGCONFIGDIR}/munge.pc"
+ :
+- UNITDIR="$(prefix)/lib/systemd/system"; \
+- $(INSTALL) -m 0755 -d "$(DESTDIR)$${UNITDIR}"; \
+- $(INSTALL) -m 0644 \
+- "$(srcdir)/munge.service" "$(DESTDIR)$${UNITDIR}/munge.service"
+- :
+- TMPFILESDIR="$(prefix)/lib/tmpfiles.d"; \
+- $(INSTALL) -m 0755 -d "$(DESTDIR)$${TMPFILESDIR}"; \
+- $(INSTALL) -m 0644 \
+- "$(srcdir)/munge-tmpfiles.conf" \
+- "$(DESTDIR)$${TMPFILESDIR}/munge.conf"
+- :
+ $(INSTALL) -m 0755 -d "$(DESTDIR)$(sysconfdir)"
+ $(INSTALL) -m 0700 -d "$(DESTDIR)$(sysconfdir)/munge"
+ $(INSTALL) -m 0755 -d "$(DESTDIR)$(localstatedir)"
diff --git a/security/munge/pkg-descr b/security/munge/pkg-descr
index 4e6b50413b01..7792c788da5b 100644
--- a/security/munge/pkg-descr
+++ b/security/munge/pkg-descr
@@ -7,4 +7,4 @@ cryptographic key. Clients within this security realm can create and validate
credentials without the use of root privileges, reserved ports, or
platform-specific methods.
-WWW: http://code.google.com/p/munge/
+WWW: https://dun.github.io/munge/
diff --git a/security/munge/pkg-plist b/security/munge/pkg-plist
index 08d0a139a72f..73b14e49d231 100644
--- a/security/munge/pkg-plist
+++ b/security/munge/pkg-plist
@@ -28,7 +28,8 @@ man/man3/munge_strerror.3.gz
man/man7/munge.7.gz
man/man8/munged.8.gz
sbin/munged
-@dir /var/run/munge
-@dir(,,700) /var/log/munge
+@dir %%ETCDIR%%
@dir(,,711) /var/lib/munge
@dir /var/lib
+@dir /var/run/munge
+@dir(,,700) /var/log/munge