aboutsummaryrefslogtreecommitdiff
path: root/security/nettle
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2012-07-12 21:02:06 +0000
committerJohan van Selst <johans@FreeBSD.org>2012-07-12 21:02:06 +0000
commit1955f615c9e4f8b4510e216422d7b6ed71a0b6a4 (patch)
treebfcd3bea74b12c40b2fab947d83f38487fe67d76 /security/nettle
parentd6a9c3620ec019bf1ee778d1c3cb86152abe55ad (diff)
downloadports-1955f615c9e4f8b4510e216422d7b6ed71a0b6a4.tar.gz
ports-1955f615c9e4f8b4510e216422d7b6ed71a0b6a4.zip
- Update Nettle to 2.5 release
- Remove local patch that is no longer needed - This release is ABI/API compatible with the previous version PR: ports/169742 Submitted by: Niclas Zeising <zeising@daemonic.se>
Notes
Notes: svn path=/head/; revision=300815
Diffstat (limited to 'security/nettle')
-rw-r--r--security/nettle/Makefile12
-rw-r--r--security/nettle/distinfo4
-rw-r--r--security/nettle/pkg-plist12
3 files changed, 14 insertions, 14 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index eb43f5983d4a..9d0c246a2cb7 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= nettle
-PORTVERSION= 2.4
+PORTVERSION= 2.5
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNU} \
http://www.lysator.liu.se/~nisse/archive/:liu \
@@ -20,7 +20,7 @@ COMMENT= A low-level cryptographic library
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp
+LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
USE_GMAKE= yes
USE_OPENSSL= yes
@@ -38,16 +38,14 @@ EXAMPLES= examples/*.c examples/*.h
INFO= nettle
-post-patch:
- @${REINPLACE_CMD} -e 's/[[:<:]]sub[[:>:]]/subl/' \
- ${WRKSRC}/x86/camellia-crypt-internal.asm
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
diff --git a/security/nettle/distinfo b/security/nettle/distinfo
index 9500c0037120..fc43f4d72ae2 100644
--- a/security/nettle/distinfo
+++ b/security/nettle/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nettle-2.4.tar.gz) = a6009208df6881f75aa1a87081ccfb2ccac1884da10670c53d7b76596f649c3f
-SIZE (nettle-2.4.tar.gz) = 1075789
+SHA256 (nettle-2.5.tar.gz) = 4aa142e908b0053082d7729fc0155dc90dbe71c8ef5f50f30034805ed5c92c72
+SIZE (nettle-2.5.tar.gz) = 1113274
diff --git a/security/nettle/pkg-plist b/security/nettle/pkg-plist
index 21389a2932c7..6a69d6992702 100644
--- a/security/nettle/pkg-plist
+++ b/security/nettle/pkg-plist
@@ -36,6 +36,7 @@ include/nettle/realloc.h
include/nettle/ripemd160.h
include/nettle/rsa-compat.h
include/nettle/rsa.h
+include/nettle/salsa20.h
include/nettle/serpent.h
include/nettle/sexp.h
include/nettle/sha.h
@@ -44,11 +45,11 @@ include/nettle/yarrow.h
lib/libhogweed.a
lib/libhogweed.so
lib/libhogweed.so.2
-lib/libhogweed.so.2.1
+lib/libhogweed.so.2.2
lib/libnettle.a
lib/libnettle.so
lib/libnettle.so.4
-lib/libnettle.so.4.3
+lib/libnettle.so.4.4
libdata/pkgconfig/nettle.pc
libdata/pkgconfig/hogweed.pc
%%PORTDOCS%%%%DOCSDIR%%/NEWS
@@ -56,10 +57,11 @@ libdata/pkgconfig/hogweed.pc
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/nettle.html
%%PORTDOCS%%%%DOCSDIR%%/nettle.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base16dec.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base16enc.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base64dec.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/base64enc.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eratosthenes.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getopt.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getopt.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getopt1.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/io.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/io.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nettle-benchmark.c