aboutsummaryrefslogtreecommitdiff
path: root/security/nettle
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-12-01 09:16:16 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-12-01 09:16:16 +0000
commit50e820083d422e7a6c2ea4935ae31f9473407eaf (patch)
tree4dd0908f7f5466ee6cd945039522296805821e25 /security/nettle
parentc04ed7243ffec5446c2e64ce1c4ba929fcd0bcd7 (diff)
downloadports-50e820083d422e7a6c2ea4935ae31f9473407eaf.tar.gz
ports-50e820083d422e7a6c2ea4935ae31f9473407eaf.zip
Enable stage support; no functional changes
Notes
Notes: svn path=/head/; revision=335369
Diffstat (limited to 'security/nettle')
-rw-r--r--security/nettle/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index 6aee9c34ec27..539175591672 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -15,9 +15,9 @@ COMMENT= Low-level cryptographic library
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING.LIB
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
-USE_GMAKE= yes
+USES= gmake
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= M4="/usr/bin/m4 -g"
@@ -32,7 +32,6 @@ PORTDOCS= NEWS README TODO nettle.html nettle.pdf
PORTEXAMPLES= *.c *.h
INFO= nettle
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
@@ -43,12 +42,13 @@ CONFIGURE_ENV+= CCPIC=-fPIC
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} examples/${PORTEXAMPLES} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${INSTALL_DATA} ${PORTEXAMPLES} \
+ ${STAGEDIR}${EXAMPLESDIR}
.endif
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.post.mk>