aboutsummaryrefslogtreecommitdiff
path: root/security/nettle
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-17 12:57:41 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-17 12:57:41 +0000
commit78899770b1aa1385e60dcd1dd8d05f18a4f12eda (patch)
treee96a0b00823f0725092cf61d71701af4b93ca31c /security/nettle
parent083f606dda3c9b1397a5e0e3b76e4bc811fc9a6d (diff)
downloadports-78899770b1aa1385e60dcd1dd8d05f18a4f12eda.tar.gz
ports-78899770b1aa1385e60dcd1dd8d05f18a4f12eda.zip
- Use = instead of += for CONFIGURE_ENV
- Use USES=localbase - Use USES=pathfix - Use USES=ssl - Reformat pkg-descr - Update WWW: use https://
Notes
Notes: svn path=/head/; revision=428740
Diffstat (limited to 'security/nettle')
-rw-r--r--security/nettle/Makefile38
-rw-r--r--security/nettle/distinfo1
-rw-r--r--security/nettle/pkg-descr9
3 files changed, 22 insertions, 26 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index ad030a24fdf8..ba167a4050c0 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -5,35 +5,32 @@ PORTNAME= nettle
PORTVERSION= 3.2
CATEGORIES= security
MASTER_SITES= GNU \
- http://www.lysator.liu.se/~nisse/archive/:liu \
- ftp://ftp.lysator.liu.se/pub/security/lsh/:liu
+ http://www.lysator.liu.se/~nisse/archive/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Low-level cryptographic library
-LICENSE= LGPL3 GPLv2+
+LICENSE= GPLv2+ LGPL3
LICENSE_COMB= multi
+LICENSE_FILE_GPLv2= ${WRKSRC}/COPYINGv2
+LICENSE_FILE_GPLv3= ${WRKSRC}/COPYINGv3
+LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING.LESSERv3
LIB_DEPENDS= libgmp.so:math/gmp
-USES= gmake makeinfo
-USE_OPENSSL= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV+= M4="/usr/bin/m4 -g"
-CONFIGURE_ARGS= --enable-shared
-MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+OPTIONS_DEFINE= DOCS EXAMPLES
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --enable-shared
+CONFIGURE_ENV= M4="/usr/bin/m4 -g"
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USES= gmake localbase makeinfo pathfix ssl
+INFO= nettle
PORTDOCS= NEWS README TODO nettle.html nettle.pdf
PORTEXAMPLES= *.c *.h
-INFO= nettle
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "sparc64"
CONFIGURE_ENV+= CCPIC=-fPIC
@@ -42,13 +39,12 @@ CONFIGURE_ENV+= CCPIC=-fPIC
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*.so
-post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${INSTALL_DATA} ${PORTEXAMPLES} \
- ${STAGEDIR}${EXAMPLESDIR}
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/security/nettle/distinfo b/security/nettle/distinfo
index 70dab012b019..1d78b3901a53 100644
--- a/security/nettle/distinfo
+++ b/security/nettle/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1481791671
SHA256 (nettle-3.2.tar.gz) = ea4283def236413edab5a4cf9cf32adf540c8df1b9b67641cfc2302fca849d97
SIZE (nettle-3.2.tar.gz) = 1879604
diff --git a/security/nettle/pkg-descr b/security/nettle/pkg-descr
index e9e262fcac2d..28d114a76096 100644
--- a/security/nettle/pkg-descr
+++ b/security/nettle/pkg-descr
@@ -1,6 +1,5 @@
-Nettle is a cryptographic library that is designed to fit easily in more or
-less any context: In crypto toolkits for object-oriented languages (C++,
-Python, Pike, ...), in applications like LSH or GNUPG, or even in kernel
-space.
+Nettle is a cryptographic library that is designed to fit easily in more or less
+any context: In crypto toolkits for object-oriented languages (C++, Python,
+Pike, ...), in applications like LSH or GNUPG, or even in kernel space.
-WWW: http://www.lysator.liu.se/~nisse/nettle/
+WWW: https://www.lysator.liu.se/~nisse/nettle/