aboutsummaryrefslogtreecommitdiff
path: root/security/nextcloud-end_to_end_encryption
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2020-08-22 12:07:45 +0000
committerBernard Spil <brnrd@FreeBSD.org>2020-08-22 12:07:45 +0000
commitacf0ce9015f22d46664f9026f3f2c9a0a28ca90e (patch)
tree71b7ab0ab7f669ee8a5cb0db7e4bf0550fb32af2 /security/nextcloud-end_to_end_encryption
parentf63e8ec482a7d4c84b7639140fe053ec365de649 (diff)
downloadports-acf0ce9015f22d46664f9026f3f2c9a0a28ca90e.tar.gz
ports-acf0ce9015f22d46664f9026f3f2c9a0a28ca90e.zip
security/nextcloud-end_to_end_encryption: Add new port
* No longer marked pre-production
Notes
Notes: svn path=/head/; revision=545761
Diffstat (limited to 'security/nextcloud-end_to_end_encryption')
-rw-r--r--security/nextcloud-end_to_end_encryption/Makefile34
-rw-r--r--security/nextcloud-end_to_end_encryption/distinfo3
-rw-r--r--security/nextcloud-end_to_end_encryption/pkg-descr3
-rw-r--r--security/nextcloud-end_to_end_encryption/pkg-plist157
4 files changed, 197 insertions, 0 deletions
diff --git a/security/nextcloud-end_to_end_encryption/Makefile b/security/nextcloud-end_to_end_encryption/Makefile
new file mode 100644
index 000000000000..a33431178281
--- /dev/null
+++ b/security/nextcloud-end_to_end_encryption/Makefile
@@ -0,0 +1,34 @@
+# Created by: Bernard Spil <brnrd@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= end_to_end_encryption
+PORTVERSION= 1.5.2
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+MASTER_SITES= https://github.com/${PKGNAMEPREFIX:S/-//}/${PORTNAME}/releases/download/${DISTVERSIONPREFIX}${PORTVERSION}/
+PKGNAMEPREFIX= nextcloud-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}/${DISTNAME}
+
+MAINTAINER= brnrd@freebsd.org
+COMMENT= End-to-End Encryption app for Nextcloud
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=19:www/nextcloud@${PHP_FLAVOR}
+
+USES= php:flavors
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR= ${PREFIX}/www/nextcloud/apps-pkg/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+ ${RM} ${STAGEDIR}${WWWDIR}/COPYING
+
+.include <bsd.port.mk>
diff --git a/security/nextcloud-end_to_end_encryption/distinfo b/security/nextcloud-end_to_end_encryption/distinfo
new file mode 100644
index 000000000000..fdaef439ae50
--- /dev/null
+++ b/security/nextcloud-end_to_end_encryption/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1598090225
+SHA256 (nextcloud/end_to_end_encryption/end_to_end_encryption.tar.gz) = 5d15e832959b57f2c7c8f6228ebabfb744c59611bf4305077418a837d7f16a53
+SIZE (nextcloud/end_to_end_encryption/end_to_end_encryption.tar.gz) = 75778
diff --git a/security/nextcloud-end_to_end_encryption/pkg-descr b/security/nextcloud-end_to_end_encryption/pkg-descr
new file mode 100644
index 000000000000..7a23b160f774
--- /dev/null
+++ b/security/nextcloud-end_to_end_encryption/pkg-descr
@@ -0,0 +1,3 @@
+Provides the necessary endpoint to enable end-to-end encryption
+
+WWW: https://apps.nextcloud.com/apps/end_to_end_encryption
diff --git a/security/nextcloud-end_to_end_encryption/pkg-plist b/security/nextcloud-end_to_end_encryption/pkg-plist
new file mode 100644
index 000000000000..6ed5fa79e521
--- /dev/null
+++ b/security/nextcloud-end_to_end_encryption/pkg-plist
@@ -0,0 +1,157 @@
+@comment %%WWWDIR%%/.DS_Store
+@comment %%WWWDIR%%/.php_cs.dist
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/SECURITY.md
+%%WWWDIR%%/appinfo/app.php
+%%WWWDIR%%/appinfo/info.xml
+%%WWWDIR%%/appinfo/routes.php
+%%WWWDIR%%/img/app.svg
+%%WWWDIR%%/l10n/.gitkeep
+%%WWWDIR%%/l10n/ar.js
+%%WWWDIR%%/l10n/ar.json
+%%WWWDIR%%/l10n/ast.js
+%%WWWDIR%%/l10n/ast.json
+%%WWWDIR%%/l10n/bg.js
+%%WWWDIR%%/l10n/bg.json
+%%WWWDIR%%/l10n/ca.js
+%%WWWDIR%%/l10n/ca.json
+%%WWWDIR%%/l10n/cs.js
+%%WWWDIR%%/l10n/cs.json
+%%WWWDIR%%/l10n/da.js
+%%WWWDIR%%/l10n/da.json
+%%WWWDIR%%/l10n/de.js
+%%WWWDIR%%/l10n/de.json
+%%WWWDIR%%/l10n/de_DE.js
+%%WWWDIR%%/l10n/de_DE.json
+%%WWWDIR%%/l10n/el.js
+%%WWWDIR%%/l10n/el.json
+%%WWWDIR%%/l10n/en_GB.js
+%%WWWDIR%%/l10n/en_GB.json
+%%WWWDIR%%/l10n/eo.js
+%%WWWDIR%%/l10n/eo.json
+%%WWWDIR%%/l10n/es.js
+%%WWWDIR%%/l10n/es.json
+%%WWWDIR%%/l10n/es_419.js
+%%WWWDIR%%/l10n/es_419.json
+%%WWWDIR%%/l10n/es_CL.js
+%%WWWDIR%%/l10n/es_CL.json
+%%WWWDIR%%/l10n/es_CO.js
+%%WWWDIR%%/l10n/es_CO.json
+%%WWWDIR%%/l10n/es_CR.js
+%%WWWDIR%%/l10n/es_CR.json
+%%WWWDIR%%/l10n/es_DO.js
+%%WWWDIR%%/l10n/es_DO.json
+%%WWWDIR%%/l10n/es_EC.js
+%%WWWDIR%%/l10n/es_EC.json
+%%WWWDIR%%/l10n/es_GT.js
+%%WWWDIR%%/l10n/es_GT.json
+%%WWWDIR%%/l10n/es_HN.js
+%%WWWDIR%%/l10n/es_HN.json
+%%WWWDIR%%/l10n/es_MX.js
+%%WWWDIR%%/l10n/es_MX.json
+%%WWWDIR%%/l10n/es_NI.js
+%%WWWDIR%%/l10n/es_NI.json
+%%WWWDIR%%/l10n/es_PA.js
+%%WWWDIR%%/l10n/es_PA.json
+%%WWWDIR%%/l10n/es_PE.js
+%%WWWDIR%%/l10n/es_PE.json
+%%WWWDIR%%/l10n/es_PR.js
+%%WWWDIR%%/l10n/es_PR.json
+%%WWWDIR%%/l10n/es_PY.js
+%%WWWDIR%%/l10n/es_PY.json
+%%WWWDIR%%/l10n/es_SV.js
+%%WWWDIR%%/l10n/es_SV.json
+%%WWWDIR%%/l10n/es_UY.js
+%%WWWDIR%%/l10n/es_UY.json
+%%WWWDIR%%/l10n/eu.js
+%%WWWDIR%%/l10n/eu.json
+%%WWWDIR%%/l10n/fi.js
+%%WWWDIR%%/l10n/fi.json
+%%WWWDIR%%/l10n/fr.js
+%%WWWDIR%%/l10n/fr.json
+%%WWWDIR%%/l10n/gl.js
+%%WWWDIR%%/l10n/gl.json
+%%WWWDIR%%/l10n/he.js
+%%WWWDIR%%/l10n/he.json
+%%WWWDIR%%/l10n/hr.js
+%%WWWDIR%%/l10n/hr.json
+%%WWWDIR%%/l10n/hu.js
+%%WWWDIR%%/l10n/hu.json
+%%WWWDIR%%/l10n/is.js
+%%WWWDIR%%/l10n/is.json
+%%WWWDIR%%/l10n/it.js
+%%WWWDIR%%/l10n/it.json
+%%WWWDIR%%/l10n/ja.js
+%%WWWDIR%%/l10n/ja.json
+%%WWWDIR%%/l10n/ka_GE.js
+%%WWWDIR%%/l10n/ka_GE.json
+%%WWWDIR%%/l10n/ko.js
+%%WWWDIR%%/l10n/ko.json
+%%WWWDIR%%/l10n/lt_LT.js
+%%WWWDIR%%/l10n/lt_LT.json
+%%WWWDIR%%/l10n/lv.js
+%%WWWDIR%%/l10n/lv.json
+%%WWWDIR%%/l10n/nb.js
+%%WWWDIR%%/l10n/nb.json
+%%WWWDIR%%/l10n/nl.js
+%%WWWDIR%%/l10n/nl.json
+%%WWWDIR%%/l10n/pl.js
+%%WWWDIR%%/l10n/pl.json
+%%WWWDIR%%/l10n/pt_BR.js
+%%WWWDIR%%/l10n/pt_BR.json
+%%WWWDIR%%/l10n/pt_PT.js
+%%WWWDIR%%/l10n/pt_PT.json
+%%WWWDIR%%/l10n/ro.js
+%%WWWDIR%%/l10n/ro.json
+%%WWWDIR%%/l10n/ru.js
+%%WWWDIR%%/l10n/ru.json
+%%WWWDIR%%/l10n/sk.js
+%%WWWDIR%%/l10n/sk.json
+%%WWWDIR%%/l10n/sl.js
+%%WWWDIR%%/l10n/sl.json
+%%WWWDIR%%/l10n/sq.js
+%%WWWDIR%%/l10n/sq.json
+%%WWWDIR%%/l10n/sr.js
+%%WWWDIR%%/l10n/sr.json
+%%WWWDIR%%/l10n/sv.js
+%%WWWDIR%%/l10n/sv.json
+%%WWWDIR%%/l10n/tr.js
+%%WWWDIR%%/l10n/tr.json
+%%WWWDIR%%/l10n/uk.js
+%%WWWDIR%%/l10n/uk.json
+%%WWWDIR%%/l10n/zh_CN.js
+%%WWWDIR%%/l10n/zh_CN.json
+%%WWWDIR%%/l10n/zh_TW.js
+%%WWWDIR%%/l10n/zh_TW.json
+%%WWWDIR%%/lib/AppInfo/Application.php
+%%WWWDIR%%/lib/BackgroundJob/RollbackBackgroundJob.php
+%%WWWDIR%%/lib/Capabilities.php
+%%WWWDIR%%/lib/Connector/Sabre/APlugin.php
+%%WWWDIR%%/lib/Connector/Sabre/LockPlugin.php
+%%WWWDIR%%/lib/Connector/Sabre/PropFindPlugin.php
+%%WWWDIR%%/lib/Connector/Sabre/RedirectRequestPlugin.php
+%%WWWDIR%%/lib/Controller/EncryptionController.php
+%%WWWDIR%%/lib/Controller/KeyController.php
+%%WWWDIR%%/lib/Controller/LockingController.php
+%%WWWDIR%%/lib/Controller/MetaDataController.php
+%%WWWDIR%%/lib/Db/Lock.php
+%%WWWDIR%%/lib/Db/LockMapper.php
+%%WWWDIR%%/lib/EncryptionManager.php
+%%WWWDIR%%/lib/Exceptions/FileLockedException.php
+%%WWWDIR%%/lib/Exceptions/FileNotLockedException.php
+%%WWWDIR%%/lib/Exceptions/KeyExistsException.php
+%%WWWDIR%%/lib/Exceptions/MetaDataExistsException.php
+%%WWWDIR%%/lib/Exceptions/MissingMetaDataException.php
+%%WWWDIR%%/lib/FileService.php
+%%WWWDIR%%/lib/IKeyStorage.php
+%%WWWDIR%%/lib/IMetaDataStorage.php
+%%WWWDIR%%/lib/KeyStorage.php
+%%WWWDIR%%/lib/LockManager.php
+%%WWWDIR%%/lib/MetaDataStorage.php
+%%WWWDIR%%/lib/Middleware/UserAgentCheckMiddleware.php
+%%WWWDIR%%/lib/Migration/Version1005Date20200312102456.php
+%%WWWDIR%%/lib/Migration/Version1005Date20200312161123.php
+%%WWWDIR%%/lib/RollbackService.php
+%%WWWDIR%%/lib/SignatureHandler.php
+%%WWWDIR%%/lib/UserAgentManager.php
+%%WWWDIR%%/lib/UserManager.php