aboutsummaryrefslogtreecommitdiff
path: root/security/nextcloud-twofactor_nextcloud_notification
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2021-10-10 17:59:45 +0000
committerBernard Spil <brnrd@FreeBSD.org>2021-10-10 17:59:45 +0000
commit7c5046b3bdc9d72791f7538a16e7a56479261361 (patch)
treeab331973a7d5954071a12e9b875c37c25952977a /security/nextcloud-twofactor_nextcloud_notification
parent46bcb098c82f7a18c7667fc99f6a7824b2b6eeef (diff)
downloadports-7c5046b3bdc9d72791f7538a16e7a56479261361.tar.gz
ports-7c5046b3bdc9d72791f7538a16e7a56479261361.zip
security/nextcloud-twofactor_nextcloud_notification: Add new port
Diffstat (limited to 'security/nextcloud-twofactor_nextcloud_notification')
-rw-r--r--security/nextcloud-twofactor_nextcloud_notification/Makefile38
-rw-r--r--security/nextcloud-twofactor_nextcloud_notification/distinfo3
-rw-r--r--security/nextcloud-twofactor_nextcloud_notification/pkg-descr3
3 files changed, 44 insertions, 0 deletions
diff --git a/security/nextcloud-twofactor_nextcloud_notification/Makefile b/security/nextcloud-twofactor_nextcloud_notification/Makefile
new file mode 100644
index 000000000000..e30b5ac22714
--- /dev/null
+++ b/security/nextcloud-twofactor_nextcloud_notification/Makefile
@@ -0,0 +1,38 @@
+# Created by: Bernard Spil <brnrd@freebsd.org>
+
+PORTNAME= twofactor_nextcloud_notification
+PORTVERSION= 3.2.1
+CATEGORIES= security
+MASTER_SITES= https://github.com/nickv-nextcloud/${PORTNAME}/releases/download/v${DISTVERSIONPREFIX}${PORTVERSION}/
+PKGNAMEPREFIX= nextcloud-
+PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAINTAINER= brnrd@FreeBSD.org
+COMMENT= Use Nextcloud notification as MFA app for Nextcloud
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= nextcloud${PHP_PKGNAMESUFFIX}>=17:www/nextcloud@${PHP_FLAVOR}
+
+USES= php:flavors
+NO_BUILD= yes
+NO_ARCH= yes
+
+NEXTCLOUD_USERNAME?= ${WWWOWN}
+NEXTCLOUD_GROUPNAME?= ${WWWGRP}
+
+PLIST_SUB= NEXTCLOUD_USERNAME=${NEXTCLOUD_USERNAME} \
+ NEXTCLOUD_GROUPNAME=${NEXTCLOUD_GROUPNAME}
+
+WWWDIR= ${PREFIX}/www/nextcloud/apps-pkg/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+ @(cd ${WRKSRC}; ${FIND} . -not -type d) | ${SORT} | \
+ ${SED} -e 's,^\.,${WWWDIR_REL},' >> ${TMPPLIST}
+
+
+.include <bsd.port.mk>
diff --git a/security/nextcloud-twofactor_nextcloud_notification/distinfo b/security/nextcloud-twofactor_nextcloud_notification/distinfo
new file mode 100644
index 000000000000..9898b31b9acb
--- /dev/null
+++ b/security/nextcloud-twofactor_nextcloud_notification/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1633887796
+SHA256 (twofactor_nextcloud_notification-3.2.1.tar.gz) = de5a4fe9fc206d9cf3d7627100d5acadcc1f59c3fa7d652e7eb02707d201b326
+SIZE (twofactor_nextcloud_notification-3.2.1.tar.gz) = 814467
diff --git a/security/nextcloud-twofactor_nextcloud_notification/pkg-descr b/security/nextcloud-twofactor_nextcloud_notification/pkg-descr
new file mode 100644
index 000000000000..6f2fbee89697
--- /dev/null
+++ b/security/nextcloud-twofactor_nextcloud_notification/pkg-descr
@@ -0,0 +1,3 @@
+Allows using any of your logged in devices as second factor
+
+WWW: https://apps.nextcloud.com/apps/twofactor_nextcloud_notification