aboutsummaryrefslogtreecommitdiff
path: root/security/nmap/Makefile
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2016-09-17 00:13:38 +0000
committerBen Woods <woodsb02@FreeBSD.org>2016-09-17 00:13:38 +0000
commite50b5c5e8d425ee35d7b5f8c36cffb35a354db77 (patch)
tree04b8a5dccd2d9e98c88e04e84781725268276d55 /security/nmap/Makefile
parent6efcbda657795ad9210013f87267c64df27dacea (diff)
downloadports-e50b5c5e8d425ee35d7b5f8c36cffb35a354db77.tar.gz
ports-e50b5c5e8d425ee35d7b5f8c36cffb35a354db77.zip
security/zenmap: Update to 7.25 BETA2 and use security/nmap as MASTERDIR
security/nmap: - Ensure MAINTAINER and COMMENT do not clobber those of slave port - Add .if !defined(MASTERDIR) to prevent inclusion in slave port - Do not include bsd.port.options.mk, as none of the features are used security/zenmap: - Convert to slave of security/nmap to ensure they are updated in lockstep - Inherently update to 7.25 BETA2 (current version of security/nmap) - Take maintainership - Remove redundant port header variables included from MASTERDIR - PKGNAME of zenmap achieved using PKGNAMEPREFIX=ze and PORTNAME=nmap - Inherit LICENSE_FILE, as zenmap/COPYING states it is the same as nmap - Set directory variables so they are not inhereted from MASTERDIR - Convert post-extract to post-patch, as it is modifying WRKSRC files - Fix REINPLACE command, as it was leaving the line with nothing but a single ',' and causing the build to fail - Do not download external zenmap icon, as one is included in distfile Approved by: ohauer (security/nmap maintainer), mat (mentor) Differential Revision: https://reviews.freebsd.org/D7880
Notes
Notes: svn path=/head/; revision=422291
Diffstat (limited to 'security/nmap/Makefile')
-rw-r--r--security/nmap/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 1c434f7ae6ab..f779c8495edf 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -7,8 +7,8 @@ CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
-MAINTAINER= ohauer@FreeBSD.org
-COMMENT= Port scanning utility for large networks
+MAINTAINER?= ohauer@FreeBSD.org
+COMMENT?= Port scanning utility for large networks
# nmap-6.47 => svn.nmap.org/nmap-releases/nmap-6.47 (r33605)
# http://nmap.org/book/man-legal.html
@@ -17,6 +17,8 @@ COMMENT= Port scanning utility for large networks
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+.if !defined(MASTERDIR)
+
LIB_DEPENDS= libpcre.so:devel/pcre
USES= tar:bzip2 gmake cpe
@@ -33,8 +35,6 @@ SSL_CONFIGURE_OFF= --without-openssl
SSL_CFLAGS= -I${OPENSSLINC}
SSL_VARS= STRIP_FILES=ncat
-.include <bsd.port.options.mk>
-
DOCS= CHANGELOG HACKING
STRIP_FILES+= nmap nping
@@ -62,4 +62,6 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+.endif
+
.include <bsd.port.mk>