aboutsummaryrefslogtreecommitdiff
path: root/security/nmap
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2011-04-20 23:09:04 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2011-04-20 23:09:04 +0000
commit911ff9e84fbff2cca873ff5925e13378b73f4203 (patch)
tree646579b01ae2464b00e7bc0e0a610a5768bf19d6 /security/nmap
parent60bdbec25e431944d2b2fc868b0b05ca3be41118 (diff)
downloadports-911ff9e84fbff2cca873ff5925e13378b73f4203.tar.gz
ports-911ff9e84fbff2cca873ff5925e13378b73f4203.zip
Notes
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile1
-rw-r--r--security/nmap/files/patch-TargetGroup.cc12
2 files changed, 13 insertions, 0 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 5340fc73877e..8b7b31a2e43d 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nmap
PORTVERSION= 5.51
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
diff --git a/security/nmap/files/patch-TargetGroup.cc b/security/nmap/files/patch-TargetGroup.cc
new file mode 100644
index 000000000000..46af812ce807
--- /dev/null
+++ b/security/nmap/files/patch-TargetGroup.cc
@@ -0,0 +1,12 @@
+--- ./TargetGroup.cc.orig 2011-01-21 01:04:16.000000000 +0100
++++ ./TargetGroup.cc 2011-04-21 00:55:50.000000000 +0200
+@@ -220,7 +220,8 @@
+ resolvedaddrs.push_back(ss);
+ }
+ }
+- freeaddrinfo(addrs);
++ if(addrs)
++ freeaddrinfo(addrs);
+
+ if (resolvedaddrs.empty()) {
+ error("Failed to resolve given hostname/IP: %s. Note that you can't use '/mask' AND '1-4,7,100-' style IP ranges", target_net);