aboutsummaryrefslogtreecommitdiff
path: root/security/nmap
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-12-25 13:29:28 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-12-25 13:29:28 +0000
commitb73fe035fc78d0e7a385b0bfeeec901184da5031 (patch)
treef093963522496142bd31442dbbde2a3d83acfb9c /security/nmap
parent5aecba4a851e43d46ce8ceddba9cdf06a3156c18 (diff)
downloadports-b73fe035fc78d0e7a385b0bfeeec901184da5031.tar.gz
ports-b73fe035fc78d0e7a385b0bfeeec901184da5031.zip
- fix build on arm/mips
PR: 196065 Submitted by: mikael.urankar
Notes
Notes: svn path=/head/; revision=375549
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 00c06ff984f2..d1483cae3c36 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -19,7 +19,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-USES= tar:bzip2 gmake cpe
+USES= tar:bzip2 gmake cpe compiler
GNU_CONFIGURE= yes
OPTIONS_SUB= yes
@@ -54,8 +54,10 @@ CONFIGURE_ARGS+=--without-localdirs \
--with-liblua=included \
--without-nmap-update
+.include <bsd.port.pre.mk>
+
# fix for gcc from ports
-.if ${CC} != "cc" && ${CC} !="clang" && !${CC:M*ccache/cc}
+.if ${CHOSEN_COMPILER_TYPE} == gcc
GCCLIBDIR_CMDS= ${CC} -print-file-name=libstdc++.so | ${SED} -e 's/libstdc++.so//'
CONFIGURE_ARGS+=LDFLAGS="-L$$(${GCCLIBDIR_CMDS})"
NOT_BASE_CC= true
@@ -81,4 +83,4 @@ post-install:
@${ECHO_MSG} do not forget to adjust libnmap.conf
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>