aboutsummaryrefslogtreecommitdiff
path: root/security/nmap
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-07-01 03:38:04 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-07-01 03:38:04 +0000
commitd8a8887c96ff96479cb5767d7f2d41bae885d950 (patch)
tree158703c8066c16517cd2408f5cd07250f57bffd2 /security/nmap
parent81e7742353792c3fc1899abc7ab61932f2678347 (diff)
downloadports-d8a8887c96ff96479cb5767d7f2d41bae885d950.tar.gz
ports-d8a8887c96ff96479cb5767d7f2d41bae885d950.zip
Notes
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile3
-rw-r--r--security/nmap/distinfo2
-rw-r--r--security/nmap/files/patch-aa28
-rw-r--r--security/nmap/files/patch-ac11
-rw-r--r--security/nmap/files/patch-nmapfe::Makefile.in (renamed from security/nmap/files/patch-ab)0
-rw-r--r--security/nmap/files/patch-nmapfe::nmapfe_sig.c11
-rw-r--r--security/nmap/pkg-plist1
7 files changed, 14 insertions, 42 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index e800a727b0aa..1a71a80dea01 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME?= nmap
-PORTVERSION= 3.28
+PORTVERSION= 3.30
CATEGORIES= security ipv6
MASTER_SITES= http://download.insecure.org/nmap/dist/
DISTNAME= nmap-${PORTVERSION:S/.b/BETA/}
@@ -16,6 +16,7 @@ MAINTAINER= dominic.marks@btinternet.com
COMMENT?= Port scanning utility for large networks
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-localdirs
USE_BZIP2= yes
MAN1?= nmap.1
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
index ffb0eb1ac3cb..962e2afc04d4 100644
--- a/security/nmap/distinfo
+++ b/security/nmap/distinfo
@@ -1 +1 @@
-MD5 (nmap-3.28.tar.bz2) = ac46d6d7a5f7eec8d0281f656c23f2b4
+MD5 (nmap-3.30.tar.bz2) = 639fc1c91f48319eca97401e74f9c90e
diff --git a/security/nmap/files/patch-aa b/security/nmap/files/patch-aa
deleted file mode 100644
index 65f57295798d..000000000000
--- a/security/nmap/files/patch-aa
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.in.orig Fri Mar 9 22:25:19 2001
-+++ Makefile.in Sun May 27 17:49:17 2001
-@@ -9,14 +9,14 @@
- mandir = @mandir@
- srcdir = @srcdir@
- nmapdatadir = @datadir@/nmap
--deskdir = $(prefix)/share/gnome/apps/Utilities
-+deskdir = $(X11BASE)/share/gnome/apps/Utilities
-
- NBASEDIR=@NBASEDIR@
- CC = @CC@
- CXX = @CXX@
- CCOPT =
- LIBPCAPDIR = @libpcapdir@
--INCLS = -I$(LIBPCAPDIR)
-+#INCLS = -I$(LIBPCAPDIR)
- DEFS = @DEFS@ -DNMAP_VERSION=\"$(NMAP_VERSION)\" -DNMAP_NAME=\"$(NMAP_NAME)\" -DNMAP_URL=\"$(NMAP_URL)\" -DNMAP_PLATFORM=\"$(NMAP_PLATFORM)\" -DNMAPDATADIR=\"$(nmapdatadir)\"
- # For mtrace debugging -- see MTRACE define in main.cc for instructions
- # Should only be enabled during debugging and not in any real release.
-@@ -200,7 +200,7 @@
- $(MAKEDEPEND) $(INCLS) -s "# DO NOT DELETE" -- $(DEFS) -- $(SRCS)
-
- install-nmap: $(TARGET)
-- $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(nmapdatadir) $(deskdir)
-+ $(SHTOOL) mkdir -f -p -m 755 $(bindir) $(mandir)/man1 $(nmapdatadir)
- $(INSTALL) -c -m 755 nmap $(bindir)/nmap
- $(INSTALL) -c -m 644 docs/$(TARGET).1 $(mandir)/man1/$(TARGET).1
- $(INSTALL) -c -m 644 nmap-os-fingerprints $(nmapdatadir)/nmap-os-fingerprints
diff --git a/security/nmap/files/patch-ac b/security/nmap/files/patch-ac
deleted file mode 100644
index 1e6ede83aceb..000000000000
--- a/security/nmap/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- nmapfe/nmapfe_sig.c.old Sun Jun 15 17:37:46 2003
-+++ nmapfe/nmapfe_sig.c Sun Jun 15 17:44:47 2003
-@@ -433,7 +433,7 @@
- if (size > command_size)
- command = realloc(command, size);
-
-- strcpy(command, "nmap ");
-+ strcpy(command, NMAP_PATH "nmap ");
- /* Uhm... yeah.. Spit out which scan to perform based
- on the which_scan variable */
-
diff --git a/security/nmap/files/patch-ab b/security/nmap/files/patch-nmapfe::Makefile.in
index 2f9fb638b978..2f9fb638b978 100644
--- a/security/nmap/files/patch-ab
+++ b/security/nmap/files/patch-nmapfe::Makefile.in
diff --git a/security/nmap/files/patch-nmapfe::nmapfe_sig.c b/security/nmap/files/patch-nmapfe::nmapfe_sig.c
new file mode 100644
index 000000000000..5345d6cf0c97
--- /dev/null
+++ b/security/nmap/files/patch-nmapfe::nmapfe_sig.c
@@ -0,0 +1,11 @@
+--- nmapfe/nmapfe_sig.c Mon Jun 30 18:23:48 2003
++++ nmapfe/nmapfe_sig.c.new Mon Jun 30 18:26:03 2003
+@@ -372,7 +372,7 @@
+ if (size > command_size)
+ command = realloc(command, size);
+
+- strcpy(command, "nmap ");
++ strcpy(command, NMAP_PATH "nmap ");
+
+ /* select the scan type */
+ if (opt.scanValue == CONNECT_SCAN) { \ No newline at end of file
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
index 93a402d54dfa..e4bc645405b4 100644
--- a/security/nmap/pkg-plist
+++ b/security/nmap/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
bin/nmap
share/nmap/nmap-os-fingerprints
share/nmap/nmap-protocols