aboutsummaryrefslogtreecommitdiff
path: root/security/nss/files
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-09-09 18:27:42 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-09-09 18:27:42 +0000
commit57605e2424af65960e9fccca186e869e72c7e56f (patch)
tree08aa5528afdefe726d61860b9f896c3c1f481683 /security/nss/files
parentd4dab6f544dcfbd7783b2789c05b46d020e77ac1 (diff)
downloadports-57605e2424af65960e9fccca186e869e72c7e56f.tar.gz
ports-57605e2424af65960e9fccca186e869e72c7e56f.zip
Notes
Diffstat (limited to 'security/nss/files')
-rw-r--r--security/nss/files/patch-bug3019862
-rw-r--r--security/nss/files/patch-const24
-rw-r--r--security/nss/files/patch-coreconf_FreeBSD.mk17
-rw-r--r--security/nss/files/patch-coreconf_UNIX.mk4
-rw-r--r--security/nss/files/patch-coreconf_arch.mk6
-rw-r--r--security/nss/files/patch-coreconf_command.mk4
-rw-r--r--security/nss/files/patch-coreconf_ruleset.mk4
-rw-r--r--security/nss/files/patch-lib-freebl-Makefile8
-rw-r--r--security/nss/files/patch-lib_freebl_mpi_mpcpucache.c4
-rw-r--r--security/nss/files/patch-lib_softoken_pkcs11c.c10
-rw-r--r--security/nss/files/patch-sysdb97
-rw-r--r--security/nss/files/patch-tests12
12 files changed, 100 insertions, 92 deletions
diff --git a/security/nss/files/patch-bug301986 b/security/nss/files/patch-bug301986
index 9ae42321f152..ca5795e0d72b 100644
--- a/security/nss/files/patch-bug301986
+++ b/security/nss/files/patch-bug301986
@@ -1,4 +1,4 @@
---- lib/util/nssilckt.h~
+--- lib/util/nssilckt.h.orig 2018-08-31 12:55:53 UTC
+++ lib/util/nssilckt.h
@@ -163,7 +163,7 @@ typedef enum {
** Declare the trace record
diff --git a/security/nss/files/patch-const b/security/nss/files/patch-const
index ccefa75c7825..8c04e31b2458 100644
--- a/security/nss/files/patch-const
+++ b/security/nss/files/patch-const
@@ -1,23 +1,27 @@
---- cmd/modutil/modutil.h Sun Apr 25 11:02:47 2004
-+++ cmd/modutil/modutil.h Fri Jul 22 17:35:20 2005
-@@ -53,6 +53,6 @@
+--- cmd/modutil/modutil.h.orig 2018-08-31 12:55:53 UTC
++++ cmd/modutil/modutil.h
+@@ -22,8 +22,8 @@
#include "error.h"
+ Error LoadMechanismList(void);
-Error FipsMode(char *arg);
-Error ChkFipsMode(char *arg);
+Error FipsMode(const char *arg);
+Error ChkFipsMode(const char *arg);
Error AddModule(char *moduleName, char *libFile, char *ciphers,
- char *mechanisms, char* modparms);
---- cmd/modutil/pk11.c Sun Apr 25 11:02:47 2004
-+++ cmd/modutil/pk11.c Fri Jul 22 17:36:48 2005
-@@ -53,5 +53,5 @@
+ char *mechanisms, char *modparms);
+ Error DeleteModule(char *moduleName);
+--- cmd/modutil/pk11.c.orig 2018-08-31 12:55:53 UTC
++++ cmd/modutil/pk11.c
+@@ -16,7 +16,7 @@
+ * disable FIPS mode on the internal module.
*/
Error
-FipsMode(char *arg)
+FipsMode(const char *arg)
{
char *internal_name;
+
@@ -25,16 +25,18 @@ FipsMode(char *arg)
internal_name = PR_smprintf("%s",
SECMOD_GetInternalModule()->commonName);
@@ -39,10 +43,12 @@
PR_fprintf(PR_STDOUT, msgStrings[FIPS_ENABLED_MSG]);
} else {
PR_fprintf(PR_STDERR, errStrings[FIPS_ALREADY_ON_ERR]);
-@@ -112,5 +114,5 @@
+@@ -75,7 +77,7 @@ FipsMode(char *arg)
+ * If arg=="false", verify FIPS mode is disabled on the internal module.
*/
Error
-ChkFipsMode(char *arg)
+ChkFipsMode(const char *arg)
{
- if(!PORT_Strcasecmp(arg, "true")) {
+ if (!PORT_Strcasecmp(arg, "true")) {
+ if (PK11_IsFIPS()) {
diff --git a/security/nss/files/patch-coreconf_FreeBSD.mk b/security/nss/files/patch-coreconf_FreeBSD.mk
index 2cbc8d92fefd..16badb8b7caf 100644
--- a/security/nss/files/patch-coreconf_FreeBSD.mk
+++ b/security/nss/files/patch-coreconf_FreeBSD.mk
@@ -1,6 +1,6 @@
---- coreconf/FreeBSD.mk.orig 2009-08-22 07:33:09.000000000 +0200
-+++ coreconf/FreeBSD.mk 2010-03-28 23:01:33.000000000 +0200
-@@ -37,9 +37,9 @@
+--- coreconf/FreeBSD.mk.orig 2018-08-31 12:55:53 UTC
++++ coreconf/FreeBSD.mk
+@@ -5,9 +5,9 @@
include $(CORE_DEPTH)/coreconf/UNIX.mk
@@ -13,7 +13,7 @@
RANLIB = ranlib
CPU_ARCH = $(OS_TEST)
-@@ -52,6 +52,16 @@ endif
+@@ -20,7 +20,17 @@ endif
ifeq ($(CPU_ARCH),amd64)
CPU_ARCH = x86_64
endif
@@ -23,13 +23,14 @@
+ifneq (,$(filter powerpc%, $(CPU_ARCH)))
+CPU_ARCH = ppc
+endif
-+
+
+ifneq (,$(filter %64, $(OS_TEST)))
+USE_64 = 1
+endif
++
+ OS_CFLAGS = $(DSO_CFLAGS) -Wall -Wno-switch -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
- OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -Wno-switch -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
-
+ DSO_CFLAGS = -fPIC
@@ -46,7 +56,11 @@ else
DLL_SUFFIX = so.1.0
endif
@@ -43,7 +44,7 @@
ifdef MAPFILE
MKSHLIB += -Wl,--version-script,$(MAPFILE)
endif
-@@ -87,4 +100,5 @@
+@@ -55,4 +69,5 @@ PROCESS_MAP_FILE = grep -v ';-' $< | \
G++INCLUDES = -I/usr/include/g++
diff --git a/security/nss/files/patch-coreconf_UNIX.mk b/security/nss/files/patch-coreconf_UNIX.mk
index 6a020fa14d88..1f940fd8aca4 100644
--- a/security/nss/files/patch-coreconf_UNIX.mk
+++ b/security/nss/files/patch-coreconf_UNIX.mk
@@ -1,6 +1,6 @@
---- coreconf/UNIX.mk~
+--- coreconf/UNIX.mk.orig 2018-08-31 12:55:53 UTC
+++ coreconf/UNIX.mk
-@@ -42,10 +42,8 @@ AR = ar cr $@
+@@ -10,10 +10,8 @@ AR = ar cr $@
LDOPTS += -L$(SOURCE_LIB_DIR)
ifdef BUILD_OPT
diff --git a/security/nss/files/patch-coreconf_arch.mk b/security/nss/files/patch-coreconf_arch.mk
index 5a95a494f72f..3f5c76ab50f4 100644
--- a/security/nss/files/patch-coreconf_arch.mk
+++ b/security/nss/files/patch-coreconf_arch.mk
@@ -1,6 +1,6 @@
---- coreconf/arch.mk.orig 2011-03-03 18:13:52.000000000 +0100
-+++ coreconf/arch.mk 2011-03-03 18:14:09.000000000 +0100
-@@ -66,7 +66,7 @@
+--- coreconf/arch.mk.orig 2018-08-31 12:55:53 UTC
++++ coreconf/arch.mk
+@@ -26,7 +26,7 @@ OS_ARCH := $(subst /,_,$(shell uname -s))
# Attempt to differentiate between sparc and x86 Solaris
#
diff --git a/security/nss/files/patch-coreconf_command.mk b/security/nss/files/patch-coreconf_command.mk
index 43d432b0e432..1d7e801bfea5 100644
--- a/security/nss/files/patch-coreconf_command.mk
+++ b/security/nss/files/patch-coreconf_command.mk
@@ -1,5 +1,5 @@
---- coreconf/command.mk Mon Oct 10 19:46:12 2005
-+++ coreconf/command.mk Wed Jan 18 17:23:28 2006
+--- coreconf/command.mk.orig 2018-08-31 12:55:53 UTC
++++ coreconf/command.mk
@@ -12,7 +12,7 @@ AS = $(CC)
ASFLAGS += $(CFLAGS)
CCF = $(CC) $(CFLAGS)
diff --git a/security/nss/files/patch-coreconf_ruleset.mk b/security/nss/files/patch-coreconf_ruleset.mk
index 44c8b8f03ffc..40b16c35e674 100644
--- a/security/nss/files/patch-coreconf_ruleset.mk
+++ b/security/nss/files/patch-coreconf_ruleset.mk
@@ -1,6 +1,6 @@
---- coreconf/ruleset.mk~
+--- coreconf/ruleset.mk.orig 2018-08-31 12:55:53 UTC
+++ coreconf/ruleset.mk
-@@ -85,7 +85,7 @@
+@@ -53,7 +53,7 @@
#
ifndef COMPILER_TAG
diff --git a/security/nss/files/patch-lib-freebl-Makefile b/security/nss/files/patch-lib-freebl-Makefile
index ff51b6c41df7..b42174292849 100644
--- a/security/nss/files/patch-lib-freebl-Makefile
+++ b/security/nss/files/patch-lib-freebl-Makefile
@@ -1,11 +1,11 @@
---- lib/freebl/Makefile~
+--- lib/freebl/Makefile.orig 2018-08-31 12:55:53 UTC
+++ lib/freebl/Makefile
-@@ -201,7 +201,7 @@ ifeq ($(USE_N32),1)
- endif
+@@ -215,7 +215,7 @@ ifeq ($(CPU_ARCH),x86)
endif
+ endif # Darwin
-ifeq ($(OS_TARGET),Linux)
+ifeq (,$(filter-out Linux FreeBSD, $(OS_TARGET)))
ifeq ($(CPU_ARCH),x86_64)
ASFILES = arcfour-amd64-gas.s mpi_amd64_gas.s
- ASFLAGS += -march=opteron -m64 -fPIC -Wa,--noexecstack
+ ASFLAGS += -fPIC -Wa,--noexecstack
diff --git a/security/nss/files/patch-lib_freebl_mpi_mpcpucache.c b/security/nss/files/patch-lib_freebl_mpi_mpcpucache.c
index e8acd48c08c9..b3ef67131f56 100644
--- a/security/nss/files/patch-lib_freebl_mpi_mpcpucache.c
+++ b/security/nss/files/patch-lib_freebl_mpi_mpcpucache.c
@@ -1,5 +1,5 @@
---- lib/freebl/mpi/mpcpucache.c.orig 2010-06-11 22:39:33.000000000 +0200
-+++ lib/freebl/mpi/mpcpucache.c 2010-06-11 22:40:20.000000000 +0200
+--- lib/freebl/mpi/mpcpucache.c.orig 2018-08-31 12:55:53 UTC
++++ lib/freebl/mpi/mpcpucache.c
@@ -705,6 +705,32 @@ s_mpi_getProcessorLineSize()
#endif
diff --git a/security/nss/files/patch-lib_softoken_pkcs11c.c b/security/nss/files/patch-lib_softoken_pkcs11c.c
index 7bb450ba5220..939bd87d241d 100644
--- a/security/nss/files/patch-lib_softoken_pkcs11c.c
+++ b/security/nss/files/patch-lib_softoken_pkcs11c.c
@@ -1,6 +1,6 @@
---- lib/softoken/pkcs11c.c.orig 2010-05-05 14:36:05.000000000 +0000
-+++ lib/softoken/pkcs11c.c 2010-05-05 14:37:25.000000000 +0000
-@@ -5679,9 +5679,6 @@ sftk_unwrapPrivateKey(SFTKObject *key, S
+--- lib/softoken/pkcs11c.c.orig 2018-08-31 12:55:53 UTC
++++ lib/softoken/pkcs11c.c
+@@ -5772,9 +5772,6 @@ sftk_unwrapPrivateKey(SFTKObject *key, SECItem *bpki)
break;
case NSSLOWKEYDSAKey:
keyType = CKK_DSA;
@@ -10,8 +10,8 @@
crv = sftk_AddAttributeType(key, CKA_KEY_TYPE, &keyType,
sizeof(keyType));
if (crv != CKR_OK)
-@@ -5722,9 +5719,6 @@ sftk_unwrapPrivateKey(SFTKObject *key, S
- #ifndef NSS_DISABLE_ECC
+@@ -5814,9 +5811,6 @@ sftk_unwrapPrivateKey(SFTKObject *key, SECItem *bpki)
+ /* what about fortezza??? */
case NSSLOWKEYECKey:
keyType = CKK_EC;
- crv = (sftk_hasAttribute(key, CKA_NETSCAPE_DB)) ? CKR_OK : CKR_KEY_TYPE_INCONSISTENT;
diff --git a/security/nss/files/patch-sysdb b/security/nss/files/patch-sysdb
index bbef0a77aeb2..1739e021484d 100644
--- a/security/nss/files/patch-sysdb
+++ b/security/nss/files/patch-sysdb
@@ -1,6 +1,6 @@
---- lib/softoken/legacydb/cdbhdl.h.orig 2009-08-31 12:33:12.000000000 +0200
-+++ lib/softoken/legacydb/cdbhdl.h 2009-08-31 12:33:36.000000000 +0200
-@@ -43,7 +43,8 @@
+--- lib/softoken/legacydb/cdbhdl.h.orig 2018-08-31 12:55:53 UTC
++++ lib/softoken/legacydb/cdbhdl.h
+@@ -9,7 +9,8 @@
#define _CDBHDL_H_
#include "nspr.h"
@@ -10,12 +10,11 @@
#include "pcertt.h"
#include "prtypes.h"
-
---- lib/softoken/legacydb/dbmshim.c.orig 2009-08-31 10:40:23.000000000 +0200
-+++ lib/softoken/legacydb/dbmshim.c 2009-08-31 10:40:35.000000000 +0200
-@@ -39,7 +39,8 @@
- *
- * $Id: dbmshim.c,v 1.2 2007/06/13 00:24:57 rrelyea%redhat.com Exp $
+--- lib/softoken/legacydb/dbmshim.c.orig 2018-08-31 12:55:53 UTC
++++ lib/softoken/legacydb/dbmshim.c
+@@ -5,7 +5,8 @@
+ /*
+ * Berkeley DB 1.85 Shim code to handle blobs.
*/
-#include "mcom_db.h"
+#include <db.h>
@@ -23,9 +22,9 @@
#include "secitem.h"
#include "nssb64.h"
#include "blapi.h"
---- lib/softoken/legacydb/keydb.c.orig 2009-08-31 10:40:04.000000000 +0200
-+++ lib/softoken/legacydb/keydb.c 2009-08-31 10:40:08.000000000 +0200
-@@ -43,7 +43,6 @@
+--- lib/softoken/legacydb/keydb.c.orig 2018-08-31 12:55:53 UTC
++++ lib/softoken/legacydb/keydb.c
+@@ -9,7 +9,6 @@
#include "blapi.h"
#include "secitem.h"
#include "pcert.h"
@@ -33,9 +32,9 @@
#include "secerr.h"
#include "keydbi.h"
---- lib/softoken/legacydb/keydbi.h.orig 2009-08-31 12:33:17.000000000 +0200
-+++ lib/softoken/legacydb/keydbi.h 2009-08-31 12:34:13.000000000 +0200
-@@ -43,5 +43,5 @@
+--- lib/softoken/legacydb/keydbi.h.orig 2018-08-31 12:55:53 UTC
++++ lib/softoken/legacydb/keydbi.h
+@@ -10,7 +10,7 @@
#include "nspr.h"
#include "seccomon.h"
@@ -44,9 +43,9 @@
/*
* Handle structure for open key databases
---- lib/softoken/legacydb/pcertdb.c.orig 2009-08-31 10:40:52.000000000 +0200
-+++ lib/softoken/legacydb/pcertdb.c 2009-08-31 10:41:26.000000000 +0200
-@@ -41,7 +41,8 @@
+--- lib/softoken/legacydb/pcertdb.c.orig 2018-08-31 12:55:53 UTC
++++ lib/softoken/legacydb/pcertdb.c
+@@ -7,7 +7,8 @@
*/
#include "lowkeyti.h"
#include "pcert.h"
@@ -56,21 +55,21 @@
#include "pcert.h"
#include "secitem.h"
#include "secder.h"
---- lib/softoken/legacydb/pk11db.c.orig 2009-08-31 10:40:57.000000000 +0200
-+++ lib/softoken/legacydb/pk11db.c 2009-08-31 10:41:55.000000000 +0200
-@@ -41,7 +41,8 @@
+--- lib/softoken/legacydb/pk11db.c.orig 2018-08-31 12:55:53 UTC
++++ lib/softoken/legacydb/pk11db.c
+@@ -8,7 +8,8 @@
+ */
- #include "pk11pars.h"
#include "lgdb.h"
-#include "mcom_db.h"
+#include <db.h>
+#include <fcntl.h>
#include "secerr.h"
+ #include "utilpars.h"
- #define FREE_CLEAR(p) if (p) { PORT_Free(p); p = NULL; }
---- lib/ckfw/dbm/ckdbm.h.orig 2009-08-31 10:46:00.000000000 +0200
-+++ lib/ckfw/dbm/ckdbm.h 2009-08-31 10:46:22.000000000 +0200
-@@ -59,7 +59,7 @@
+--- lib/ckfw/dbm/ckdbm.h.orig 2018-08-31 12:55:53 UTC
++++ lib/ckfw/dbm/ckdbm.h
+@@ -23,7 +23,7 @@
#include "ckt.h"
#endif /* CKT_H */
@@ -79,9 +78,9 @@
NSS_EXTERN_DATA NSSCKMDInstance nss_dbm_mdInstance;
---- lib/softoken/legacydb/config.mk.orig 2009-08-31 12:39:49.000000000 +0200
-+++ lib/softoken/legacydb/config.mk 2009-08-31 12:40:03.000000000 +0200
-@@ -40,7 +40,6 @@
+--- lib/softoken/legacydb/config.mk.orig 2018-08-31 12:55:53 UTC
++++ lib/softoken/legacydb/config.mk
+@@ -8,7 +8,6 @@ CRYPTOLIB=$(DIST)/lib/$(LIB_PREFIX)freebl.$(LIB_SUFFIX
EXTRA_LIBS += \
$(CRYPTOLIB) \
@@ -89,9 +88,9 @@
$(NULL)
# can't do this in manifest.mn because OS_TARGET isn't defined there.
---- lib/certdb/xauthkid.c.orig 2009-08-31 12:43:13.000000000 +0200
-+++ lib/certdb/xauthkid.c 2009-08-31 12:44:21.000000000 +0200
-@@ -39,7 +39,7 @@
+--- lib/certdb/xauthkid.c.orig 2018-08-31 12:55:53 UTC
++++ lib/certdb/xauthkid.c
+@@ -7,7 +7,7 @@
*
*/
@@ -100,10 +99,10 @@
#include "seccomon.h"
#include "secdert.h"
#include "secoidt.h"
---- lib/certdb/xbsconst.c.orig 2009-08-31 12:43:22.000000000 +0200
-+++ lib/certdb/xbsconst.c 2009-08-31 12:44:41.000000000 +0200
-@@ -38,7 +38,7 @@
- * X.509 v3 Basic Constraints Extension
+--- lib/certdb/xbsconst.c.orig 2018-08-31 12:55:53 UTC
++++ lib/certdb/xbsconst.c
+@@ -6,7 +6,7 @@
+ * X.509 v3 Basic Constraints Extension
*/
-#include "prtypes.h"
@@ -111,10 +110,10 @@
#include <limits.h> /* for LONG_MAX */
#include "seccomon.h"
#include "secdert.h"
---- lib/certdb/xconst.c.orig 2009-08-31 12:43:46.000000000 +0200
-+++ lib/certdb/xconst.c 2009-08-31 12:44:50.000000000 +0200
-@@ -38,7 +38,7 @@
- * X.509 Extension Encoding
+--- lib/certdb/xconst.c.orig 2018-08-31 12:55:53 UTC
++++ lib/certdb/xconst.c
+@@ -6,7 +6,7 @@
+ * X.509 Extension Encoding
*/
-#include "prtypes.h"
@@ -122,20 +121,20 @@
#include "seccomon.h"
#include "secdert.h"
#include "secoidt.h"
---- lib/manifest.mn~
+--- lib/manifest.mn.orig 2018-08-31 12:55:53 UTC
+++ lib/manifest.mn
-@@ -20,7 +20,7 @@ DIRS = \
- $(UTIL_SRCDIR) \
+@@ -20,7 +20,7 @@ ifndef NSS_BUILD_UTIL_ONLY
+ SOFTOKEN_SRCDIRS = \
$(FREEBL_SRCDIR) \
$(SQLITE_SRCDIR) \
- $(DBM_SRCDIR) \
+ $(NULL) \
$(SOFTOKEN_SRCDIR) \
- base dev pki \
- libpkix \
---- cmd/platlibs.mk.orig 2009-08-31 12:57:13.000000000 +0200
-+++ cmd/platlibs.mk 2009-08-31 12:57:29.000000000 +0200
-@@ -85,7 +85,7 @@
+ $(NULL)
+ ifndef NSS_BUILD_SOFTOKEN_ONLY
+--- cmd/platlibs.mk.orig 2018-08-31 12:55:53 UTC
++++ cmd/platlibs.mk
+@@ -29,7 +29,7 @@ endif # BUILD_SUN_PKG
ifdef NSS_DISABLE_DBM
DBMLIB = $(NULL)
else
@@ -143,4 +142,4 @@
+DBMLIB = $(NULL)
endif
- ifdef USE_STATIC_LIBS
+ ifeq ($(NSS_BUILD_UTIL_ONLY),1)
diff --git a/security/nss/files/patch-tests b/security/nss/files/patch-tests
index 2ff07f35a788..a5b9a3f4e38f 100644
--- a/security/nss/files/patch-tests
+++ b/security/nss/files/patch-tests
@@ -1,10 +1,12 @@
---- tests/common/init.sh Mon Apr 11 22:24:17 2005
-+++ tests/common/init.sh Fri Jul 22 16:55:36 2005
-@@ -197,5 +197,6 @@
- case $HOST in
- *\.*)
+--- tests/common/init.sh.orig 2018-08-31 12:55:53 UTC
++++ tests/common/init.sh
+@@ -366,7 +366,8 @@ if [ -z "${INIT_SOURCED}" -o "${INIT_SOURCED}" != "TRU
+ if [ -z "${DOMSUF}" ]; then
+ DOMSUF=`echo $HOST | sed -e "s/^[^.]*\.//"`
+ fi
- HOST=`echo $HOST | sed -e "s/\..*//"`
+ DOMSUF=${HOST#*.} # remove Smallest Prefix matching ``*.''
+ HOST=${HOST%%.*} # remove Largest Suffix ``.*''. See sh(1)
;;
?*)
+ ;;