aboutsummaryrefslogtreecommitdiff
path: root/security/nss
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-05-15 02:45:46 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-05-15 02:45:46 +0000
commit192a67a0d79f89529eaac61ea9e865b7cb32365e (patch)
tree50d8b700050633f3bbd14ec3c98eb843bef237e0 /security/nss
parent8d94d913b7e6b91ea4401ca181a33fe20a78117a (diff)
downloadports-192a67a0d79f89529eaac61ea9e865b7cb32365e.tar.gz
ports-192a67a0d79f89529eaac61ea9e865b7cb32365e.zip
security/nss: fix build on powerpc64le
LLVM's integrated assembler can't build ppc-gcm.s: ppc-gcm.s:642:24: error: invalid memory operand std 31,-8(SP); Use as from binutils on powerpc64le. While here correct the architecture check to also check for Linux's ppc64 - similar to the OS check in the same patch.
Diffstat (limited to 'security/nss')
-rw-r--r--security/nss/Makefile2
-rw-r--r--security/nss/files/patch-lib-freebl-Makefile5
2 files changed, 5 insertions, 2 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index a47e49da406f..c6f37513d58d 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -11,6 +11,8 @@ COMMENT= Libraries to support development of security-enabled applications
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= ${BUILD_DEPENDS_${ARCH}}
+BUILD_DEPENDS_powerpc64le= as:devel/binutils
LIB_DEPENDS= libnspr4.so:devel/nspr \
libsqlite3.so:databases/sqlite3
TEST_DEPENDS= bash:shells/bash
diff --git a/security/nss/files/patch-lib-freebl-Makefile b/security/nss/files/patch-lib-freebl-Makefile
index 0ed2694c5b67..5321d667a4b0 100644
--- a/security/nss/files/patch-lib-freebl-Makefile
+++ b/security/nss/files/patch-lib-freebl-Makefile
@@ -9,16 +9,17 @@
ifeq ($(CPU_ARCH),x86_64)
# Lower case s on mpi_amd64_common due to make implicit rules.
ASFILES = arcfour-amd64-gas.s mpi_amd64_common.s
-@@ -298,11 +298,11 @@ ifdef USE_64
+@@ -298,11 +298,12 @@ ifdef USE_64
PPC_ABI := $(shell $(CC) -dM -E - < /dev/null | awk '$$2 == "_CALL_ELF" {print $$3}')
ifeq ($(PPC_ABI),2)
ASFILES += sha512-p8.s
- ifeq ($(OS_TEST),ppc64le)
-+ ifeq ($(OS_TEST),powerpc64le)
++ ifeq (,$(filter-out powerpc64le ppc64le, $(OS_TEST)))
DEFINES += -DPPC_GCM
EXTRA_SRCS += chacha20poly1305-ppc.c ppc-gcm-wrap.c
ASFILES += chacha20-ppc64le.s ppc-gcm.s
- endif # ppc64le
++ ASFLAGS += -fno-integrated-as
+ endif # powerpc64le
endif
endif # USE_64