aboutsummaryrefslogtreecommitdiff
path: root/security/nss
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-05-15 22:26:53 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-05-15 22:26:53 +0000
commit328d95161481a639eec94591fc5cd0477c5f07e5 (patch)
tree6d4aff1adae96dda85114f6e269e8645e6319444 /security/nss
parent8541ea4c32e930f32384f266fce15c79b346f237 (diff)
downloadports-328d95161481a639eec94591fc5cd0477c5f07e5.tar.gz
ports-328d95161481a639eec94591fc5cd0477c5f07e5.zip
security/nss: back out my own changes for troubleshooting, disable VSX when VSX option is off
I had pre-build commented out. This is needed to actually fix build. NSS_DISABLE_ALTIVEC doesn't actually disable AltiVec. It only disables VSX, because NSS doesn't support AltiVec. MFH: 2020Q2 (fix build blanket)
Notes
Notes: svn path=/head/; revision=535336
Diffstat (limited to 'security/nss')
-rw-r--r--security/nss/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index e158e6e130ed..6367a38b0cd2 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -65,9 +65,10 @@ BINS= ${DIST}/${OPSYS}${OSREL}_DBG.OBJ
.if ${ARCH} == powerpc64 || ${ARCH} == powerpc
EXTRA_PATCHES= ${FILESDIR}/${ARCH}${PPC_ABI:tl}-lib_freebl_scripts_gen.sh
USES+= compiler:c++11-lang # -mcrypto -mvsx
-.else
+.if ! ${PORT_OPTIONS:MVSX}
MAKE_ENV+= NSS_DISABLE_ALTIVEC=1
.endif
+.endif
.if ${OPSYS} == FreeBSD && ${ARCH} == amd64
USE_BINUTILS= # intel-gcm.s
@@ -95,10 +96,10 @@ post-patch:
${FIND} . -name "*.c" -o -name "*.h" | \
${XARGS} ${REINPLACE_CMD} -e 's|"nspr.h"|<nspr.h>|'
-#.if ${ARCH} == powerpc64 || ${ARCH} == powerpc
-#pre-build:
-# @cd ${WRKSRC}/lib/freebl/scripts && ./gen.sh
-#.endif
+.if ${ARCH} == powerpc64 || ${ARCH} == powerpc
+pre-build:
+ @cd ${WRKSRC}/lib/freebl/scripts && ./gen.sh
+.endif
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/nss ${STAGEDIR}${PREFIX}/lib